summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-11-06 07:28:03 +0100
committerRemi Collet <fedora@famillecollet.com>2014-11-06 07:28:03 +0100
commit64988817163926903c2366b33df4355dc592525a (patch)
tree10f93e115f4a26a6b8e5d65c04b38b246426b66b
parente60a8bcf0f92ab140f782e8610058a6e1a4dccba (diff)
php-ocramius-code-generator-utils: backport stuff
-rw-r--r--Makefile4
-rw-r--r--php-ocramius-code-generator-utils.spec13
2 files changed, 14 insertions, 3 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/php-ocramius-code-generator-utils.spec b/php-ocramius-code-generator-utils.spec
index 307fede..83752a3 100644
--- a/php-ocramius-code-generator-utils.spec
+++ b/php-ocramius-code-generator-utils.spec
@@ -39,6 +39,7 @@ License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
%if %{with_tests}
# composer.json
@@ -78,6 +79,7 @@ when combined with Reflection.
%install
+rm -rf %{buildroot}
mkdir -pm 0755 %{buildroot}%{phpdir}
cp -rp src/* %{buildroot}%{phpdir}/
@@ -94,9 +96,6 @@ spl_autoload_register(function ($class) {
});
AUTOLOAD
-# Create PHPUnit config with colors turned off
-sed 's/colors="true"/colors="false"/' phpunit.xml.dist > phpunit.xml
-
%{__phpunit} \
--bootstrap autoload.php \
--include-path %{buildroot}%{phpdir}:./tests \
@@ -106,7 +105,12 @@ sed 's/colors="true"/colors="false"/' phpunit.xml.dist > phpunit.xml
%endif
+%clean
+rm -rf %{buildroot}
+
+
%files
+%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md composer.json
@@ -114,6 +118,9 @@ sed 's/colors="true"/colors="false"/' phpunit.xml.dist > phpunit.xml
%changelog
+* Thu Nov 6 2014 Remi Collet <remi@fedoraproject.org> - 0.3.0-2
+- backport for remi repository
+
* Wed Nov 05 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 0.3.0-2
- Silenced include in autoloader
- Removed debug from %%check