summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-11-06 07:25:25 +0100
committerRemi Collet <fedora@famillecollet.com>2014-11-06 07:25:25 +0100
commite60a8bcf0f92ab140f782e8610058a6e1a4dccba (patch)
treec8b645c7fa70ec2afe99cff6dae9d72110ce3949
php-ocramius-code-generator-utils: import from rawhide
-rw-r--r--php-ocramius-code-generator-utils.spec122
1 files changed, 122 insertions, 0 deletions
diff --git a/php-ocramius-code-generator-utils.spec b/php-ocramius-code-generator-utils.spec
new file mode 100644
index 0000000..307fede
--- /dev/null
+++ b/php-ocramius-code-generator-utils.spec
@@ -0,0 +1,122 @@
+#
+# RPM spec file for php-ocramius-code-generator-utils
+#
+# Copyright (c) 2014 Shawn Iwinski <shawn.iwinski@gmail.com>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+%global github_owner Ocramius
+%global github_name CodeGenerationUtils
+%global github_version 0.3.0
+%global github_commit 5d9c4e3ae36010fef22b3393b3734c84106d1d5c
+
+%global composer_vendor ocramius
+%global composer_project code-generator-utils
+
+# "php": ">=5.3.3"
+%global php_min_ver 5.3.3
+# "nikic/php-parser": "1.0.*"
+%global php_parser_min_ver 1.0.0
+%global php_parser_max_ver 1.1.0
+
+# Build using "--without tests" to disable tests
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+
+%{!?phpdir: %global phpdir %{_datadir}/php}
+%{!?__phpunit: %global __phpunit %{_bindir}/phpunit}
+
+Name: php-%{composer_vendor}-%{composer_project}
+Version: %{github_version}
+Release: 2%{?github_release}%{?dist}
+Summary: A set of code generator utilities built on top of PHP-Parsers
+
+Group: Development/Libraries
+License: MIT
+URL: https://github.com/%{github_owner}/%{github_name}
+Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+
+BuildArch: noarch
+%if %{with_tests}
+# composer.json
+BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-composer(nikic/php-parser) >= %{php_parser_min_ver}
+BuildRequires: php-composer(nikic/php-parser) < %{php_parser_max_ver}
+BuildRequires: php-phpunit-PHPUnit
+# phpcompatinfo (computed from version 0.3.0)
+BuildRequires: php-pcre
+BuildRequires: php-reflection
+BuildRequires: php-spl
+%endif
+
+# composer.json
+Requires: php(language) >= %{php_min_ver}
+Requires: php-composer(nikic/php-parser) >= %{php_parser_min_ver}
+Requires: php-composer(nikic/php-parser) < %{php_parser_max_ver}
+# phpcompatinfo (computed from version 0.3.0)
+Requires: php-pcre
+Requires: php-reflection
+Requires: php-spl
+
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+
+%description
+A set of code generator utilities built on top of PHP-Parsers that ease its use
+when combined with Reflection.
+
+
+%prep
+%setup -qn %{github_name}-%{github_commit}
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+mkdir -pm 0755 %{buildroot}%{phpdir}
+cp -rp src/* %{buildroot}%{phpdir}/
+
+
+%check
+%if %{with_tests}
+# Create autoloader
+cat > autoload.php <<'AUTOLOAD'
+<?php
+
+spl_autoload_register(function ($class) {
+ $src = str_replace('\\', '/', $class).'.php';
+ @include_once $src;
+});
+AUTOLOAD
+
+# Create PHPUnit config with colors turned off
+sed 's/colors="true"/colors="false"/' phpunit.xml.dist > phpunit.xml
+
+%{__phpunit} \
+ --bootstrap autoload.php \
+ --include-path %{buildroot}%{phpdir}:./tests \
+ -d date.timezone="UTC"
+%else
+: Tests skipped
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md composer.json
+%{phpdir}/CodeGenerationUtils
+
+
+%changelog
+* Wed Nov 05 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 0.3.0-2
+- Silenced include in autoloader
+- Removed debug from %%check
+
+* Mon Oct 27 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 0.3.0-1
+- Initial package