summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json9
-rw-r--r--php-nikic-fast-route-tests-autoloader.php10
-rw-r--r--php-nikic-fast-route.spec75
3 files changed, 43 insertions, 51 deletions
diff --git a/composer.json b/composer.json
index 62aad22..fb446a2 100644
--- a/composer.json
+++ b/composer.json
@@ -9,13 +9,16 @@
"email": "nikic@php.net"
}
],
- "require": {
- "php": ">=5.4.0"
- },
"autoload": {
"psr-4": {
"FastRoute\\": "src/"
},
"files": ["src/functions.php"]
+ },
+ "require": {
+ "php": ">=5.4.0"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^4.8.35|~5.7"
}
}
diff --git a/php-nikic-fast-route-tests-autoloader.php b/php-nikic-fast-route-tests-autoloader.php
deleted file mode 100644
index c484d51..0000000
--- a/php-nikic-fast-route-tests-autoloader.php
+++ /dev/null
@@ -1,10 +0,0 @@
-<?php
-
-spl_autoload_register(function($class) {
- if (strpos($class, 'FastRoute\\') === 0 && strcasecmp(substr($class, -4), 'Test') === 0) {
- $name = substr($class, strlen('FastRoute'));
- require __DIR__ . strtr($name, '\\', DIRECTORY_SEPARATOR) . '.php';
- }
-});
-
-require_once 'BUILDROOT_PATH/bootstrap.php';
diff --git a/php-nikic-fast-route.spec b/php-nikic-fast-route.spec
index 8f4aa53..faa1513 100644
--- a/php-nikic-fast-route.spec
+++ b/php-nikic-fast-route.spec
@@ -7,43 +7,45 @@
#
# Please preserve changelog entries
-%global gh_commit b5f95749071c82a8e0f58586987627054400cdf6
+%bcond_without tests
+
+%global gh_commit 181d480e08d9476e61381e04a71b34dc0432e812
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nikic
%global gh_project FastRoute
%global pk_project fast-route
%global php_home %{_datadir}/php
-%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{pk_project}
-Version: 1.2.0
-Release: 1%{?dist}
+Version: 1.3.0
+Release: 6%{?dist}
Summary: Fast implementation of a regular expression based router
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
-Source1: php-%{gh_owner}-%{pk_project}-tests-autoloader.php
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
# For tests
BuildRequires: php(language) >= 5.4
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "~4.0"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+# "phpunit/phpunit": "^4.8.35|~5.7"
+BuildRequires: php-composer(phpunit/phpunit) >= 4.8.35
%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
# "php": ">=5.4",
Requires: php(language) >= 5.4
-# From phpcompatinfo 5.0.0 report for version 1.0.0
+# From phpcompatinfo report for version 1.3.0
Requires: php-pcre
Requires: php-spl
+# Autoloader
+BuildRequires: php-composer(fedora/autoloader)
Provides: php-composer(%{gh_owner}/%{pk_project}) = %{version}
@@ -54,7 +56,7 @@ Fast implementation of a regular expression based router.
Documentation:
http://nikic.github.io/2014/02/18/Fast-request-routing-using-regular-expressions.html
-Autoloader: %{php_home}/%{gh_project}/bootstrap.php
+Autoloader: %{php_home}/%{gh_project}/autoload.php
%prep
@@ -62,52 +64,43 @@ Autoloader: %{php_home}/%{gh_project}/bootstrap.php
%build
-#Nothing to build
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+require_once __DIR__ . '/functions.php';
+EOF
+phpab --template fedora --output test/bootstrap.php test
+cat << 'EOF' | tee -a test/bootstrap.php
+require_once '%{buildroot}%{php_home}/%{gh_project}/autoload.php';
+EOF
-%install
-rm -rf %{buildroot}
+%install
#: Library
mkdir -p %{buildroot}%{php_home}
cp -pr src %{buildroot}%{php_home}/%{gh_project}
%check
-%if %{with_tests}
-#ensure tests are not ran against local sources
+%if %{with tests}
+# ensure tests are not ran against local sources
rm -rf src
-cp %{SOURCE1} test/bootstrap.php
-sed -e "s|BUILDROOT_PATH|%{buildroot}/%{php_home}/%{gh_project}|" -i test/bootstrap.php
: Run upstream test suite
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in php php72 php73 php74 php80; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -116,6 +109,12 @@ rm -rf %{buildroot}
%changelog
+* Mon Dec 21 2020 Remi Collet <remi@remirepo.net> - 1.3.0-6
+- add classmap autoloader
+
+* Wed Feb 14 2018 Remi Collet <remi@remirepo.net> - 1.3.0-1
+- Update to 1.3.0
+
* Fri Feb 10 2017 Johan Cwiklinski <johan AT x-tnd DOT be> - 1.2.0-1
- Last upstream release