summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-21 16:10:12 +0100
committerRemi Collet <remi@remirepo.net>2020-12-21 16:10:12 +0100
commit45665b6eafb4d0eebf72a5471e8b516b8bac6cab (patch)
tree12753404158d4fd9b98785270d43c8d31613d7ed
parent757fc03beb92fa446ca01323b4ea0abef9e3fe0d (diff)
add classmap autoloaderHEADmaster
-rw-r--r--php-nikic-fast-route-tests-autoloader.php10
-rw-r--r--php-nikic-fast-route.spec38
2 files changed, 26 insertions, 22 deletions
diff --git a/php-nikic-fast-route-tests-autoloader.php b/php-nikic-fast-route-tests-autoloader.php
deleted file mode 100644
index c484d51..0000000
--- a/php-nikic-fast-route-tests-autoloader.php
+++ /dev/null
@@ -1,10 +0,0 @@
-<?php
-
-spl_autoload_register(function($class) {
- if (strpos($class, 'FastRoute\\') === 0 && strcasecmp(substr($class, -4), 'Test') === 0) {
- $name = substr($class, strlen('FastRoute'));
- require __DIR__ . strtr($name, '\\', DIRECTORY_SEPARATOR) . '.php';
- }
-});
-
-require_once 'BUILDROOT_PATH/bootstrap.php';
diff --git a/php-nikic-fast-route.spec b/php-nikic-fast-route.spec
index a1e86ea..faa1513 100644
--- a/php-nikic-fast-route.spec
+++ b/php-nikic-fast-route.spec
@@ -7,26 +7,26 @@
#
# Please preserve changelog entries
+%bcond_without tests
+
%global gh_commit 181d480e08d9476e61381e04a71b34dc0432e812
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nikic
%global gh_project FastRoute
%global pk_project fast-route
%global php_home %{_datadir}/php
-%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{pk_project}
Version: 1.3.0
-Release: 1%{?dist}
+Release: 6%{?dist}
Summary: Fast implementation of a regular expression based router
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
-Source1: php-%{gh_owner}-%{pk_project}-tests-autoloader.php
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
# For tests
BuildRequires: php(language) >= 5.4
BuildRequires: php-pcre
@@ -35,13 +35,17 @@ BuildRequires: php-spl
# "phpunit/phpunit": "^4.8.35|~5.7"
BuildRequires: php-composer(phpunit/phpunit) >= 4.8.35
%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
# "php": ">=5.4",
Requires: php(language) >= 5.4
-# From phpcompatinfo 5.0.0 report for version 1.0.0
+# From phpcompatinfo report for version 1.3.0
Requires: php-pcre
Requires: php-spl
+# Autoloader
+BuildRequires: php-composer(fedora/autoloader)
Provides: php-composer(%{gh_owner}/%{pk_project}) = %{version}
@@ -52,7 +56,7 @@ Fast implementation of a regular expression based router.
Documentation:
http://nikic.github.io/2014/02/18/Fast-request-routing-using-regular-expressions.html
-Autoloader: %{php_home}/%{gh_project}/bootstrap.php
+Autoloader: %{php_home}/%{gh_project}/autoload.php
%prep
@@ -60,7 +64,15 @@ Autoloader: %{php_home}/%{gh_project}/bootstrap.php
%build
-#Nothing to build
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+require_once __DIR__ . '/functions.php';
+EOF
+
+phpab --template fedora --output test/bootstrap.php test
+cat << 'EOF' | tee -a test/bootstrap.php
+require_once '%{buildroot}%{php_home}/%{gh_project}/autoload.php';
+EOF
%install
@@ -70,15 +82,13 @@ cp -pr src %{buildroot}%{php_home}/%{gh_project}
%check
-%if %{with_tests}
-#ensure tests are not ran against local sources
+%if %{with tests}
+# ensure tests are not ran against local sources
rm -rf src
-cp %{SOURCE1} test/bootstrap.php
-sed -e "s|BUILDROOT_PATH|%{buildroot}/%{php_home}/%{gh_project}|" -i test/bootstrap.php
: Run upstream test suite
ret=0
-for cmd in php php70 php71 php72; do
+for cmd in php php72 php73 php74 php80; do
if which $cmd; then
$cmd %{_bindir}/phpunit --verbose || ret=1
fi
@@ -90,6 +100,7 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -98,6 +109,9 @@ exit $ret
%changelog
+* Mon Dec 21 2020 Remi Collet <remi@remirepo.net> - 1.3.0-6
+- add classmap autoloader
+
* Wed Feb 14 2018 Remi Collet <remi@remirepo.net> - 1.3.0-1
- Update to 1.3.0