summaryrefslogtreecommitdiffstats
path: root/php-myclabs-php-enum.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-27 08:42:47 +0200
committerRemi Collet <remi@remirepo.net>2017-06-27 08:42:47 +0200
commit59287ce7c13922b93c124c0f27d5d115e3226fa8 (patch)
tree28878c2294eeff7ac6a5deb41a745788bfc9a218 /php-myclabs-php-enum.spec
New package
Diffstat (limited to 'php-myclabs-php-enum.spec')
-rw-r--r--php-myclabs-php-enum.spec124
1 files changed, 124 insertions, 0 deletions
diff --git a/php-myclabs-php-enum.spec b/php-myclabs-php-enum.spec
new file mode 100644
index 0000000..8976866
--- /dev/null
+++ b/php-myclabs-php-enum.spec
@@ -0,0 +1,124 @@
+# remirepo/fedora spec file for php-myclabs-php-enum
+#
+# Copyright (c) 2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 61f4a24da5be216301447f3278ea6562609d61f5
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner myclabs
+%global gh_project php-enum
+
+%global pk_vendor %{gh_owner}
+%global pk_project %{gh_project}
+
+%global ns_vendor MyCLabs
+%global ns_project Enum
+%global php_home %{_datadir}/php
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-%{pk_vendor}-%{pk_project}
+Version: 1.5.1
+Release: 1%{?dist}
+Summary: PHP Enum implementation
+
+Group: Development/Libraries
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+# git snashop to get upstream test suite
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+%if %{with_tests}
+# For tests
+BuildRequires: php(language) >= 5.3
+BuildRequires: php-reflection
+BuildRequires: php-spl
+# From composer.json, "require-dev": {
+# "phpunit/phpunit": "4.*",
+# "squizlabs/php_codesniffer": "1.*"
+BuildRequires: php-composer(phpunit/phpunit)
+# Required by autoloader
+BuildRequires: php-composer(fedora/autoloader)
+%endif
+
+# From composer.json, "require": {
+# "php": ">=5.3"
+Requires: php(language) >= 5.3
+# From phpcompatinfo report for version 1.5.1
+Requires: php-reflection
+Requires: php-spl
+# Required by autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+PHP Enum implementation inspired from SplEnum.
+
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+# https://github.com/myclabs/php-enum/pull/55
+chmod -x src/*php *md composer.json
+
+cat << 'EOF' | tee src/autoload.php
+<?php
+/* Autoloader for %{name} and its dependencies */
+require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\%{ns_project}\\', __DIR__);
+EOF
+
+
+%build
+# Empty build section, most likely nothing required.
+
+
+%install
+: Library
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
+cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\Tests\\%{ns_project}\\', __DIR__ . '/../tests');
+EOF
+
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc README.md
+%dir %{php_home}/%{ns_vendor}
+ %{php_home}/%{ns_vendor}/%{ns_project}
+
+
+%changelog
+* Tue Jun 27 2017 Remi Collet <remi@remirepo.net> - 1.5.1-1
+- initial package, version 1.5.1
+- open https://github.com/myclabs/php-enum/pull/55 - perms
+- open https://github.com/myclabs/php-enum/pull/56 - phpunit