summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-27 08:42:47 +0200
committerRemi Collet <remi@remirepo.net>2017-06-27 08:42:47 +0200
commit59287ce7c13922b93c124c0f27d5d115e3226fa8 (patch)
tree28878c2294eeff7ac6a5deb41a745788bfc9a218
New package
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--composer.json31
-rwxr-xr-xmakesrc.sh27
-rw-r--r--php-myclabs-php-enum.spec124
5 files changed, 193 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..87a6119
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,31 @@
+{
+ "name": "myclabs/php-enum",
+ "type": "library",
+ "description": "PHP Enum implementation",
+ "keywords": ["enum"],
+ "homepage": "http://github.com/myclabs/php-enum",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "PHP Enum contributors",
+ "homepage": "https://github.com/myclabs/php-enum/graphs/contributors"
+ }
+ ],
+ "autoload": {
+ "psr-4": {
+ "MyCLabs\\Enum\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "MyCLabs\\Tests\\Enum\\": "tests/"
+ }
+ },
+ "require": {
+ "php": ">=5.3"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "4.*",
+ "squizlabs/php_codesniffer": "1.*"
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..dfd5c2a
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,27 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-myclabs-php-enum.spec b/php-myclabs-php-enum.spec
new file mode 100644
index 0000000..8976866
--- /dev/null
+++ b/php-myclabs-php-enum.spec
@@ -0,0 +1,124 @@
+# remirepo/fedora spec file for php-myclabs-php-enum
+#
+# Copyright (c) 2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 61f4a24da5be216301447f3278ea6562609d61f5
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner myclabs
+%global gh_project php-enum
+
+%global pk_vendor %{gh_owner}
+%global pk_project %{gh_project}
+
+%global ns_vendor MyCLabs
+%global ns_project Enum
+%global php_home %{_datadir}/php
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-%{pk_vendor}-%{pk_project}
+Version: 1.5.1
+Release: 1%{?dist}
+Summary: PHP Enum implementation
+
+Group: Development/Libraries
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+# git snashop to get upstream test suite
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+%if %{with_tests}
+# For tests
+BuildRequires: php(language) >= 5.3
+BuildRequires: php-reflection
+BuildRequires: php-spl
+# From composer.json, "require-dev": {
+# "phpunit/phpunit": "4.*",
+# "squizlabs/php_codesniffer": "1.*"
+BuildRequires: php-composer(phpunit/phpunit)
+# Required by autoloader
+BuildRequires: php-composer(fedora/autoloader)
+%endif
+
+# From composer.json, "require": {
+# "php": ">=5.3"
+Requires: php(language) >= 5.3
+# From phpcompatinfo report for version 1.5.1
+Requires: php-reflection
+Requires: php-spl
+# Required by autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+PHP Enum implementation inspired from SplEnum.
+
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+# https://github.com/myclabs/php-enum/pull/55
+chmod -x src/*php *md composer.json
+
+cat << 'EOF' | tee src/autoload.php
+<?php
+/* Autoloader for %{name} and its dependencies */
+require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\%{ns_project}\\', __DIR__);
+EOF
+
+
+%build
+# Empty build section, most likely nothing required.
+
+
+%install
+: Library
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
+cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\Tests\\%{ns_project}\\', __DIR__ . '/../tests');
+EOF
+
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc README.md
+%dir %{php_home}/%{ns_vendor}
+ %{php_home}/%{ns_vendor}/%{ns_project}
+
+
+%changelog
+* Tue Jun 27 2017 Remi Collet <remi@remirepo.net> - 1.5.1-1
+- initial package, version 1.5.1
+- open https://github.com/myclabs/php-enum/pull/55 - perms
+- open https://github.com/myclabs/php-enum/pull/56 - phpunit