summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-08-12 04:50:03 +0200
committerRemi Collet <remi@remirepo.net>2019-08-12 04:50:03 +0200
commit62d8ed44880758a49e9a11b77fdd60eb886bebc6 (patch)
tree428c707fb65654fce75c8f53b168889d9f5ba690
parent8d99771b88524db2bf811b7ab0fb4ed23835625f (diff)
v1.9.3
-rwxr-xr-xmakesrc.sh2
-rw-r--r--php-myclabs-deep-copy.spec9
2 files changed, 7 insertions, 4 deletions
diff --git a/makesrc.sh b/makesrc.sh
index c047df5..dfd5c2a 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -1,6 +1,6 @@
#!/bin/bash
-NAME=$(sed -n '/^Name:/{s/.* //;p}' *.spec)
+NAME=$(basename $PWD)
OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
diff --git a/php-myclabs-deep-copy.spec b/php-myclabs-deep-copy.spec
index ab6c337..a0e8cc3 100644
--- a/php-myclabs-deep-copy.spec
+++ b/php-myclabs-deep-copy.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit e6828efaba2c9b79f4499dae1d66ef8bfa7b2b72
+%global gh_commit 007c053ae6f31bba39dfa19a7726f56e9763bbea
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner myclabs
%global gh_project DeepCopy
@@ -21,7 +21,7 @@
%global with_tests 0
%endif
Name: php-myclabs-deep-copy%{major}
-Version: 1.9.1
+Version: 1.9.3
Release: 1%{?dist}
Summary: Create deep copies (clones) of your objects
@@ -106,7 +106,7 @@ require_once '%{php_home}/Doctrine/Common/autoload.php';
EOF
ret=0
-for cmd in php php71 php72 php73; do
+for cmd in php php71 php72 php73 php74; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{gh_project}%{major}/autoload.php \
%{_bindir}/phpunit7 --verbose || ret=1
@@ -128,6 +128,9 @@ exit $ret
%changelog
+* Mon Aug 12 2019 Remi Collet <remi@remirepo.net> - 1.9.3-1
+- update to 1.9.3 (no change)
+
* Fri Jun 7 2019 Remi Collet <remi@remirepo.net> - 1.9.1-1
- php-myclabs-deep-copy19 for EL 6 and 7