summaryrefslogtreecommitdiffstats
path: root/makesrc.sh
diff options
context:
space:
mode:
Diffstat (limited to 'makesrc.sh')
-rwxr-xr-xmakesrc.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/makesrc.sh b/makesrc.sh
index c047df5..dfd5c2a 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -1,6 +1,6 @@
#!/bin/bash
-NAME=$(sed -n '/^Name:/{s/.* //;p}' *.spec)
+NAME=$(basename $PWD)
OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)