summaryrefslogtreecommitdiffstats
path: root/php-monolog2.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-03-14 15:30:56 +0100
committerRemi Collet <remi@php.net>2022-03-14 15:30:56 +0100
commit74f0ed32d1b487237e96acf754d7e2c84a0973b5 (patch)
tree2994779c22466359cd198a3d7bad7d257ed41ded /php-monolog2.spec
parentf2d4830085cb101ef694a30255aa54fa2d7878fe (diff)
update to 2.4.0
Diffstat (limited to 'php-monolog2.spec')
-rw-r--r--php-monolog2.spec17
1 files changed, 10 insertions, 7 deletions
diff --git a/php-monolog2.spec b/php-monolog2.spec
index 0a1b255..2a5aba8 100644
--- a/php-monolog2.spec
+++ b/php-monolog2.spec
@@ -11,8 +11,8 @@
%global github_owner Seldaek
%global github_name monolog
-%global github_version 2.3.5
-%global github_commit fd4380d6fc37626e2f799f29d91195040137eba9
+%global github_version 2.4.0
+%global github_commit d7fd7450628561ba697b7097d86db72662f54aef
%global composer_vendor monolog
%global composer_project monolog
@@ -55,12 +55,10 @@ BuildRequires: phpunit8 >= 8.5
%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
BuildRequires: (php-composer(psr/log) >= %{psrlog_min_ver} with php-composer(psr/log) < %{psrlog_max_ver})
BuildRequires: (php-composer(swiftmailer/swiftmailer) >= %{swift_min_ver} with php-composer(swiftmailer/swiftmailer) < %{swift_max_ver})
-BuildRequires: (php-composer(aws/aws-sdk-php) >= %{aws_min_ver} with php-composer(aws/aws-sdk-php) < %{aws_max_ver})
-# remirepo:5
+# remirepo:4
%else
BuildRequires: php-PsrLog
BuildRequires: php-swiftmailer6
-BuildRequires: php-aws-sdk3
%endif
## optional
## phpcompatinfo (computed from version 2.1.1)
@@ -203,9 +201,11 @@ rm -f tests/Monolog/Handler/RollbarHandlerTest.php
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit8)
-for PHP_EXEC in "" php73 php80 php81; do
+for PHP_EXEC in "" php80 php81; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC $PHPUNIT --verbose || RETURN_CODE=1
+ $PHP_EXEC $PHPUNIT \
+ --filter '^((?!(testWriteInvalidResource)).)*$' \
+ --verbose || RETURN_CODE=1
fi
rm -rf .hg
done
@@ -226,6 +226,9 @@ exit $RETURN_CODE
%changelog
+* Mon Mar 14 2022 Remi Collet <remi@remirepo.net> - 2.4.0-1
+- update to 2.4.0
+
* Mon Oct 4 2021 Remi Collet <remi@remirepo.net> - 2.3.5-1
- update to 2.3.5