summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json6
-rw-r--r--php-monolog2.spec17
2 files changed, 13 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 020d278..b151c65 100644
--- a/composer.json
+++ b/composer.json
@@ -27,7 +27,7 @@
"phpspec/prophecy": "^1.6.1",
"phpunit/phpunit": "^8.5",
"predis/predis": "^1.1",
- "rollbar/rollbar": "^1.3",
+ "rollbar/rollbar": "^1.3 || ^2 || ^3",
"ruflin/elastica": ">=0.90@dev",
"swiftmailer/swiftmailer": "^5.3|^6.0",
"phpstan/phpstan": "^0.12.91"
@@ -64,8 +64,8 @@
}
},
"scripts": {
- "test": "vendor/bin/phpunit",
- "phpstan": "vendor/bin/phpstan analyse"
+ "test": "@php vendor/bin/phpunit",
+ "phpstan": "@php vendor/bin/phpstan analyse"
},
"config": {
"lock": false,
diff --git a/php-monolog2.spec b/php-monolog2.spec
index 0a1b255..2a5aba8 100644
--- a/php-monolog2.spec
+++ b/php-monolog2.spec
@@ -11,8 +11,8 @@
%global github_owner Seldaek
%global github_name monolog
-%global github_version 2.3.5
-%global github_commit fd4380d6fc37626e2f799f29d91195040137eba9
+%global github_version 2.4.0
+%global github_commit d7fd7450628561ba697b7097d86db72662f54aef
%global composer_vendor monolog
%global composer_project monolog
@@ -55,12 +55,10 @@ BuildRequires: phpunit8 >= 8.5
%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
BuildRequires: (php-composer(psr/log) >= %{psrlog_min_ver} with php-composer(psr/log) < %{psrlog_max_ver})
BuildRequires: (php-composer(swiftmailer/swiftmailer) >= %{swift_min_ver} with php-composer(swiftmailer/swiftmailer) < %{swift_max_ver})
-BuildRequires: (php-composer(aws/aws-sdk-php) >= %{aws_min_ver} with php-composer(aws/aws-sdk-php) < %{aws_max_ver})
-# remirepo:5
+# remirepo:4
%else
BuildRequires: php-PsrLog
BuildRequires: php-swiftmailer6
-BuildRequires: php-aws-sdk3
%endif
## optional
## phpcompatinfo (computed from version 2.1.1)
@@ -203,9 +201,11 @@ rm -f tests/Monolog/Handler/RollbarHandlerTest.php
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit8)
-for PHP_EXEC in "" php73 php80 php81; do
+for PHP_EXEC in "" php80 php81; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC $PHPUNIT --verbose || RETURN_CODE=1
+ $PHP_EXEC $PHPUNIT \
+ --filter '^((?!(testWriteInvalidResource)).)*$' \
+ --verbose || RETURN_CODE=1
fi
rm -rf .hg
done
@@ -226,6 +226,9 @@ exit $RETURN_CODE
%changelog
+* Mon Mar 14 2022 Remi Collet <remi@remirepo.net> - 2.4.0-1
+- update to 2.4.0
+
* Mon Oct 4 2021 Remi Collet <remi@remirepo.net> - 2.3.5-1
- update to 2.3.5