summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-03-02 14:56:20 +0100
committerRemi Collet <remi@php.net>2023-03-02 14:56:20 +0100
commite9bad46e12143269630bdf99304b6f7381ccbac1 (patch)
tree55e928d86fc037be8cabc8e8f6fddaa2ef396595
parent16edd261c907a49bf877ffac7ceeffcfbee52a61 (diff)
update to 2.16.0HEADmaster
raise dependency on PHP 8.1
-rw-r--r--composer.json12
-rw-r--r--php-laminas-xmlrpc.spec36
2 files changed, 26 insertions, 22 deletions
diff --git a/composer.json b/composer.json
index 12df4be..433900a 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "8.0.99"
+ "php": "8.1.99"
},
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
@@ -27,7 +27,7 @@
"extra": {
},
"require": {
- "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
+ "php": "~8.1.0 || ~8.2.0",
"laminas/laminas-code": "^4.4",
"laminas/laminas-http": "^2.15",
"laminas/laminas-math": "^3.4.0",
@@ -36,10 +36,10 @@
"laminas/laminas-xml": "^1.4.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~2.4.0",
- "phpunit/phpunit": "^9.5.26",
- "psalm/plugin-phpunit": "^0.18.0",
- "vimeo/psalm": "^4.29.0"
+ "laminas/laminas-coding-standard": "~2.5.0",
+ "phpunit/phpunit": "^10.0",
+ "psalm/plugin-phpunit": "^0.18.4",
+ "vimeo/psalm": "^5.4"
},
"suggest": {
"laminas/laminas-cache": "To support Laminas\\XmlRpc\\Server\\Cache usage"
diff --git a/php-laminas-xmlrpc.spec b/php-laminas-xmlrpc.spec
index 6da7133..0ca150e 100644
--- a/php-laminas-xmlrpc.spec
+++ b/php-laminas-xmlrpc.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-xmlrpc
#
-# Copyright (c) 2015-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2015-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 101362ec6a542f5c4d034d7541a89ee7bde5fd51
+%global gh_commit 32f680741f7508045f61f0c6bc81c92994ac8300
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-xmlrpc
@@ -22,11 +22,11 @@
%endif
Name: php-%{gh_project}
-Version: 2.15.0
+Version: 2.16.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
-License: BSD
+License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 8.0
+BuildRequires: php(language) >= 8.1
BuildRequires: php-simplexml
BuildRequires: php-date
BuildRequires: php-dom
@@ -53,10 +53,10 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.10
BuildRequires: (php-autoloader(%{gh_owner}/laminas-xml) >= 1.4 with php-autoloader(%{gh_owner}/laminas-xml) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~2.4.0",
-# "phpunit/phpunit": "^9.5.26",
-# "psalm/plugin-phpunit": "^0.18.0",
-# "vimeo/psalm": "^4.29.0"
+# "laminas/laminas-coding-standard": "~2.5.0",
+# "phpunit/phpunit": "^10.0",
+# "psalm/plugin-phpunit": "^0.18.4",
+# "vimeo/psalm": "^5.4"
# remirepo:9
%else
BuildRequires: php-laminas-code4
@@ -67,21 +67,21 @@ BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-xml
BuildRequires: php-laminas-zendframework-bridge
%endif
-%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.26
+%global phpunit %{_bindir}/phpunit10
+BuildRequires: phpunit10
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
+# "php": "~8.1.0 || ~8.2.0",
# "laminas/laminas-code": "^4.4",
# "laminas/laminas-http": "^2.15",
# "laminas/laminas-math": "^3.4.0",
# "laminas/laminas-server": "^2.11",
# "laminas/laminas-stdlib": "^3.10.1",
# "laminas/laminas-xml": "^1.4.0"
-Requires: php(language) >= 8.0
+Requires: php(language) >= 8.1
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -202,10 +202,10 @@ exit (class_exists("\\Zend\\%{library}\\Server") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php81 php82; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit10} || ret=1
fi
done
exit $ret
@@ -225,6 +225,10 @@ exit $ret
%changelog
+* Thu Mar 2 2023 Remi Collet <remi@remirepo.net> - 2.16.0-1
+- update to 2.16.0
+- raise dependency on PHP 8.1
+
* Wed Nov 16 2022 Remi Collet <remi@remirepo.net> - 2.15.0-1
- update to 2.15.0
- raise dependency on PHP 8.0