summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-16 14:01:48 +0100
committerRemi Collet <remi@php.net>2022-11-16 14:01:48 +0100
commit16edd261c907a49bf877ffac7ceeffcfbee52a61 (patch)
tree41d39e4887f1165b8b5c90c190a4dbd0c6ab8479
parentc69145a2f681beb125b8e1802ea1c3eea036095d (diff)
update to 2.15.0
raise dependency on PHP 8.0
-rw-r--r--composer.json10
-rw-r--r--php-laminas-xmlrpc.spec24
2 files changed, 19 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index 99cb32c..12df4be 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "7.4.99"
+ "php": "8.0.99"
},
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
@@ -27,7 +27,7 @@
"extra": {
},
"require": {
- "php": "^7.4 || ~8.0.0 || ~8.1.0",
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
"laminas/laminas-code": "^4.4",
"laminas/laminas-http": "^2.15",
"laminas/laminas-math": "^3.4.0",
@@ -37,9 +37,9 @@
},
"require-dev": {
"laminas/laminas-coding-standard": "~2.4.0",
- "phpunit/phpunit": "^9.5.8",
- "psalm/plugin-phpunit": "^0.17.0",
- "vimeo/psalm": "^4.24"
+ "phpunit/phpunit": "^9.5.26",
+ "psalm/plugin-phpunit": "^0.18.0",
+ "vimeo/psalm": "^4.29.0"
},
"suggest": {
"laminas/laminas-cache": "To support Laminas\\XmlRpc\\Server\\Cache usage"
diff --git a/php-laminas-xmlrpc.spec b/php-laminas-xmlrpc.spec
index d946f63..6da7133 100644
--- a/php-laminas-xmlrpc.spec
+++ b/php-laminas-xmlrpc.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 65674a9a39a7948c1555038c3808c9791a06823c
+%global gh_commit 101362ec6a542f5c4d034d7541a89ee7bde5fd51
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-xmlrpc
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.14.0
+Version: 2.15.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.0
BuildRequires: php-simplexml
BuildRequires: php-date
BuildRequires: php-dom
@@ -54,9 +54,9 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-xml) >= 1.4
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~2.4.0",
-# "phpunit/phpunit": "^9.5.8",
-# "psalm/plugin-phpunit": "^0.17.0",
-# "vimeo/psalm": "^4.24"
+# "phpunit/phpunit": "^9.5.26",
+# "psalm/plugin-phpunit": "^0.18.0",
+# "vimeo/psalm": "^4.29.0"
# remirepo:9
%else
BuildRequires: php-laminas-code4
@@ -68,20 +68,20 @@ BuildRequires: php-laminas-xml
BuildRequires: php-laminas-zendframework-bridge
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.8
+BuildRequires: phpunit9 >= 9.5.26
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "laminas/laminas-code": "^4.4",
# "laminas/laminas-http": "^2.15",
# "laminas/laminas-math": "^3.4.0",
# "laminas/laminas-server": "^2.11",
# "laminas/laminas-stdlib": "^3.10.1",
# "laminas/laminas-xml": "^1.4.0"
-Requires: php(language) >= 7.3
+Requires: php(language) >= 8.0
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -202,7 +202,7 @@ exit (class_exists("\\Zend\\%{library}\\Server") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -225,6 +225,10 @@ exit $ret
%changelog
+* Wed Nov 16 2022 Remi Collet <remi@remirepo.net> - 2.15.0-1
+- update to 2.15.0
+- raise dependency on PHP 8.0
+
* Thu Sep 22 2022 Remi Collet <remi@remirepo.net> - 2.14.0-1
- update to 2.14.0
- raise dependency on laminas-stdlib 3.10.1