summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-08 13:06:11 +0100
committerRemi Collet <remi@remirepo.net>2020-01-08 13:06:11 +0100
commitb2a8fab2b5fb994ee33fdfb45bcf1f0aa6bf9318 (patch)
tree6be14ca9955387d6f9d92b24cb692f1c259518b9
duplicate ZF
-rw-r--r--.gitignore8
-rw-r--r--Makefile3
-rw-r--r--composer.json54
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-laminas-xml.spec133
5 files changed, 226 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..045b1ec
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,54 @@
+{
+ "name": "zendframework/zendxml",
+ "description": "Utility library for XML usage, best practices, and security in PHP",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zf",
+ "zendframework",
+ "xml",
+ "security"
+ ],
+ "support": {
+ "issues": "https://github.com/zendframework/ZendXml/issues",
+ "source": "https://github.com/zendframework/ZendXml",
+ "rss": "https://github.com/zendframework/ZendXml/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
+ },
+ "require": {
+ "php": "^5.6 || ^7.0"
+ },
+ "require-dev": {
+ "zendframework/zend-coding-standard": "~1.0.0",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
+ },
+ "autoload": {
+ "psr-4": {
+ "ZendXml\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendXmlTest\\": "test/"
+ }
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.2.x-dev",
+ "dev-develop": "1.3.x-dev"
+ }
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..87d223d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-laminas-xml.spec b/php-laminas-xml.spec
new file mode 100644
index 0000000..fe3b197
--- /dev/null
+++ b/php-laminas-xml.spec
@@ -0,0 +1,133 @@
+# remirepo/Fedora spec file for php-zendframework-zendxml
+#
+# Copyright (c) 2015-2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit eceab37a591c9e140772a1470338258857339e00
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zendxml
+%global php_home %{_datadir}/php
+%global library ZendXml
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.2.0
+Release: 1%{?dist}
+Summary: Zend Framework %{library} component
+
+License: BSD
+URL: https://framework.zend.com/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.3.3
+BuildRequires: php-simplexml
+BuildRequires: php-dom
+BuildRequires: php-libxml
+BuildRequires: php-pcre
+BuildRequires: php-spl
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^3.7 || ^4.0",
+# "squizlabs/php_codesniffer": "~1.5"
+BuildRequires: php-composer(phpunit/phpunit) >= 3.7
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^5.3.3 || ^7.0"
+Requires: php(language) >= 5.3.3
+# From phpcompatinfo report for version 1.0.1
+Requires: php-simplexml
+Requires: php-dom
+Requires: php-libxml
+Requires: php-pcre
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = 1:%{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+An utility component for XML usage and best practices in PHP.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+: Create autoloader
+phpab --template fedora --output src/autoload.php src
+
+
+%install
+mkdir -p %{buildroot}%{php_home}
+cp -pr src %{buildroot}%{php_home}/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\Xml\\', dirname(__DIR__) . '/test');
+EOF
+
+ret=0
+for cmd in php php56 php70 php71 php72 php73 php74; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{php_home}/%{library}
+
+
+%changelog
+* Wed Jan 23 2019 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update to 1.2.0
+
+* Thu May 3 2018 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+
+* Wed Dec 6 2017 Remi Collet <remi@remirepo.net> - 1.0.2-5
+- switch from zend-loader to fedora/autoloader
+
+* Sat Jun 11 2016 Shawn Iwinski <shawn@iwin.ski> - 1.0.2-2
+- Allow F22 / EPEL7 / EPEL6 (ZF 2.4)
+
+* Fri Feb 5 2016 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
+- update to 1.0.2
+
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
+- initial package