summaryrefslogtreecommitdiffstats
path: root/php-laminas-xml.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-xml.spec')
-rw-r--r--php-laminas-xml.spec133
1 files changed, 133 insertions, 0 deletions
diff --git a/php-laminas-xml.spec b/php-laminas-xml.spec
new file mode 100644
index 0000000..fe3b197
--- /dev/null
+++ b/php-laminas-xml.spec
@@ -0,0 +1,133 @@
+# remirepo/Fedora spec file for php-zendframework-zendxml
+#
+# Copyright (c) 2015-2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit eceab37a591c9e140772a1470338258857339e00
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zendxml
+%global php_home %{_datadir}/php
+%global library ZendXml
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.2.0
+Release: 1%{?dist}
+Summary: Zend Framework %{library} component
+
+License: BSD
+URL: https://framework.zend.com/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.3.3
+BuildRequires: php-simplexml
+BuildRequires: php-dom
+BuildRequires: php-libxml
+BuildRequires: php-pcre
+BuildRequires: php-spl
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^3.7 || ^4.0",
+# "squizlabs/php_codesniffer": "~1.5"
+BuildRequires: php-composer(phpunit/phpunit) >= 3.7
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^5.3.3 || ^7.0"
+Requires: php(language) >= 5.3.3
+# From phpcompatinfo report for version 1.0.1
+Requires: php-simplexml
+Requires: php-dom
+Requires: php-libxml
+Requires: php-pcre
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = 1:%{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+An utility component for XML usage and best practices in PHP.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+: Create autoloader
+phpab --template fedora --output src/autoload.php src
+
+
+%install
+mkdir -p %{buildroot}%{php_home}
+cp -pr src %{buildroot}%{php_home}/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\Xml\\', dirname(__DIR__) . '/test');
+EOF
+
+ret=0
+for cmd in php php56 php70 php71 php72 php73 php74; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{php_home}/%{library}
+
+
+%changelog
+* Wed Jan 23 2019 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update to 1.2.0
+
+* Thu May 3 2018 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+
+* Wed Dec 6 2017 Remi Collet <remi@remirepo.net> - 1.0.2-5
+- switch from zend-loader to fedora/autoloader
+
+* Sat Jun 11 2016 Shawn Iwinski <shawn@iwin.ski> - 1.0.2-2
+- Allow F22 / EPEL7 / EPEL6 (ZF 2.4)
+
+* Fri Feb 5 2016 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
+- update to 1.0.2
+
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
+- initial package