summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-09 09:08:17 +0200
committerRemi Collet <remi@remirepo.net>2021-09-09 09:08:17 +0200
commit7bf4e7f23cbb59c37b38cf11fc5737b39f37b5e0 (patch)
treebbe17396cce6f6d30105f15c470da8ccddb611d4
parent65c04e165a82c4a6ed3fc38df7d2b46f83d264e7 (diff)
update to 2.15.0HEADmaster
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader raise dependency on zend-stdlib >= 3.6
-rw-r--r--106.patch23
-rw-r--r--composer.json15
-rw-r--r--php-laminas-validator.spec33
3 files changed, 26 insertions, 45 deletions
diff --git a/106.patch b/106.patch
deleted file mode 100644
index 64601bc..0000000
--- a/106.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 5b8b5a95c7e7736ff7553caa4745248a86ef59f2 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Fri, 30 Jul 2021 13:04:28 +0200
-Subject: [PATCH] fix Regression in RoyalMail
-
----
- src/Barcode/Royalmail.php | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/src/Barcode/Royalmail.php b/src/Barcode/Royalmail.php
-index 211f9cbc..8d5cd5dc 100644
---- a/src/Barcode/Royalmail.php
-+++ b/src/Barcode/Royalmail.php
-@@ -124,7 +124,8 @@ protected function royalmail($value)
- $rowchkvalue = array_keys($this->rows, $rowvalue);
- $colchkvalue = array_keys($this->columns, $colvalue);
- $intersect = array_intersect($rowchkvalue, $colchkvalue);
-- $chkvalue = current($intersect);
-+ $chkvalue = (string)current($intersect);
-+
- if ($chkvalue === $checksum) {
- return true;
- }
diff --git a/composer.json b/composer.json
index f7da50a..8ead394 100644
--- a/composer.json
+++ b/composer.json
@@ -25,15 +25,13 @@
}
},
"require": {
- "php": "^7.3 || ~8.0.0",
+ "php": "^7.3 || ~8.0.0 || ~8.1.0",
"container-interop/container-interop": "^1.1",
- "laminas/laminas-stdlib": "^3.3",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "laminas/laminas-stdlib": "^3.6"
},
"require-dev": {
"laminas/laminas-cache": "^2.6.1",
"laminas/laminas-coding-standard": "~2.2.1",
- "laminas/laminas-config": "^2.6",
"laminas/laminas-db": "^2.7",
"laminas/laminas-filter": "^2.6",
"laminas/laminas-http": "^2.14.2",
@@ -43,7 +41,7 @@
"laminas/laminas-session": "^2.8",
"laminas/laminas-uri": "^2.7",
"phpspec/prophecy-phpunit": "^2.0",
- "phpunit/phpunit": "^9.3",
+ "phpunit/phpunit": "^9.5.5",
"psalm/plugin-phpunit": "^0.15.0",
"psr/http-client": "^1.0",
"psr/http-factory": "^1.0",
@@ -67,6 +65,9 @@
}
},
"autoload-dev": {
+ "files": [
+ "test/autoload.php"
+ ],
"psr-4": {
"LaminasTest\\Validator\\": "test/"
}
@@ -82,7 +83,7 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
"static-analysis": "psalm --shepherd --stats"
},
- "replace": {
- "zendframework/zend-validator": "^2.13.0"
+ "conflict": {
+ "zendframework/zend-validator": "*"
}
}
diff --git a/php-laminas-validator.spec b/php-laminas-validator.spec
index c751cbf..d9b2637 100644
--- a/php-laminas-validator.spec
+++ b/php-laminas-validator.spec
@@ -6,9 +6,9 @@
#
# Please, preserve the changelog entries
#
-# When buid without config, db, filter, http, session, uri
+# When buid without db, filter, http, session, uri
%global bootstrap 0
-%global gh_commit be4c91184882e893d33aea9a64f1a44e6172b11d
+%global gh_commit 270380e87904f5a1a1fba3059989d4ca157e16a9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-validator
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.14.6
+Version: 2.15.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -42,12 +42,11 @@ BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-cache": "^2.6.1",
# "laminas/laminas-coding-standard": "~2.2.1",
-# "laminas/laminas-config": "^2.6",
# "laminas/laminas-db": "^2.7",
# "laminas/laminas-filter": "^2.6",
# "laminas/laminas-http": "^2.14.2",
@@ -57,7 +56,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# "laminas/laminas-session": "^2.8",
# "laminas/laminas-uri": "^2.7",
# "phpspec/prophecy-phpunit": "^2.0",
-# "phpunit/phpunit": "^9.3",
+# "phpunit/phpunit": "^9.5.5",
# "psalm/plugin-phpunit": "^0.15.0",
# "psr/http-client": "^1.0",
# "psr/http-factory": "^1.0",
@@ -69,7 +68,6 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.6
BuildRequires: (php-autoloader(%{gh_owner}/laminas-math) >= 2.6 with php-autoloader(%{gh_owner}/laminas-math) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
%if ! %{bootstrap}
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6 with php-autoloader(%{gh_owner}/laminas-config) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.7 with php-autoloader(%{gh_owner}/laminas-db) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.6 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.14.2 with php-autoloader(%{gh_owner}/laminas-http) < 3)
@@ -80,7 +78,7 @@ BuildRequires: (php-composer(psr/http-message) >= 1.0
BuildRequires: (php-composer(psr/http-client) >= 1.0 with php-composer(psr/http-client) < 2)
BuildRequires: (php-composer(psr/http-factory) >= 1.0 with php-composer(psr/http-factory) < 2)
BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
-# remirepo:21
+# remirepo:20
%else
BuildRequires: php-container-interop
BuildRequires: php-laminas-stdlib
@@ -90,7 +88,6 @@ BuildRequires: php-laminas-i18n
BuildRequires: php-laminas-math
BuildRequires: php-laminas-servicemanager
%if ! %{bootstrap}
-BuildRequires: php-laminas-config
BuildRequires: php-laminas-db
BuildRequires: php-laminas-filter
BuildRequires: php-laminas-http
@@ -102,21 +99,20 @@ BuildRequires: php-psr-http-client
BuildRequires: php-psr-http-factory
BuildRequires: php-phpspec-prophecy-phpunit
%endif
-BuildRequires: phpunit9 >= 9.3
+BuildRequires: phpunit9 >= 9.5.5
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
+# "php": "^7.3 || ~8.0.0 || ~8.1.0",
# "container-interop/container-interop": "^1.1",
-# "laminas/laminas-stdlib": "^3.3",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "laminas/laminas-stdlib": "^3.6"
Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
# "laminas/laminas-db": "Laminas\\Db component, required by the (No)RecordExists validator",
@@ -233,6 +229,7 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
'%{php_home}/Psr/Http/Client/autoload.php',
'%{php_home}/Psr/Http/Message/http-factory-autoload.php',
'%{php_home}/Prophecy/PhpUnit/autoload.php',
+ dirname(__DIR__) . '/test/autoload.php',
]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
@@ -256,7 +253,7 @@ exit (class_exists("\\Zend\\%{library}\\Hex") ? 0 : 1);
: upstream test suite
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php73 php74 php80 php81; do
if which $cmd; then
$cmd -d memory_limit=1G %{_bindir}/phpunit9 --verbose || ret=1
fi
@@ -278,6 +275,12 @@ exit $ret
%changelog
+* Thu Sep 9 2021 Remi Collet <remi@remirepo.net> - 2.15.0-1
+- update to 2.15.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+- raise dependency on zend-stdlib >= 3.6
+
* Thu Sep 9 2021 Remi Collet <remi@remirepo.net> - 2.14.6-1
- update to 2.14.6