summaryrefslogtreecommitdiffstats
path: root/php-laminas-validator.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-validator.spec')
-rw-r--r--php-laminas-validator.spec33
1 files changed, 18 insertions, 15 deletions
diff --git a/php-laminas-validator.spec b/php-laminas-validator.spec
index c751cbf..d9b2637 100644
--- a/php-laminas-validator.spec
+++ b/php-laminas-validator.spec
@@ -6,9 +6,9 @@
#
# Please, preserve the changelog entries
#
-# When buid without config, db, filter, http, session, uri
+# When buid without db, filter, http, session, uri
%global bootstrap 0
-%global gh_commit be4c91184882e893d33aea9a64f1a44e6172b11d
+%global gh_commit 270380e87904f5a1a1fba3059989d4ca157e16a9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-validator
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.14.6
+Version: 2.15.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -42,12 +42,11 @@ BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-cache": "^2.6.1",
# "laminas/laminas-coding-standard": "~2.2.1",
-# "laminas/laminas-config": "^2.6",
# "laminas/laminas-db": "^2.7",
# "laminas/laminas-filter": "^2.6",
# "laminas/laminas-http": "^2.14.2",
@@ -57,7 +56,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# "laminas/laminas-session": "^2.8",
# "laminas/laminas-uri": "^2.7",
# "phpspec/prophecy-phpunit": "^2.0",
-# "phpunit/phpunit": "^9.3",
+# "phpunit/phpunit": "^9.5.5",
# "psalm/plugin-phpunit": "^0.15.0",
# "psr/http-client": "^1.0",
# "psr/http-factory": "^1.0",
@@ -69,7 +68,6 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.6
BuildRequires: (php-autoloader(%{gh_owner}/laminas-math) >= 2.6 with php-autoloader(%{gh_owner}/laminas-math) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
%if ! %{bootstrap}
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6 with php-autoloader(%{gh_owner}/laminas-config) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.7 with php-autoloader(%{gh_owner}/laminas-db) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.6 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.14.2 with php-autoloader(%{gh_owner}/laminas-http) < 3)
@@ -80,7 +78,7 @@ BuildRequires: (php-composer(psr/http-message) >= 1.0
BuildRequires: (php-composer(psr/http-client) >= 1.0 with php-composer(psr/http-client) < 2)
BuildRequires: (php-composer(psr/http-factory) >= 1.0 with php-composer(psr/http-factory) < 2)
BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
-# remirepo:21
+# remirepo:20
%else
BuildRequires: php-container-interop
BuildRequires: php-laminas-stdlib
@@ -90,7 +88,6 @@ BuildRequires: php-laminas-i18n
BuildRequires: php-laminas-math
BuildRequires: php-laminas-servicemanager
%if ! %{bootstrap}
-BuildRequires: php-laminas-config
BuildRequires: php-laminas-db
BuildRequires: php-laminas-filter
BuildRequires: php-laminas-http
@@ -102,21 +99,20 @@ BuildRequires: php-psr-http-client
BuildRequires: php-psr-http-factory
BuildRequires: php-phpspec-prophecy-phpunit
%endif
-BuildRequires: phpunit9 >= 9.3
+BuildRequires: phpunit9 >= 9.5.5
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
+# "php": "^7.3 || ~8.0.0 || ~8.1.0",
# "container-interop/container-interop": "^1.1",
-# "laminas/laminas-stdlib": "^3.3",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "laminas/laminas-stdlib": "^3.6"
Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
# "laminas/laminas-db": "Laminas\\Db component, required by the (No)RecordExists validator",
@@ -233,6 +229,7 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
'%{php_home}/Psr/Http/Client/autoload.php',
'%{php_home}/Psr/Http/Message/http-factory-autoload.php',
'%{php_home}/Prophecy/PhpUnit/autoload.php',
+ dirname(__DIR__) . '/test/autoload.php',
]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
@@ -256,7 +253,7 @@ exit (class_exists("\\Zend\\%{library}\\Hex") ? 0 : 1);
: upstream test suite
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php73 php74 php80 php81; do
if which $cmd; then
$cmd -d memory_limit=1G %{_bindir}/phpunit9 --verbose || ret=1
fi
@@ -278,6 +275,12 @@ exit $ret
%changelog
+* Thu Sep 9 2021 Remi Collet <remi@remirepo.net> - 2.15.0-1
+- update to 2.15.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+- raise dependency on zend-stdlib >= 3.6
+
* Thu Sep 9 2021 Remi Collet <remi@remirepo.net> - 2.14.6-1
- update to 2.14.6