summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-09 13:21:57 +0100
committerRemi Collet <remi@remirepo.net>2020-01-09 13:21:57 +0100
commit3c204e2c14651f52f1f12660920c2a6601537976 (patch)
tree9f5c65b304a92d89bdccb6a4a1ade5c52f8ee545
parentb139a22095b8c71b5b9fd69789baf7254ea97bd1 (diff)
switch to Laminas
-rw-r--r--32.patch36
-rw-r--r--composer.json98
-rw-r--r--php-laminas-validator.spec269
3 files changed, 237 insertions, 166 deletions
diff --git a/32.patch b/32.patch
new file mode 100644
index 0000000..53c5c03
--- /dev/null
+++ b/32.patch
@@ -0,0 +1,36 @@
+From 05fcad5da30ff15326ad13c91bcd49cdc3cb9ec7 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Fri, 3 Jan 2020 09:48:45 +0100
+Subject: [PATCH] Fix using array_key_exists() on objects is deprecated (7.4)
+
+---
+ src/Barcode.php | 13 +++++++++----
+ 1 file changed, 9 insertions(+), 4 deletions(-)
+
+diff --git a/src/Barcode.php b/src/Barcode.php
+index 65e27ed7..27c2a487 100644
+--- a/src/Barcode.php
++++ b/src/Barcode.php
+@@ -51,13 +51,18 @@ public function __construct($options = null)
+ $options = [];
+ }
+
+- if (! is_array($options) && ! ($options instanceof Traversable)) {
++ if (is_array($options)) {
++ if (array_key_exists('options', $options)) {
++ $options['options'] = ['options' => $options['options']];
++ }
++ } else if ($options instanceof Traversable) {
++ if (property_exists($options, 'options')) {
++ $options['options'] = ['options' => $options['options']];
++ }
++ } else {
+ $options = ['adapter' => $options];
+ }
+
+- if (array_key_exists('options', $options)) {
+- $options['options'] = ['options' => $options['options']];
+- }
+
+ parent::__construct($options);
+ }
diff --git a/composer.json b/composer.json
index 076b1c7..3975cf6 100644
--- a/composer.json
+++ b/composer.json
@@ -1,74 +1,75 @@
{
- "name": "zendframework/zend-validator",
+ "name": "laminas/laminas-validator",
"description": "Validation classes for a wide range of domains, and the ability to chain validators to create complex validation criteria",
"license": "BSD-3-Clause",
"keywords": [
- "zendframework",
- "zf",
+ "laminas",
"validator"
],
+ "homepage": "https://laminas.dev",
"support": {
- "docs": "https://docs.zendframework.com/zend-validator/",
- "issues": "https://github.com/zendframework/zend-validator/issues",
- "source": "https://github.com/zendframework/zend-validator",
- "rss": "https://github.com/zendframework/zend-validator/releases.atom",
- "chat": "https://zendframework-slack.herokuapp.com",
- "forum": "https://discourse.zendframework.com/c/questions/components"
+ "docs": "https://docs.laminas.dev/laminas-validator/",
+ "issues": "https://github.com/laminas/laminas-validator/issues",
+ "source": "https://github.com/laminas/laminas-validator",
+ "rss": "https://github.com/laminas/laminas-validator/releases.atom",
+ "chat": "https://laminas.dev/chat",
+ "forum": "https://discourse.laminas.dev"
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.13.x-dev",
+ "dev-develop": "2.14.x-dev"
+ },
+ "laminas": {
+ "component": "Laminas\\Validator",
+ "config-provider": "Laminas\\Validator\\ConfigProvider"
+ }
},
"require": {
"php": "^7.1",
- "zendframework/zend-stdlib": "^3.2.1",
- "container-interop/container-interop": "^1.1"
+ "container-interop/container-interop": "^1.1",
+ "laminas/laminas-stdlib": "^3.2.1",
+ "laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
+ "laminas/laminas-cache": "^2.6.1",
+ "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-config": "^2.6",
+ "laminas/laminas-db": "^2.7",
+ "laminas/laminas-filter": "^2.6",
+ "laminas/laminas-http": "^2.5.4",
+ "laminas/laminas-i18n": "^2.6",
+ "laminas/laminas-math": "^2.6",
+ "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
+ "laminas/laminas-session": "^2.8",
+ "laminas/laminas-uri": "^2.5",
"phpunit/phpunit": "^6.0.8 || ^5.7.15",
- "psr/http-message": "^1.0",
"psr/http-client": "^1.0",
"psr/http-factory": "^1.0",
- "zendframework/zend-cache": "^2.6.1",
- "zendframework/zend-coding-standard": "~1.0.0",
- "zendframework/zend-config": "^2.6",
- "zendframework/zend-db": "^2.7",
- "zendframework/zend-filter": "^2.6",
- "zendframework/zend-http": "^2.5.4",
- "zendframework/zend-i18n": "^2.6",
- "zendframework/zend-math": "^2.6",
- "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
- "zendframework/zend-session": "^2.8",
- "zendframework/zend-uri": "^2.5"
+ "psr/http-message": "^1.0"
},
"suggest": {
- "psr/http-message": "psr/http-message, required when validating PSR-7 UploadedFileInterface instances via the Upload and UploadFile validators",
- "zendframework/zend-db": "Zend\\Db component, required by the (No)RecordExists validator",
- "zendframework/zend-filter": "Zend\\Filter component, required by the Digits validator",
- "zendframework/zend-i18n": "Zend\\I18n component to allow translation of validation error messages",
- "zendframework/zend-math": "Zend\\Math component, required by the Csrf validator",
- "zendframework/zend-i18n-resources": "Translations of validator messages",
- "zendframework/zend-servicemanager": "Zend\\ServiceManager component to allow using the ValidatorPluginManager and validator chains",
- "zendframework/zend-session": "Zend\\Session component, ^2.8; required by the Csrf validator",
- "zendframework/zend-uri": "Zend\\Uri component, required by the Uri and Sitemap\\Loc validators"
+ "laminas/laminas-db": "Laminas\\Db component, required by the (No)RecordExists validator",
+ "laminas/laminas-filter": "Laminas\\Filter component, required by the Digits validator",
+ "laminas/laminas-i18n": "Laminas\\I18n component to allow translation of validation error messages",
+ "laminas/laminas-i18n-resources": "Translations of validator messages",
+ "laminas/laminas-math": "Laminas\\Math component, required by the Csrf validator",
+ "laminas/laminas-servicemanager": "Laminas\\ServiceManager component to allow using the ValidatorPluginManager and validator chains",
+ "laminas/laminas-session": "Laminas\\Session component, ^2.8; required by the Csrf validator",
+ "laminas/laminas-uri": "Laminas\\Uri component, required by the Uri and Sitemap\\Loc validators",
+ "psr/http-message": "psr/http-message, required when validating PSR-7 UploadedFileInterface instances via the Upload and UploadFile validators"
},
"autoload": {
"psr-4": {
- "Zend\\Validator\\": "src/"
+ "Laminas\\Validator\\": "src/"
}
},
"autoload-dev": {
"psr-4": {
- "ZendTest\\Validator\\": "test/"
- }
- },
- "config": {
- "sort-packages": true
- },
- "extra": {
- "branch-alias": {
- "dev-master": "2.13.x-dev",
- "dev-develop": "2.14.x-dev"
- },
- "zf": {
- "component": "Zend\\Validator",
- "config-provider": "Zend\\Validator\\ConfigProvider"
+ "LaminasTest\\Validator\\": "test/"
}
},
"scripts": {
@@ -80,5 +81,8 @@
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ },
+ "replace": {
+ "zendframework/zend-validator": "self.version"
}
}
diff --git a/php-laminas-validator.spec b/php-laminas-validator.spec
index 808c99c..cec3d23 100644
--- a/php-laminas-validator.spec
+++ b/php-laminas-validator.spec
@@ -1,4 +1,4 @@
-# remirepo/Fedora spec file for php-zendframework-zend-validator
+# remirepo/Fedora spec file for php-laminas-validator
#
# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
@@ -6,28 +6,25 @@
#
# Please, preserve the changelog entries
#
-%global bootstrap 0
-%global gh_commit b54acef1f407741c5347f2a97f899ab21f2229ef
+# When buid without config, db, filter, http, session, uri
+%global bootstrap 1
+%global gh_commit 2a03c207d5ae038259f0abb588f64851cebdcb1a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-validator
+%global gh_owner laminas
+%global gh_project laminas-validator
+%global zf_name zend-validator
%global php_home %{_datadir}/php
+%global namespace Laminas
%global library Validator
-%if %{bootstrap}
-%global with_tests 0%{?_with_tests:1}
-%else
%global with_tests 0%{!?_without_tests:1}
-%endif
-# TODO switch BR to fedora-autoloader + tests
-
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 2.13.0
Release: 1%{?dist}
-Summary: Zend Framework %{library} component
+Summary: %{namespace} Framework %{library} component
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -46,111 +43,106 @@ BuildRequires: php-pcre
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
-# remirepo:4
-%else
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
-BuildRequires: php-composer(container-interop/container-interop) >= 1.1
-%endif
+BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
+# "laminas/laminas-cache": "^2.6.1",
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-config": "^2.6",
+# "laminas/laminas-db": "^2.7",
+# "laminas/laminas-filter": "^2.6",
+# "laminas/laminas-http": "^2.5.4",
+# "laminas/laminas-i18n": "^2.6",
+# "laminas/laminas-math": "^2.6",
+# "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
+# "laminas/laminas-session": "^2.8",
+# "laminas/laminas-uri": "^2.5",
# "phpunit/phpunit": "^6.0.8 || ^5.7.15",
-# "psr/http-message": "^1.0",
# "psr/http-client": "^1.0",
# "psr/http-factory": "^1.0",
-# "zendframework/zend-cache": "^2.6.1",
-# "zendframework/zend-coding-standard": "~1.0.0",
-# "zendframework/zend-config": "^2.6",
-# "zendframework/zend-db": "^2.7",
-# "zendframework/zend-filter": "^2.6",
-# "zendframework/zend-http": "^2.5.4",
-# "zendframework/zend-i18n": "^2.6",
-# "zendframework/zend-math": "^2.6",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "zendframework/zend-session": "^2.8",
-# "zendframework/zend-uri": "^2.5"
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
-BuildRequires: (php-composer(psr/http-client) >= 1.0 with php-composer(psr/http-client) < 2)
-BuildRequires: (php-composer(psr/http-factory) >= 1.0 with php-composer(psr/http-factory) < 2)
-BuildRequires: (php-composer(%{gh_owner}/zend-cache) >= 2.6.1 with php-composer(%{gh_owner}/zend-cache) < 3)
-BuildRequires: (php-composer(%{gh_owner}/zend-config) >= 2.6 with php-composer(%{gh_owner}/zend-config) < 3)
-BuildRequires: (php-composer(%{gh_owner}/zend-db) >= 2.7 with php-composer(%{gh_owner}/zend-db) < 3)
-BuildRequires: (php-composer(%{gh_owner}/zend-filter) >= 2.6 with php-composer(%{gh_owner}/zend-filter) < 3)
-BuildRequires: (php-composer(%{gh_owner}/zend-http) >= 2.5.4 with php-composer(%{gh_owner}/zend-http) < 3)
-BuildRequires: (php-composer(%{gh_owner}/zend-i18n) >= 2.6 with php-composer(%{gh_owner}/zend-i18n) < 3)
+# "psr/http-message": "^1.0"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-cache) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.6 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
# ignore max version
-BuildRequires: (php-composer(%{gh_owner}/zend-math) >= 2.6 with php-composer(%{gh_owner}/zend-math) < 4)
-BuildRequires: (php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-composer(%{gh_owner}/zend-servicemanager) < 4)
-BuildRequires: (php-composer(%{gh_owner}/zend-session) >= 2.8 with php-composer(%{gh_owner}/zend-session) < 3)
-BuildRequires: (php-composer(%{gh_owner}/zend-uri) >= 2.5 with php-composer(%{gh_owner}/zend-uri) < 3)
-# remirepo:15
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-math) >= 2.6 with php-autoloader(%{gh_owner}/laminas-math) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+%if ! %{bootstrap}
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6 with php-autoloader(%{gh_owner}/laminas-config) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.7 with php-autoloader(%{gh_owner}/laminas-db) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.6 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.5.4 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.8 with php-autoloader(%{gh_owner}/laminas-session) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.5 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
+%endif
+BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
+BuildRequires: (php-composer(psr/http-client) >= 1.0 with php-composer(psr/http-client) < 2)
+BuildRequires: (php-composer(psr/http-factory) >= 1.0 with php-composer(psr/http-factory) < 2)
+# remirepo:20
%else
-BuildRequires: php-composer(psr/http-message) >= 1.0
-BuildRequires: php-composer(psr/http-client) >= 1.0
-BuildRequires: php-composer(psr/http-factory) >= 1.0
-BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.6.1
-BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
-BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.7
-BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.6
-BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5.4
-BuildRequires: php-composer(%{gh_owner}/zend-i18n) >= 2.6
-BuildRequires: php-composer(%{gh_owner}/zend-math) >= 2.6
-BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.8
-BuildRequires: php-composer(%{gh_owner}/zend-uri) >= 2.5
+BuildRequires: php-container-interop
+BuildRequires: php-laminas-stdlib
+BuildRequires: php-laminas-zendframework-bridge
+BuildRequires: php-psr-http-message
+BuildRequires: php-psr-http-client
+BuildRequires: php-psr-http-factory
+BuildRequires: php-laminas-cache
+BuildRequires: php-laminas-i18n
+BuildRequires: php-laminas-math
+BuildRequires: php-laminas-servicemanager
+%if ! %{bootstrap}
+BuildRequires: php-laminas-config
+BuildRequires: php-laminas-db
+BuildRequires: php-laminas-filter
+BuildRequires: php-laminas-http
+BuildRequires: php-laminas-session
+BuildRequires: php-laminas-uri
+%endif
%endif
BuildRequires: phpunit6 >= 6.0.8
-# Autoloader
-BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
+# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^7.1",
-# "zendframework/zend-stdlib": "^3.2.1",
-# "container-interop/container-interop": "^1.1"
+# "container-interop/container-interop": "^1.1",
+# "laminas/laminas-stdlib": "^3.2.1",
+# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 7.1
-%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
-# remirepo:6
-%else
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-Requires: php-composer(container-interop/container-interop) >= 1.1
-Requires: php-composer(container-interop/container-interop) < 2
-%endif
+Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
-# "psr/http-message": "psr/http-message, required when validating PSR-7 UploadedFileInterface instances via the Upload and UploadFile validators",
-# "zendframework/zend-db": "Zend\\Db component, required by the (No)RecordExists validator",
-# "zendframework/zend-filter": "Zend\\Filter component, required by the Digits validator",
-# "zendframework/zend-i18n": "Zend\\I18n component to allow translation of validation error messages",
-# "zendframework/zend-math": "Zend\\Math component, required by the Csrf validator",
-# "zendframework/zend-i18n-resources": "Translations of validator messages",
-# "zendframework/zend-servicemanager": "Zend\\ServiceManager component to allow using the ValidatorPluginManager and validator chains",
-# "zendframework/zend-session": "Zend\\Session component, ^2.8; required by the Csrf validator",
-# "zendframework/zend-uri": "Zend\\Uri component, required by the Uri and Sitemap\\Loc validators"
-# remirepo:1
-%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
+# "laminas/laminas-db": "Laminas\\Db component, required by the (No)RecordExists validator",
+# "laminas/laminas-filter": "Laminas\\Filter component, required by the Digits validator",
+# "laminas/laminas-i18n": "Laminas\\I18n component to allow translation of validation error messages",
+# "laminas/laminas-i18n-resources": "Translations of validator messages",
+# "laminas/laminas-math": "Laminas\\Math component, required by the Csrf validator",
+# "laminas/laminas-servicemanager": "Laminas\\ServiceManager component to allow using the ValidatorPluginManager and validator chains",
+# "laminas/laminas-session": "Laminas\\Session component, ^2.8; required by the Csrf validator",
+# "laminas/laminas-uri": "Laminas\\Uri component, required by the Uri and Sitemap\\Loc validators",
+# "psr/http-message": "psr/http-message, required when validating PSR-7 UploadedFileInterface instances via the Upload and UploadFile validators"
+Suggests: php-composer(%{gh_owner}/laminas-db)
+Suggests: php-composer(%{gh_owner}/laminas-filter)
+Suggests: php-composer(%{gh_owner}/laminas-i18n)
+Suggests: php-composer(%{gh_owner}/laminas-i18n-resources)
+Suggests: php-composer(%{gh_owner}/laminas-math)
+Suggests: php-composer(%{gh_owner}/laminas-servicemanager)
+Suggests: php-composer(%{gh_owner}/laminas-session)
+Suggests: php-composer(%{gh_owner}/laminas-uri)
Recommends: php-composer(psr/http-message)
-Suggests: php-composer(%{gh_owner}/zend-db)
-Suggests: php-composer(%{gh_owner}/zend-filter)
-Suggests: php-composer(%{gh_owner}/zend-i18n)
-Suggests: php-composer(%{gh_owner}/zend-math)
-Suggests: php-composer(%{gh_owner}/zend-i18n-resources)
-Suggests: php-composer(%{gh_owner}/zend-servicemanager)
-Suggests: php-composer(%{gh_owner}/zend-session)
-Suggests: php-composer(%{gh_owner}/zend-uri)
-# remirepo:1
-%endif
+# remirepo:5
+%else
+Requires: php-container-interop
+Requires: php-laminas-stdlib
+Requires: php-laminas-zendframework-bridge
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 2.10.1
+# From phpcompatinfo report for version 2.13.0
Requires: php-ctype
Requires: php-date
Requires: php-fileinfo
@@ -159,18 +151,21 @@ Requires: php-intl
Requires: php-pcre
Requires: php-spl
-Obsoletes: php-ZendFramework2-%{library} < 2.5
-Provides: php-ZendFramework2-%{library} = %{version}
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 2.13.0-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-The Zend\Validator component provides a set of commonly needed validators.
+The %{namespace}\Validator component provides a set of commonly needed validators.
It also provides a simple validator chaining mechanism by which multiple
validators may be applied to a single datum in a user-defined order.
-Documentation: https://zendframework.github.io/%{gh_project}/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -186,26 +181,40 @@ phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/Interop/Container/autoload.php',
- '%{php_home}/Zend/Stdlib/autoload.php',
+ '%{php_home}/%{namespace}/Stdlib/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
'%{php_home}/Psr/Http/Message/autoload.php',
- '%{php_home}/Zend/Db/autoload.php',
- '%{php_home}/Zend/Filter/autoload.php',
- '%{php_home}/Zend/I18n/autoload.php',
- '%{php_home}/Zend/I18n/Translator/autoload.php',
- '%{php_home}/Zend/Math/autoload.php',
- '%{php_home}/Zend/ServiceManager/autoload.php',
- '%{php_home}/Zend/Validator/autoload.php',
- '%{php_home}/Zend/Session/autoload.php',
- '%{php_home}/Zend/Uri/Translator/Resources.php',
+ '%{php_home}/%{namespace}/Db/autoload.php',
+ '%{php_home}/%{namespace}/Filter/autoload.php',
+ '%{php_home}/%{namespace}/I18n/autoload.php',
+ '%{php_home}/%{namespace}/I18n/Translator/autoload.php',
+ '%{php_home}/%{namespace}/Math/autoload.php',
+ '%{php_home}/%{namespace}/ServiceManager/autoload.php',
+ '%{php_home}/%{namespace}/Validator/autoload.php',
+ '%{php_home}/%{namespace}/Session/autoload.php',
+ '%{php_home}/%{namespace}/Uri/Translator/Resources.php',
+]);
+EOF
+
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(__DIR__)) . '/%{namespace}/%{library}/autoload.php',
]);
EOF
%install
-mkdir -p %{buildroot}%{php_home}/Zend/
-cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}
+
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
%check
@@ -213,18 +222,35 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
# For BR without new autoloader
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/autoload.php',
'%{php_home}/Psr/Http/Client/autoload.php',
'%{php_home}/Psr/Http/Message/http-factory-autoload.php',
]);
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
+%if %{bootstrap}
+rm -r test/Db/
+rm -r test/Sitemap/
+rm test/BarcodeTest.php
+rm test/CreditCardTest.php
+rm test/CsrfTest.php
+rm test/DigitsTest.php
+rm test/NotEmptyTest.php
+rm test/UriTest.php
+%endif
+
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
+return (class_exists("\\Zend\\%{library}\\Hex") ? 0 : 1);
+'
+
+: upstream test suite
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php72 php73 php74; do
if which $cmd; then
$cmd -d memory_limit=1G %{_bindir}/phpunit6 --verbose || ret=1
fi
@@ -242,9 +268,14 @@ exit $ret
%doc *.md
%doc composer.json
%{php_home}/Zend/%{library}
+%{php_home}/%{namespace}/%{library}
%changelog
+* Wed Jan 8 2020 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- switch to Laminas
+- boostrap build without config, db, filter, http, session and uri
+
* Fri Jan 3 2020 Remi Collet <remi@remirepo.net> - 2.13.0-1
- update to 2.13.0
- raise dependency on PHP 7.1