summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-09 12:16:39 +0100
committerRemi Collet <remi@remirepo.net>2020-01-09 12:16:39 +0100
commitb139a22095b8c71b5b9fd69789baf7254ea97bd1 (patch)
tree9f404b7bf60877e2b623fcd93b9301374afc6fd4
duplicate ZF
-rw-r--r--.gitignore7
-rw-r--r--Makefile3
-rw-r--r--composer.json84
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-laminas-validator.spec334
5 files changed, 456 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..076b1c7
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,84 @@
+{
+ "name": "zendframework/zend-validator",
+ "description": "Validation classes for a wide range of domains, and the ability to chain validators to create complex validation criteria",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zendframework",
+ "zf",
+ "validator"
+ ],
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-validator/",
+ "issues": "https://github.com/zendframework/zend-validator/issues",
+ "source": "https://github.com/zendframework/zend-validator",
+ "rss": "https://github.com/zendframework/zend-validator/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
+ },
+ "require": {
+ "php": "^7.1",
+ "zendframework/zend-stdlib": "^3.2.1",
+ "container-interop/container-interop": "^1.1"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^6.0.8 || ^5.7.15",
+ "psr/http-message": "^1.0",
+ "psr/http-client": "^1.0",
+ "psr/http-factory": "^1.0",
+ "zendframework/zend-cache": "^2.6.1",
+ "zendframework/zend-coding-standard": "~1.0.0",
+ "zendframework/zend-config": "^2.6",
+ "zendframework/zend-db": "^2.7",
+ "zendframework/zend-filter": "^2.6",
+ "zendframework/zend-http": "^2.5.4",
+ "zendframework/zend-i18n": "^2.6",
+ "zendframework/zend-math": "^2.6",
+ "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
+ "zendframework/zend-session": "^2.8",
+ "zendframework/zend-uri": "^2.5"
+ },
+ "suggest": {
+ "psr/http-message": "psr/http-message, required when validating PSR-7 UploadedFileInterface instances via the Upload and UploadFile validators",
+ "zendframework/zend-db": "Zend\\Db component, required by the (No)RecordExists validator",
+ "zendframework/zend-filter": "Zend\\Filter component, required by the Digits validator",
+ "zendframework/zend-i18n": "Zend\\I18n component to allow translation of validation error messages",
+ "zendframework/zend-math": "Zend\\Math component, required by the Csrf validator",
+ "zendframework/zend-i18n-resources": "Translations of validator messages",
+ "zendframework/zend-servicemanager": "Zend\\ServiceManager component to allow using the ValidatorPluginManager and validator chains",
+ "zendframework/zend-session": "Zend\\Session component, ^2.8; required by the Csrf validator",
+ "zendframework/zend-uri": "Zend\\Uri component, required by the Uri and Sitemap\\Loc validators"
+ },
+ "autoload": {
+ "psr-4": {
+ "Zend\\Validator\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\Validator\\": "test/"
+ }
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.13.x-dev",
+ "dev-develop": "2.14.x-dev"
+ },
+ "zf": {
+ "component": "Zend\\Validator",
+ "config-provider": "Zend\\Validator\\ConfigProvider"
+ }
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..87d223d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-laminas-validator.spec b/php-laminas-validator.spec
new file mode 100644
index 0000000..808c99c
--- /dev/null
+++ b/php-laminas-validator.spec
@@ -0,0 +1,334 @@
+# remirepo/Fedora spec file for php-zendframework-zend-validator
+#
+# Copyright (c) 2015-2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit b54acef1f407741c5347f2a97f899ab21f2229ef
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-validator
+%global php_home %{_datadir}/php
+%global library Validator
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+# TODO switch BR to fedora-autoloader + tests
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 2.13.0
+Release: 1%{?dist}
+Summary: Zend Framework %{library} component
+
+License: BSD
+URL: https://zendframework.github.io/%{gh_project}/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+Patch0: https://patch-diff.githubusercontent.com/raw/laminas/laminas-validator/pull/32.patch
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 7.1
+BuildRequires: php-ctype
+BuildRequires: php-date
+BuildRequires: php-fileinfo
+BuildRequires: php-hash
+BuildRequires: php-intl
+BuildRequires: php-pcre
+BuildRequires: php-spl
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+# remirepo:4
+%else
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
+BuildRequires: php-composer(container-interop/container-interop) >= 1.1
+%endif
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^6.0.8 || ^5.7.15",
+# "psr/http-message": "^1.0",
+# "psr/http-client": "^1.0",
+# "psr/http-factory": "^1.0",
+# "zendframework/zend-cache": "^2.6.1",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-config": "^2.6",
+# "zendframework/zend-db": "^2.7",
+# "zendframework/zend-filter": "^2.6",
+# "zendframework/zend-http": "^2.5.4",
+# "zendframework/zend-i18n": "^2.6",
+# "zendframework/zend-math": "^2.6",
+# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
+# "zendframework/zend-session": "^2.8",
+# "zendframework/zend-uri": "^2.5"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
+BuildRequires: (php-composer(psr/http-client) >= 1.0 with php-composer(psr/http-client) < 2)
+BuildRequires: (php-composer(psr/http-factory) >= 1.0 with php-composer(psr/http-factory) < 2)
+BuildRequires: (php-composer(%{gh_owner}/zend-cache) >= 2.6.1 with php-composer(%{gh_owner}/zend-cache) < 3)
+BuildRequires: (php-composer(%{gh_owner}/zend-config) >= 2.6 with php-composer(%{gh_owner}/zend-config) < 3)
+BuildRequires: (php-composer(%{gh_owner}/zend-db) >= 2.7 with php-composer(%{gh_owner}/zend-db) < 3)
+BuildRequires: (php-composer(%{gh_owner}/zend-filter) >= 2.6 with php-composer(%{gh_owner}/zend-filter) < 3)
+BuildRequires: (php-composer(%{gh_owner}/zend-http) >= 2.5.4 with php-composer(%{gh_owner}/zend-http) < 3)
+BuildRequires: (php-composer(%{gh_owner}/zend-i18n) >= 2.6 with php-composer(%{gh_owner}/zend-i18n) < 3)
+# ignore max version
+BuildRequires: (php-composer(%{gh_owner}/zend-math) >= 2.6 with php-composer(%{gh_owner}/zend-math) < 4)
+BuildRequires: (php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-composer(%{gh_owner}/zend-servicemanager) < 4)
+BuildRequires: (php-composer(%{gh_owner}/zend-session) >= 2.8 with php-composer(%{gh_owner}/zend-session) < 3)
+BuildRequires: (php-composer(%{gh_owner}/zend-uri) >= 2.5 with php-composer(%{gh_owner}/zend-uri) < 3)
+# remirepo:15
+%else
+BuildRequires: php-composer(psr/http-message) >= 1.0
+BuildRequires: php-composer(psr/http-client) >= 1.0
+BuildRequires: php-composer(psr/http-factory) >= 1.0
+BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.6.1
+BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.7
+BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5.4
+BuildRequires: php-composer(%{gh_owner}/zend-i18n) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-math) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
+BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.8
+BuildRequires: php-composer(%{gh_owner}/zend-uri) >= 2.5
+%endif
+BuildRequires: phpunit6 >= 6.0.8
+# Autoloader
+BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
+%endif
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^7.1",
+# "zendframework/zend-stdlib": "^3.2.1",
+# "container-interop/container-interop": "^1.1"
+Requires: php(language) >= 7.1
+%if ! %{bootstrap}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+# remirepo:6
+%else
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+Requires: php-composer(container-interop/container-interop) >= 1.1
+Requires: php-composer(container-interop/container-interop) < 2
+%endif
+# From composer, "suggest": {
+# "psr/http-message": "psr/http-message, required when validating PSR-7 UploadedFileInterface instances via the Upload and UploadFile validators",
+# "zendframework/zend-db": "Zend\\Db component, required by the (No)RecordExists validator",
+# "zendframework/zend-filter": "Zend\\Filter component, required by the Digits validator",
+# "zendframework/zend-i18n": "Zend\\I18n component to allow translation of validation error messages",
+# "zendframework/zend-math": "Zend\\Math component, required by the Csrf validator",
+# "zendframework/zend-i18n-resources": "Translations of validator messages",
+# "zendframework/zend-servicemanager": "Zend\\ServiceManager component to allow using the ValidatorPluginManager and validator chains",
+# "zendframework/zend-session": "Zend\\Session component, ^2.8; required by the Csrf validator",
+# "zendframework/zend-uri": "Zend\\Uri component, required by the Uri and Sitemap\\Loc validators"
+# remirepo:1
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
+Recommends: php-composer(psr/http-message)
+Suggests: php-composer(%{gh_owner}/zend-db)
+Suggests: php-composer(%{gh_owner}/zend-filter)
+Suggests: php-composer(%{gh_owner}/zend-i18n)
+Suggests: php-composer(%{gh_owner}/zend-math)
+Suggests: php-composer(%{gh_owner}/zend-i18n-resources)
+Suggests: php-composer(%{gh_owner}/zend-servicemanager)
+Suggests: php-composer(%{gh_owner}/zend-session)
+Suggests: php-composer(%{gh_owner}/zend-uri)
+# remirepo:1
+%endif
+%endif
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+# From phpcompatinfo report for version 2.10.1
+Requires: php-ctype
+Requires: php-date
+Requires: php-fileinfo
+Requires: php-hash
+Requires: php-intl
+Requires: php-pcre
+Requires: php-spl
+
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = %{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+The Zend\Validator component provides a set of commonly needed validators.
+It also provides a simple validator chaining mechanism by which multiple
+validators may be applied to a single datum in a user-defined order.
+
+Documentation: https://zendframework.github.io/%{gh_project}/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
+
+mv LICENSE.md LICENSE
+
+
+%build
+: Create autoloader
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Interop/Container/autoload.php',
+ '%{php_home}/Zend/Stdlib/autoload.php',
+]);
+\Fedora\Autoloader\Dependencies::optional([
+ '%{php_home}/Psr/Http/Message/autoload.php',
+ '%{php_home}/Zend/Db/autoload.php',
+ '%{php_home}/Zend/Filter/autoload.php',
+ '%{php_home}/Zend/I18n/autoload.php',
+ '%{php_home}/Zend/I18n/Translator/autoload.php',
+ '%{php_home}/Zend/Math/autoload.php',
+ '%{php_home}/Zend/ServiceManager/autoload.php',
+ '%{php_home}/Zend/Validator/autoload.php',
+ '%{php_home}/Zend/Session/autoload.php',
+ '%{php_home}/Zend/Uri/Translator/Resources.php',
+]);
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/Zend/
+cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
+# For BR without new autoloader
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Zend/autoload.php',
+ '%{php_home}/Psr/Http/Client/autoload.php',
+ '%{php_home}/Psr/Http/Message/http-factory-autoload.php',
+]);
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+EOF
+
+ret=0
+for cmd in php php71 php72 php73 php74; do
+ if which $cmd; then
+ $cmd -d memory_limit=1G %{_bindir}/phpunit6 --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{php_home}/Zend/%{library}
+
+
+%changelog
+* Fri Jan 3 2020 Remi Collet <remi@remirepo.net> - 2.13.0-1
+- update to 2.13.0
+- raise dependency on PHP 7.1
+- add patch for PHP 7.4 from
+ https://github.com/laminas/laminas-validator/pull/32
+
+* Tue Oct 29 2019 Remi Collet <remi@remirepo.net> - 2.12.2-1
+- update to 2.12.2
+
+* Sun Oct 13 2019 Remi Collet <remi@remirepo.net> - 2.12.1-1
+- update to 2.12.1
+
+* Thu Jan 31 2019 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0
+- raise dependency on zend-stdlib 3.2.1
+
+* Fri Dec 14 2018 Remi Collet <remi@remirepo.net> - 2.11.0-2
+- update to 2.11.0
+- add weak dependency on psr/http-message
+- use range dependencies
+
+* Fri Feb 2 2018 Remi Collet <remi@remirepo.net> - 2.10.2-1
+- Update to 2.10.2
+- switch to phpunit6
+
+* Thu Dec 7 2017 Remi Collet <remi@remirepo.net> - 2.10-1-3
+- switch from zend-loader to fedora/autoloader
+
+* Tue Oct 31 2017 Remi Collet <remi@remirepo.net> - 2.10.1-2
+- fix FTBFS from Koschei, add patch for test with 7.2 from
+ https://github.com/zendframework/zend-validator/pull/205
+
+* Wed Aug 23 2017 Remi Collet <remi@remirepo.net> - 2.10.1-1
+- Update to 2.10.1
+
+* Tue Aug 15 2017 Remi Collet <remi@remirepo.net> - 2.10.0-1
+- Update to 2.10.0
+
+* Fri Aug 4 2017 Remi Collet <remi@remirepo.net> - 2.9.2-1
+- Update to 2.9.2
+- add patch for PHP 7.2 from
+ https://github.com/zendframework/zend-validator/pull/190
+
+* Mon May 22 2017 Remi Collet <remi@remirepo.net> - 2.9.1-1
+- Update to 2.9.1
+
+* Fri Mar 17 2017 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- Update to 2.9.0
+- raise dependency on PHP 5.6
+- raise dependency on zend-stdlib 2.7.6
+- use phpunit6 on F26+
+
+* Sun Jan 29 2017 Remi Collet <remi@fedoraproject.org> - 2.8.2-1
+- Update to 2.8.2
+
+* Tue Nov 15 2016 Remi Collet <remi@fedoraproject.org> - 2.8.1-2
+- add patch for PHP 7.1 and timezone changes
+- open https://github.com/zendframework/zend-validator/pull/136
+
+* Thu Jun 23 2016 Remi Collet <remi@fedoraproject.org> - 2.8.1-1
+- Update to 2.8.1
+
+* Tue May 17 2016 Remi Collet <remi@fedoraproject.org> - 2.8.0-1
+- Update to 2.8.0
+
+* Tue Apr 19 2016 Remi Collet <remi@fedoraproject.org> - 2.7.2-1
+- Update to 2.7.2
+
+* Wed Apr 6 2016 Remi Collet <remi@fedoraproject.org> - 2.7.1-1
+- Update to 2.7.1
+
+* Wed Apr 6 2016 Remi Collet <remi@fedoraproject.org> - 2.7.0-1
+- Update to 2.7.0
+
+* Thu Feb 18 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- Update to 2.6.0
+- raise dependency on zend-stdlib ^2.7
+- add dependency on container-interop/container-interop
+
+* Fri Sep 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.3-1
+- Update to 2.5.3
+
+* Thu Aug 6 2015 Remi Collet <remi@fedoraproject.org> - 2.5.2-2
+- fix description
+
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
+- initial package