summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-02 10:13:44 +0100
committerRemi Collet <remi@remirepo.net>2020-11-02 10:13:44 +0100
commit3e133f38c0859fbe5bfc2fca98e6f0ccfe277ea2 (patch)
tree4a760d0e1d4af79c039977057924a205a5b75724
parent492008af63136762e4d642f8f2d065b36e9dc6a3 (diff)
update to 2.8.0
raise dependency on PHP 7.3 switch to phpunit9
-rw-r--r--8.patch28
-rw-r--r--composer.json12
-rw-r--r--dd2561ed82692212fca4d71ec94a58bae04a1524.patch29
-rw-r--r--php-laminas-uri.spec34
4 files changed, 21 insertions, 82 deletions
diff --git a/8.patch b/8.patch
deleted file mode 100644
index 23ffddc..0000000
--- a/8.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 353a7eb58cb1d159979d8a5d181324ef4a8b91d8 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 9 Jan 2020 14:13:48 +0100
-Subject: [PATCH] rewrite testRegisteringNewScheme for 7.4
-
----
- test/UriFactoryTest.php | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/test/UriFactoryTest.php b/test/UriFactoryTest.php
-index 9828d1b..a9cbf7d 100644
---- a/test/UriFactoryTest.php
-+++ b/test/UriFactoryTest.php
-@@ -29,11 +29,11 @@ class UriFactoryTest extends TestCase
- */
- public function testRegisteringNewScheme($scheme, $class)
- {
-- $this->assertAttributeNotContains($class, 'schemeClasses', '\Laminas\Uri\UriFactory');
-+ $this->assertNull(UriFactory::getRegisteredSchemeClass($scheme));
- UriFactory::registerScheme($scheme, $class);
-- $this->assertAttributeContains($class, 'schemeClasses', '\Laminas\Uri\UriFactory');
-+ $this->assertEquals(UriFactory::getRegisteredSchemeClass($scheme), $class);
- UriFactory::unregisterScheme($scheme);
-- $this->assertAttributeNotContains($class, 'schemeClasses', '\Laminas\Uri\UriFactory');
-+ $this->assertNull(UriFactory::getRegisteredSchemeClass($scheme));
- }
-
- /**
diff --git a/composer.json b/composer.json
index 4bc1c35..2eb6043 100644
--- a/composer.json
+++ b/composer.json
@@ -19,20 +19,16 @@
"sort-packages": true
},
"extra": {
- "branch-alias": {
- "dev-master": "2.7.x-dev",
- "dev-develop": "2.8.x-dev"
- }
},
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"laminas/laminas-escaper": "^2.5",
"laminas/laminas-validator": "^2.10",
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
+ "laminas/laminas-coding-standard": "^2.1",
+ "phpunit/phpunit": "^9.3"
},
"autoload": {
"psr-4": {
@@ -55,6 +51,6 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-uri": "self.version"
+ "zendframework/zend-uri": "^2.7.1"
}
}
diff --git a/dd2561ed82692212fca4d71ec94a58bae04a1524.patch b/dd2561ed82692212fca4d71ec94a58bae04a1524.patch
deleted file mode 100644
index 2c52069..0000000
--- a/dd2561ed82692212fca4d71ec94a58bae04a1524.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From dd2561ed82692212fca4d71ec94a58bae04a1524 Mon Sep 17 00:00:00 2001
-From: Fahl-Design <Fahl-Design@users.noreply.github.com>
-Date: Fri, 3 Jan 2020 22:56:03 +0100
-Subject: [PATCH] Fix FileTest::testCanCreateUriObjectFromWindowsPath
-
-with data set #0 ('C:\Program Files\Laminas\README', 'C:/Program%20Files/Laminas%20...README')
-Failed asserting that two strings are equal.
---- Expected
-+++ Actual
--'C:/Program%20Files/Laminas%20Framework/README'
-+'C:/Program%20Files/Laminas/README'
-laminas/laminas-uri/test/FileTest.php:201
----
- test/FileTest.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/test/FileTest.php b/test/FileTest.php
-index b37d1dd..aca6f27 100644
---- a/test/FileTest.php
-+++ b/test/FileTest.php
-@@ -87,7 +87,7 @@ public static function unixUris()
- public static function windowsUris()
- {
- return [
-- ['C:\Program Files\Laminas\README', 'C:/Program%20Files/Laminas%20Framework/README'],
-+ ['C:\Program Files\Laminas\README', 'C:/Program%20Files/Laminas/README'],
- ];
- }
-
diff --git a/php-laminas-uri.spec b/php-laminas-uri.spec
index b2bb2bf..1fb8b87 100644
--- a/php-laminas-uri.spec
+++ b/php-laminas-uri.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 6be8ce19622f359b048ce4faebf1aa1bca73a7ff
+%global gh_commit 8651611b6285529f25a4cb9a466c686d9b31468e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-uri
@@ -23,8 +23,8 @@
%endif
Name: php-%{gh_project}
-Version: 2.7.1
-Release: 2%{?dist}
+Version: 2.8.0
+Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
License: BSD
@@ -32,18 +32,15 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://github.com/laminas/laminas-uri/commit/dd2561ed82692212fca4d71ec94a58bae04a1524.patch
-Patch1: https://patch-diff.githubusercontent.com/raw/laminas/laminas-uri/pull/8.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
+# "laminas/laminas-coding-standard": "^2.1",
+# "phpunit/phpunit": "^9.3"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-escaper) >= 2.5 with php-autoloader(%{gh_owner}/laminas-escaper) < 3)
@@ -55,18 +52,18 @@ BuildRequires: php-laminas-escaper
BuildRequires: php-laminas-validator
BuildRequires: php-laminas-zendframework-bridge
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.4
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-escaper": "^2.5",
# "laminas/laminas-validator": "^2.10",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-escaper) >= 2.5 with php-autoloader(%{gh_owner}/laminas-escaper) < 3)
@@ -106,8 +103,6 @@ Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
-%patch1 -p1
mv LICENSE.md LICENSE
@@ -159,10 +154,10 @@ exit (class_exists("\\Zend\\%{library}\\File") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -182,6 +177,11 @@ exit $ret
%changelog
+* Mon Nov 2 2020 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Fri Jan 17 2020 Remi Collet <remi@remirepo.net> - 2.7.1-2
- cleanup