summaryrefslogtreecommitdiffstats
path: root/php-laminas-uri.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-uri.spec')
-rw-r--r--php-laminas-uri.spec34
1 files changed, 17 insertions, 17 deletions
diff --git a/php-laminas-uri.spec b/php-laminas-uri.spec
index b2bb2bf..1fb8b87 100644
--- a/php-laminas-uri.spec
+++ b/php-laminas-uri.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 6be8ce19622f359b048ce4faebf1aa1bca73a7ff
+%global gh_commit 8651611b6285529f25a4cb9a466c686d9b31468e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-uri
@@ -23,8 +23,8 @@
%endif
Name: php-%{gh_project}
-Version: 2.7.1
-Release: 2%{?dist}
+Version: 2.8.0
+Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
License: BSD
@@ -32,18 +32,15 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://github.com/laminas/laminas-uri/commit/dd2561ed82692212fca4d71ec94a58bae04a1524.patch
-Patch1: https://patch-diff.githubusercontent.com/raw/laminas/laminas-uri/pull/8.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
+# "laminas/laminas-coding-standard": "^2.1",
+# "phpunit/phpunit": "^9.3"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-escaper) >= 2.5 with php-autoloader(%{gh_owner}/laminas-escaper) < 3)
@@ -55,18 +52,18 @@ BuildRequires: php-laminas-escaper
BuildRequires: php-laminas-validator
BuildRequires: php-laminas-zendframework-bridge
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.4
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-escaper": "^2.5",
# "laminas/laminas-validator": "^2.10",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-escaper) >= 2.5 with php-autoloader(%{gh_owner}/laminas-escaper) < 3)
@@ -106,8 +103,6 @@ Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
-%patch1 -p1
mv LICENSE.md LICENSE
@@ -159,10 +154,10 @@ exit (class_exists("\\Zend\\%{library}\\File") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -182,6 +177,11 @@ exit $ret
%changelog
+* Mon Nov 2 2020 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Fri Jan 17 2020 Remi Collet <remi@remirepo.net> - 2.7.1-2
- cleanup