summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-29 07:20:19 +0200
committerRemi Collet <remi@remirepo.net>2021-06-29 07:20:19 +0200
commit5b79af4cd414a1648e87ebfc5e58c41b8bcc5f40 (patch)
treeb7eb8a22775e805861c63f4e27a2d982f762bbfb
parentbb4dd0f5b899c6a6cebeff704324d37d3317b05d (diff)
update to 3.4.0
-rw-r--r--composer.json7
-rw-r--r--php-laminas-stdlib.spec20
2 files changed, 16 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index b2e28d1..b881a0f 100644
--- a/composer.json
+++ b/composer.json
@@ -25,9 +25,11 @@
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-coding-standard": "~2.3.0",
"phpbench/phpbench": "^0.17.1",
- "phpunit/phpunit": "~9.3.7"
+ "phpunit/phpunit": "~9.3.7",
+ "psalm/plugin-phpunit": "^0.16.0",
+ "vimeo/psalm": "^4.7"
},
"autoload": {
"psr-4": {
@@ -47,6 +49,7 @@
],
"cs-check": "phpcs",
"cs-fix": "phpcbf",
+ "static-analysis": "psalm --shepherd --stats",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
diff --git a/php-laminas-stdlib.spec b/php-laminas-stdlib.spec
index c2d7b0b..bdc9da8 100644
--- a/php-laminas-stdlib.spec
+++ b/php-laminas-stdlib.spec
@@ -1,6 +1,6 @@
# remirepo/Fedora spec file for php-laminas-stdlib
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -13,7 +13,7 @@
%bcond_without tests
%endif
-%global gh_commit d81c7ffe602ed0e6ecb18691019111c0f4bf1efe
+%global gh_commit e89c2268c9cad25099f562f7f015c28c5dd383c9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-stdlib
@@ -23,7 +23,7 @@
%global library Stdlib
Name: php-%{gh_project}
-Version: 3.3.1
+Version: 3.4.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -50,14 +50,16 @@ BuildRequires: php-pcre
BuildRequires: php-posix
BuildRequires: php-spl
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-coding-standard": "~2.3.0",
# "phpbench/phpbench": "^0.17.1",
-# "phpunit/phpunit": "~9.3.7"
+# "phpunit/phpunit": "~9.3.7",
+# "psalm/plugin-phpunit": "^0.16.0",
+# "vimeo/psalm": "^4.7"
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.3.7
+%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
-%endif
# From composer, "require": {
# "php": "^7.3 || ^8.0",
@@ -141,9 +143,6 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
-# until phpunit 9.4.4
-find test -name \*php -exec sed '/@group/d' -i {} \;
-
: upstream test suite
ret=0
for cmdarg in "php %{phpunit}" php73 php74 php80; do
@@ -179,6 +178,9 @@ exit $ret
%changelog
+* Tue Jun 29 2021 Remi Collet <remi@remirepo.net> - 3.4.0-1
+- update to 3.4.0
+
* Mon Nov 23 2020 Remi Collet <remi@remirepo.net> - 3.3.1-1
- update to 3.3.1