summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-23 10:48:34 +0100
committerRemi Collet <remi@remirepo.net>2020-11-23 10:48:34 +0100
commitbb4dd0f5b899c6a6cebeff704324d37d3317b05d (patch)
treef46e791508c3c0fc06e40baa4dcf1684298c6038
parent24b54c389eb553228631e278c99fda7849d7d129 (diff)
update to 3.3.1
-rw-r--r--composer.json6
-rw-r--r--php-laminas-stdlib.spec17
2 files changed, 14 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 3f3031d..b2e28d1 100644
--- a/composer.json
+++ b/composer.json
@@ -19,10 +19,6 @@
"sort-packages": true
},
"extra": {
- "branch-alias": {
- "dev-master": "3.3.x-dev",
- "dev-develop": "3.4.x-dev"
- }
},
"require": {
"php": "^7.3 || ^8.0",
@@ -31,7 +27,7 @@
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
"phpbench/phpbench": "^0.17.1",
- "phpunit/phpunit": "^9.3.7"
+ "phpunit/phpunit": "~9.3.7"
},
"autoload": {
"psr-4": {
diff --git a/php-laminas-stdlib.spec b/php-laminas-stdlib.spec
index 046ebd4..c2d7b0b 100644
--- a/php-laminas-stdlib.spec
+++ b/php-laminas-stdlib.spec
@@ -13,7 +13,7 @@
%bcond_without tests
%endif
-%global gh_commit b9d84eaa39fde733356ea948cdef36c631f202b6
+%global gh_commit d81c7ffe602ed0e6ecb18691019111c0f4bf1efe
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-stdlib
@@ -23,7 +23,7 @@
%global library Stdlib
Name: php-%{gh_project}
-Version: 3.3.0
+Version: 3.3.1
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -52,7 +52,7 @@ BuildRequires: php-spl
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
# "phpbench/phpbench": "^0.17.1",
-# "phpunit/phpunit": "^9.3.7"
+# "phpunit/phpunit": "~9.3.7"
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.3.7
# Autoloader
@@ -141,12 +141,18 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
+# until phpunit 9.4.4
+find test -name \*php -exec sed '/@group/d' -i {} \;
+
: upstream test suite
ret=0
for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
+ if [ $($1 -r 'echo PHP_VERSION_ID;') -ge 80000 ]; then
+ filter="--filter '^((?!(testReturnCatchedError|testThrowCatchedError|testCount)).)*$'"
+ fi
+ $1 ${2:-%{_bindir}/phpunit9} $filter --verbose || ret=1
fi
done
@@ -173,6 +179,9 @@ exit $ret
%changelog
+* Mon Nov 23 2020 Remi Collet <remi@remirepo.net> - 3.3.1-1
+- update to 3.3.1
+
* Tue Aug 25 2020 Remi Collet <remi@remirepo.net> - 3.3.0-1
- update to 3.3.0
- raise dependency on PHP 7.3