summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-08-04 08:56:21 +0200
committerRemi Collet <remi@remirepo.net>2021-08-04 08:56:21 +0200
commit4535b22d8c40ae90555aae5e2a427f979a82fafb (patch)
treea29bfd2955c2a716a073597f1fe9835ece4a7724
parent5b79af4cd414a1648e87ebfc5e58c41b8bcc5f40 (diff)
update to 3.5.0 (no change)
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader
-rw-r--r--composer.json7
-rw-r--r--php-laminas-stdlib.spec15
2 files changed, 13 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index b881a0f..9046c3a 100644
--- a/composer.json
+++ b/composer.json
@@ -21,8 +21,7 @@
"extra": {
},
"require": {
- "php": "^7.3 || ^8.0",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "php": "^7.3 || ^8.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~2.3.0",
@@ -53,7 +52,7 @@
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zend-stdlib": "^3.2.1"
+ "conflict": {
+ "zendframework/zend-stdlib": "*"
}
}
diff --git a/php-laminas-stdlib.spec b/php-laminas-stdlib.spec
index bdc9da8..2d9877c 100644
--- a/php-laminas-stdlib.spec
+++ b/php-laminas-stdlib.spec
@@ -13,7 +13,7 @@
%bcond_without tests
%endif
-%global gh_commit e89c2268c9cad25099f562f7f015c28c5dd383c9
+%global gh_commit c8ac6a76a133e682acfabc821d4a2ec646934b12
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-stdlib
@@ -23,7 +23,7 @@
%global library Stdlib
Name: php-%{gh_project}
-Version: 3.4.0
+Version: 3.5.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -62,11 +62,11 @@ BuildRequires: phpunit9 >= 9.3.7
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ^8.0",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "php": "^7.3 || ^8.0"
Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+# only require for compatibility layer
Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
# remirepo:3
%else
@@ -145,7 +145,7 @@ EOF
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
if [ $($1 -r 'echo PHP_VERSION_ID;') -ge 80000 ]; then
@@ -178,6 +178,11 @@ exit $ret
%changelog
+* Wed Aug 4 2021 Remi Collet <remi@remirepo.net> - 3.5.0-1
+- update to 3.5.0 (no change)
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
* Tue Jun 29 2021 Remi Collet <remi@remirepo.net> - 3.4.0-1
- update to 3.4.0