summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-07 15:35:33 +0100
committerRemi Collet <remi@php.net>2021-12-07 15:35:33 +0100
commitec29a3bd7e7ed9e16a11f7c4c99c86e6476ec240 (patch)
treed885f156c6eb6908821f1bc5ba4db2a75651f404
parent780cabe5258411a4115950ef6a493f4b39574b92 (diff)
update to 2.12.0 (no change)
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader
-rw-r--r--composer.json7
-rw-r--r--php-laminas-serializer.spec14
2 files changed, 12 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index af6ca91..57dde78 100644
--- a/composer.json
+++ b/composer.json
@@ -27,8 +27,7 @@
"require": {
"php": "^7.3 || ~8.0.0 || ~8.1.0",
"laminas/laminas-json": "^3.1",
- "laminas/laminas-stdlib": "^3.2",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "laminas/laminas-stdlib": "^3.2"
},
"require-dev": {
"laminas/laminas-coding-standard": "~2.3.0",
@@ -60,7 +59,7 @@
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zend-serializer": "^2.9.1"
+ "conflict": {
+ "zendframework/zend-serializer": "*"
}
}
diff --git a/php-laminas-serializer.spec b/php-laminas-serializer.spec
index 0fefd43..4f0f6d4 100644
--- a/php-laminas-serializer.spec
+++ b/php-laminas-serializer.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit a76e3a341a1a4993fd88e1d3587b93d60406d08e
+%global gh_commit 2826fd71f202569c169456a4b84297da9ff630cd
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-serializer
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.11.0
+Version: 2.12.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -69,8 +69,7 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^7.3 || ~8.0.0|| ~8.1.0"",
# "laminas/laminas-json": "^3.1",
-# "laminas/laminas-stdlib": "^3.2",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "laminas/laminas-stdlib": "^3.2"
Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
@@ -170,7 +169,7 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -200,6 +199,11 @@ exit $ret
%changelog
+* Tue Dec 7 2021 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0 (no change)
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
* Mon Oct 25 2021 Remi Collet <remi@remirepo.net> - 2.11.0-1
- update to 2.11.0