summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-25 11:57:10 +0200
committerRemi Collet <remi@php.net>2021-10-25 11:57:10 +0200
commit780cabe5258411a4115950ef6a493f4b39574b92 (patch)
treedd0ef97f39f46b63916ce912e34adb3f6a6b1526
parentdeb2968f8fb16ee26edfd65d84f28858a00c91fe (diff)
update to 2.11.0
-rw-r--r--composer.json4
-rw-r--r--php-laminas-serializer.spec13
2 files changed, 10 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 23eb52d..af6ca91 100644
--- a/composer.json
+++ b/composer.json
@@ -25,13 +25,13 @@
}
},
"require": {
- "php": "^7.3 || ~8.0.0",
+ "php": "^7.3 || ~8.0.0 || ~8.1.0",
"laminas/laminas-json": "^3.1",
"laminas/laminas-stdlib": "^3.2",
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-coding-standard": "~2.3.0",
"laminas/laminas-math": "^3.3",
"laminas/laminas-servicemanager": "^3.6",
"phpunit/phpunit": "^9.3"
diff --git a/php-laminas-serializer.spec b/php-laminas-serializer.spec
index 2f6a5d1..0fefd43 100644
--- a/php-laminas-serializer.spec
+++ b/php-laminas-serializer.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 254cf6a17b46d98808c0810939268f63538dcc0c
+%global gh_commit a76e3a341a1a4993fd88e1d3587b93d60406d08e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-serializer
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.10.1
+Version: 2.11.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -41,7 +41,7 @@ BuildRequires: php-pcre
BuildRequires: php-simplexml
BuildRequires: php-spl
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-coding-standard": "~2.3.0",
# "laminas/laminas-math": "^3.3",
# "laminas/laminas-servicemanager": "^3.6",
# "phpunit/phpunit": "^9.3"
@@ -67,7 +67,7 @@ BuildRequires: phpunit9 >= 9.3
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
+# "php": "^7.3 || ~8.0.0|| ~8.1.0"",
# "laminas/laminas-json": "^3.1",
# "laminas/laminas-stdlib": "^3.2",
# "laminas/laminas-zendframework-bridge": "^1.0"
@@ -170,7 +170,7 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -200,6 +200,9 @@ exit $ret
%changelog
+* Mon Oct 25 2021 Remi Collet <remi@remirepo.net> - 2.11.0-1
+- update to 2.11.0
+
* Thu Feb 25 2021 Remi Collet <remi@remirepo.net> - 2.10.1-1
- update to 2.10.1
- raise dependency on PHP 7.3