summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-04-12 08:30:13 +0200
committerRemi Collet <remi@php.net>2022-04-12 08:30:13 +0200
commitc5c7e8c702b54401d40cc17e35136e467339b2fa (patch)
treebb0e3592819443017c82dc530948ac568edc4421
parentec29a3bd7e7ed9e16a11f7c4c99c86e6476ec240 (diff)
update to 2.13.0
raise dependency on PHP 7.4
-rw-r--r--composer.json10
-rw-r--r--php-laminas-serializer.spec16
2 files changed, 18 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 57dde78..8d91b11 100644
--- a/composer.json
+++ b/composer.json
@@ -16,7 +16,13 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ },
+ "platform": {
+ "php": "7.4"
+ }
},
"extra": {
"laminas": {
@@ -25,7 +31,7 @@
}
},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0",
+ "php": "^7.4 || ~8.0.0 || ~8.1.0",
"laminas/laminas-json": "^3.1",
"laminas/laminas-stdlib": "^3.2"
},
diff --git a/php-laminas-serializer.spec b/php-laminas-serializer.spec
index 4f0f6d4..8339bad 100644
--- a/php-laminas-serializer.spec
+++ b/php-laminas-serializer.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-php-laminas-serializer
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 2826fd71f202569c169456a4b84297da9ff630cd
+%global gh_commit aa72a694d79f01ef1252b276ca9930158c3b877d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-serializer
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.12.0
+Version: 2.13.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 7.4
BuildRequires: php-dom
BuildRequires: php-libxml
BuildRequires: php-pcre
@@ -67,10 +67,10 @@ BuildRequires: phpunit9 >= 9.3
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0|| ~8.1.0"",
+# "php": "^7.4 || ~8.0.0|| ~8.1.0"",
# "laminas/laminas-json": "^3.1",
# "laminas/laminas-stdlib": "^3.2"
-Requires: php(language) >= 7.3
+Requires: php(language) >= 7.4
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -199,6 +199,10 @@ exit $ret
%changelog
+* Tue Apr 12 2022 Remi Collet <remi@remirepo.net> - 2.13.0-1
+- update to 2.13.0
+- raise dependency on PHP 7.4
+
* Tue Dec 7 2021 Remi Collet <remi@remirepo.net> - 2.12.0-1
- update to 2.12.0 (no change)
- keep compatibility using laminas-zendframework-bridge