summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-06 08:16:27 +0100
committerRemi Collet <remi@php.net>2022-12-06 08:16:27 +0100
commitc5d03dafeb39e29234fe10ef16e6243e71a6da8a (patch)
tree61a3928615a7e136dc928d26f801a5413328bd85
parent492bf8d88d0ee3dcc195e75be71f0fc41b485678 (diff)
update to 3.11.0
-rw-r--r--composer.json8
-rw-r--r--php-laminas-router.spec17
2 files changed, 14 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index c3e21db..a515a2f 100644
--- a/composer.json
+++ b/composer.json
@@ -38,10 +38,10 @@
},
"require-dev": {
"laminas/laminas-coding-standard": "~2.4.0",
- "laminas/laminas-i18n": "^2.17",
- "phpunit/phpunit": "^9.5.25",
- "psalm/plugin-phpunit": "^0.17.0",
- "vimeo/psalm": "^4.28"
+ "laminas/laminas-i18n": "^2.19.0",
+ "phpunit/phpunit": "^9.5.26",
+ "psalm/plugin-phpunit": "^0.18.0",
+ "vimeo/psalm": "^5.0.0"
},
"suggest": {
"laminas/laminas-i18n": "^2.15.0 if defining translatable HTTP path segments"
diff --git a/php-laminas-router.spec b/php-laminas-router.spec
index 1998e5a..7922bc2 100644
--- a/php-laminas-router.spec
+++ b/php-laminas-router.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 84aa1047389270cc2b05e2fe85667efb592fbf5e
+%global gh_commit 48b6fccd63b9e04e67781c212bf3bedd75c9ca17
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-router
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.10.0
+Version: 3.11.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -45,11 +45,11 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.10
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~2.4.0",
-# "laminas/laminas-i18n": "^2.17",
-# "phpunit/phpunit": "^9.5.25",
-# "psalm/plugin-phpunit": "^0.17.0",
-# "vimeo/psalm": "^4.28"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.17 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
+# "laminas/laminas-i18n": "^2.19.0",
+# "phpunit/phpunit": "^9.5.26",
+# "psalm/plugin-phpunit": "^0.18.0",
+# "vimeo/psalm": "^5.0.0"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.19 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
# remirepo:7
%else
BuildRequires: php-laminas-http
@@ -206,6 +206,9 @@ exit $ret
%changelog
+* Tue Dec 6 2022 Remi Collet <remi@remirepo.net> - 3.11.0-1
+- update to 3.11.0
+
* Tue Oct 11 2022 Remi Collet <remi@remirepo.net> - 3.10.0-1
- update to 3.10.0
- raise dependency on PHP 8.0