summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-11 09:29:56 +0200
committerRemi Collet <remi@php.net>2022-10-11 09:29:56 +0200
commit492bf8d88d0ee3dcc195e75be71f0fc41b485678 (patch)
treefbb7fb1a13ec2021296e783daf67e811e3cfb76c
parent5de888651fc0815716d97f47add34395ba681610 (diff)
update to 3.10.0
raise dependency on PHP 8.0
-rw-r--r--composer.json10
-rw-r--r--php-laminas-router.spec24
2 files changed, 19 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index 0a00cd4..c3e21db 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "7.4.99"
+ "php": "8.0.99"
},
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
@@ -31,17 +31,17 @@
}
},
"require": {
- "php": "^7.4 || ~8.0.0 || ~8.1.0",
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
"laminas/laminas-http": "^2.15",
"laminas/laminas-servicemanager": "^3.14.0",
"laminas/laminas-stdlib": "^3.10.1"
},
"require-dev": {
"laminas/laminas-coding-standard": "~2.4.0",
- "laminas/laminas-i18n": "^2.15.0",
- "phpunit/phpunit": "^9.5.5",
+ "laminas/laminas-i18n": "^2.17",
+ "phpunit/phpunit": "^9.5.25",
"psalm/plugin-phpunit": "^0.17.0",
- "vimeo/psalm": "^4.24.0"
+ "vimeo/psalm": "^4.28"
},
"suggest": {
"laminas/laminas-i18n": "^2.15.0 if defining translatable HTTP path segments"
diff --git a/php-laminas-router.spec b/php-laminas-router.spec
index ac19580..1998e5a 100644
--- a/php-laminas-router.spec
+++ b/php-laminas-router.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit ebd084f7fda7520394b9ddc1e9ec2cbdf2094daa
+%global gh_commit 84aa1047389270cc2b05e2fe85667efb592fbf5e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-router
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.9.0
+Version: 3.10.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 8.0
BuildRequires: php-pcre
BuildRequires: php-spl
# remirepo:1
@@ -45,11 +45,11 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.10
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~2.4.0",
-# "laminas/laminas-i18n": "^2.15.0",
-# "phpunit/phpunit": "^9.5.5",
+# "laminas/laminas-i18n": "^2.17",
+# "phpunit/phpunit": "^9.5.25",
# "psalm/plugin-phpunit": "^0.17.0",
-# "vimeo/psalm": "^4.24"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.15.0 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
+# "vimeo/psalm": "^4.28"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.17 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
# remirepo:7
%else
BuildRequires: php-laminas-http
@@ -65,11 +65,11 @@ BuildRequires: phpunit9 >= 9.5.5
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "laminas/laminas-http": "^2.15",
# "laminas/laminas-servicemanager": "^3.14.0",
# "laminas/laminas-stdlib": "^3.10.1"
-Requires: php(language) >= 7.4
+Requires: php(language) >= 8.0
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -183,7 +183,7 @@ exit (class_exists("\\Zend\\%{library}\\RouterFactory") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 -d memory_limit=1G ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -206,6 +206,10 @@ exit $ret
%changelog
+* Tue Oct 11 2022 Remi Collet <remi@remirepo.net> - 3.10.0-1
+- update to 3.10.0
+- raise dependency on PHP 8.0
+
* Tue Sep 20 2022 Remi Collet <remi@remirepo.net> - 3.9.0-1
- update to 3.9.0