summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-29 10:34:58 +0200
committerRemi Collet <remi@php.net>2021-10-29 10:34:58 +0200
commit27439e4eaa66abc73772573eb3e40388ab4aa835 (patch)
treeacdc8869173494a1c5d3e86f43f63d29174c10cc
parent8db5fc835195d581213f055c7827ee47c6da71ea (diff)
update to 1.5.0 (no change)
-rw-r--r--composer.json7
-rw-r--r--php-laminas-psr7bridge.spec11
2 files changed, 13 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index 21024af..2a916d7 100644
--- a/composer.json
+++ b/composer.json
@@ -31,7 +31,9 @@
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^9.5.10"
+ "phpunit/phpunit": "^9.5.10",
+ "psalm/plugin-phpunit": "^0.16.1",
+ "vimeo/psalm": "^4.11"
},
"conflict": {
"laminas/laminas-stdlib": "< 3.2.1"
@@ -54,7 +56,8 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "static-analysis": "psalm --shepherd --stats"
},
"replace": {
"zendframework/zend-psr7bridge": "^1.2.0"
diff --git a/php-laminas-psr7bridge.spec b/php-laminas-psr7bridge.spec
index 3c2d3db..3194c4f 100644
--- a/php-laminas-psr7bridge.spec
+++ b/php-laminas-psr7bridge.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 993dd79beca509c8a93ebd9bac4cbfeacd831c29
+%global gh_commit a560f42d66fc11b0b05e7d2103e69e434365e7c1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-psr7bridge
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 1.4.0
+Version: 1.5.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -54,7 +54,9 @@ BuildRequires: php-psr-http-message
%endif
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^9.5.10"
+# "phpunit/phpunit": "^9.5.10",
+# "psalm/plugin-phpunit": "^0.16.1",
+# "vimeo/psalm": "^4.11"
BuildRequires: phpunit9 >= 9.5.10
%endif
# Autoloader
@@ -180,6 +182,9 @@ exit $ret
%changelog
+* Fri Oct 29 2021 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0 (no change)
+
* Tue Oct 26 2021 Remi Collet <remi@remirepo.net> - 1.4.0-1
- update to 1.4.0
- raise dependency on laminas-http 2.15