summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-26 15:08:07 +0200
committerRemi Collet <remi@php.net>2021-10-26 15:08:07 +0200
commit8db5fc835195d581213f055c7827ee47c6da71ea (patch)
treee3d520536afe04d7f05eb514ec7d85286c637fe6
parentb5064798889ad9035ab204e2a303930a9ce97222 (diff)
update to 1.4.0
raise dependency on laminas-http 2.15
-rw-r--r--composer.json8
-rw-r--r--php-laminas-psr7bridge.spec22
2 files changed, 17 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index 62fb1cb..21024af 100644
--- a/composer.json
+++ b/composer.json
@@ -1,6 +1,6 @@
{
"name": "laminas/laminas-psr7bridge",
- "description": "PSR-7 &lt;-&gt; laminas-http message conversions",
+ "description": "Bidirectional conversions between PSR-7 and laminas-http messages",
"license": "BSD-3-Clause",
"keywords": [
"laminas",
@@ -23,15 +23,15 @@
"extra": {
},
"require": {
- "php": "^7.3 || ~8.0.0",
+ "php": "^7.3 || ~8.0.0 || ~8.1.0",
"laminas/laminas-diactoros": "^1.7 || ^2.0",
- "laminas/laminas-http": "^2.11",
+ "laminas/laminas-http": "^2.15",
"laminas/laminas-zendframework-bridge": "^1.0",
"psr/http-message": "^1.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^9.4.1"
+ "phpunit/phpunit": "^9.5.10"
},
"conflict": {
"laminas/laminas-stdlib": "< 3.2.1"
diff --git a/php-laminas-psr7bridge.spec b/php-laminas-psr7bridge.spec
index b1043f0..3c2d3db 100644
--- a/php-laminas-psr7bridge.spec
+++ b/php-laminas-psr7bridge.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit b1158f0574164039f698a261c01c26119cc6dbd6
+%global gh_commit 993dd79beca509c8a93ebd9bac4cbfeacd831c29
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-psr7bridge
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 1.3.1
+Version: 1.4.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -42,7 +42,7 @@ BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-diactoros) >= 1.7 with php-autoloader(%{gh_owner}/laminas-diactoros) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.11 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.15 with php-autoloader(%{gh_owner}/laminas-http) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
# remirepo:6
@@ -54,23 +54,23 @@ BuildRequires: php-psr-http-message
%endif
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^9.4.1"
-BuildRequires: phpunit9 >= 9.4.1
+# "phpunit/phpunit": "^9.5.10"
+BuildRequires: phpunit9 >= 9.5.10
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
+# "php": "^7.3 || ~8.0.0 || ~8.1.0",
# "laminas/laminas-diactoros": "^1.7 || ^2.0",
-# "laminas/laminas-http": "^2.11",
+# "laminas/laminas-http": "^2.15",
# "laminas/laminas-zendframework-bridge": "^1.0",
# "psr/http-message": "^1.0"
Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-diactoros) >= 1.7 with php-autoloader(%{gh_owner}/laminas-diactoros) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.11 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.15 with php-autoloader(%{gh_owner}/laminas-http) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
Requires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
# remirepo:6
@@ -158,7 +158,7 @@ exit (class_exists("\\Zend\\%{library}\\Psr7Response") ? 0 : 1);
: upstream test suite
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php73 php74 php80 php81; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 || ret=1
fi
@@ -180,6 +180,10 @@ exit $ret
%changelog
+* Tue Oct 26 2021 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0
+- raise dependency on laminas-http 2.15
+
* Wed Apr 14 2021 Remi Collet <remi@remirepo.net> - 1.3.1-1
- update to 1.3.1 (no change)