summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-07 16:09:35 +0100
committerRemi Collet <remi@php.net>2021-12-07 16:09:35 +0100
commit72e5543ca63f348079224276dfe773fee33be7f0 (patch)
tree20f183f14e40209894d8a1f6d8148177ff8db5a3
parentefc3719dc523d0a23b70e67d4d8c724a4c7728d2 (diff)
update to 2.9.0
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader
-rw-r--r--composer.json7
-rw-r--r--php-laminas-progressbar.spec14
2 files changed, 12 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 8b8cc4e..1027824 100644
--- a/composer.json
+++ b/composer.json
@@ -20,8 +20,7 @@
},
"require": {
"php": "^7.3 || ~8.0.0",
- "laminas/laminas-stdlib": "^3.2.1",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "laminas/laminas-stdlib": "^3.2.1"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
@@ -53,7 +52,7 @@
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zend-progressbar": "^2.7.0"
+ "conflict": {
+ "zendframework/zend-progressbar": "*"
}
}
diff --git a/php-laminas-progressbar.spec b/php-laminas-progressbar.spec
index 1d509c3..991043a 100644
--- a/php-laminas-progressbar.spec
+++ b/php-laminas-progressbar.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 44efc8a9c766329d5200f52c3ebf70dffeaf0feb
+%global gh_commit de3c203c59e0cc5b06e79683172841179dcb633c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-progressbar
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.8.0
+Version: 2.9.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -65,8 +65,7 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^7.3 || ~8.0.0",
-# "laminas/laminas-stdlib": "^3.2.1",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "laminas/laminas-stdlib": "^3.2.1"
Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
@@ -171,7 +170,7 @@ exit (class_exists("\\Zend\\%{library}\\ProgressBar") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -194,6 +193,11 @@ exit $ret
%changelog
+* Tue Dec 7 2021 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
* Thu Feb 25 2021 Remi Collet <remi@remirepo.net> - 2.8.0-1
- update to 2.8.0
- raise dependency on PHP 7.3