summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-02-25 08:52:27 +0100
committerRemi Collet <remi@remirepo.net>2021-02-25 08:52:27 +0100
commitefc3719dc523d0a23b70e67d4d8c724a4c7728d2 (patch)
tree49045e677f1469d97dc6167ced976f19a505bfa1
parentdc079a3a34ba95822e6709fec4c0ddb9fa0fd4e4 (diff)
update to 2.8.0
raise dependency on PHP 7.3 switch to phpunit9
-rw-r--r--composer.json12
-rw-r--r--php-laminas-progressbar.spec32
2 files changed, 22 insertions, 22 deletions
diff --git a/composer.json b/composer.json
index af2cd29..8b8cc4e 100644
--- a/composer.json
+++ b/composer.json
@@ -18,14 +18,8 @@
"config": {
"sort-packages": true
},
- "extra": {
- "branch-alias": {
- "dev-master": "2.7.x-dev",
- "dev-develop": "2.8.x-dev"
- }
- },
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"laminas/laminas-stdlib": "^3.2.1",
"laminas/laminas-zendframework-bridge": "^1.0"
},
@@ -33,7 +27,7 @@
"laminas/laminas-coding-standard": "~1.0.0",
"laminas/laminas-json": "^2.6.1",
"laminas/laminas-session": "^2.8.5",
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
+ "phpunit/phpunit": "^9.3"
},
"suggest": {
"laminas/laminas-json": "Laminas\\Json component",
@@ -60,6 +54,6 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-progressbar": "self.version"
+ "zendframework/zend-progressbar": "^2.7.0"
}
}
diff --git a/php-laminas-progressbar.spec b/php-laminas-progressbar.spec
index 64cab95..1d509c3 100644
--- a/php-laminas-progressbar.spec
+++ b/php-laminas-progressbar.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-progressbar
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 15f9e983276462f30d7d38660dc7488c6e3df34b
+%global gh_commit 44efc8a9c766329d5200f52c3ebf70dffeaf0feb
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-progressbar
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.7.0
+Version: 2.8.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-date
BuildRequires: php-pcre
BuildRequires: php-spl
@@ -46,7 +46,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# "laminas/laminas-coding-standard": "~1.0.0",
# "laminas/laminas-json": "^2.6.1",
# "laminas/laminas-session": "^2.8.5",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
+# "phpunit/phpunit": "^9.3"
# ignore max version
BuildRequires: (php-autoloader(%{gh_owner}/laminas-json) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-json) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.8.5 with php-autoloader(%{gh_owner}/laminas-session) < 3)
@@ -57,17 +57,17 @@ BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-laminas-json
BuildRequires: php-laminas-session
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.4
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-stdlib": "^3.2.1",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -92,11 +92,12 @@ Requires: php-pcre
Requires: php-spl
# apc and uploadprogress are optional
+# remirepo:2
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 2.7.0-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 2.7.1
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -170,10 +171,10 @@ exit (class_exists("\\Zend\\%{library}\\ProgressBar") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -193,6 +194,11 @@ exit $ret
%changelog
+* Thu Feb 25 2021 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Tue Jan 14 2020 Remi Collet <remi@remirepo.net> - 2.7.0-1
- switch to Laminas