summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-16 10:20:11 +0100
committerRemi Collet <remi@php.net>2022-11-16 10:20:11 +0100
commit077c028a9b14f814d62cce174c0c939408b30a91 (patch)
treebfe8a0cee55f33fb6a0feb6921abb45735f52537
parentdeff79e467fb05e641e37dea35f41ee6c45f9f7c (diff)
update to 3.4.0 (no change)HEADmaster
raise dependency on PHP 8.0
-rw-r--r--composer.json12
-rw-r--r--php-laminas-permissions-rbac.spec24
2 files changed, 20 insertions, 16 deletions
diff --git a/composer.json b/composer.json
index ea7fc5a..c9a6770 100644
--- a/composer.json
+++ b/composer.json
@@ -20,20 +20,20 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "7.4.99"
+ "php": "8.0.99"
},
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
}
},
"require": {
- "php": "^7.4 || ~8.0.0 || ~8.1.0"
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~2.3.0",
- "phpunit/phpunit": "^9.5.21",
- "psalm/plugin-phpunit": "^0.17.0",
- "vimeo/psalm": "^4.24.0"
+ "laminas/laminas-coding-standard": "~2.4.0",
+ "phpunit/phpunit": "^9.5.26",
+ "psalm/plugin-phpunit": "^0.18.0",
+ "vimeo/psalm": "^4.29.0"
},
"autoload": {
"psr-4": {
diff --git a/php-laminas-permissions-rbac.spec b/php-laminas-permissions-rbac.spec
index bfbde5a..4b67485 100644
--- a/php-laminas-permissions-rbac.spec
+++ b/php-laminas-permissions-rbac.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 77011e721c1af3c4cede98df2f8c06944c0f0b67
+%global gh_commit b3c376fdc0eae3d5208280d57cd9bb766c3d85a0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-permissions-rbac
@@ -23,7 +23,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.3.0
+Version: 3.4.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj} component
@@ -35,16 +35,16 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 8.0
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~2.3.0",
-# "phpunit/phpunit": "^9.5.21",
-# "psalm/plugin-phpunit": "^0.17.0",
-# "vimeo/psalm": "^4.24.0"
+# "laminas/laminas-coding-standard": "~2.4.0",
+# "phpunit/phpunit": "^9.5.26",
+# "psalm/plugin-phpunit": "^0.18.0",
+# "vimeo/psalm": "^4.29.0"
# remirepo:3
%else
BuildRequires: php-laminas-zendframework-bridge
@@ -56,8 +56,8 @@ BuildRequires: phpunit9 >= 9.5.21
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.4 || ~8.0.0 || ~8.1.0"
-Requires: php(language) >= 7.4
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0"
+Requires: php(language) >= 8.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -135,7 +135,7 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\Role") ? 0 : 1);
: upstream test suite
ret=0
-for cmd in "php %{phpunit}" php74 php80 php81 php82; do
+for cmd in "php %{phpunit}" php80 php81 php82; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit9} \
@@ -161,6 +161,10 @@ exit $ret
%changelog
+* Wed Nov 16 2022 Remi Collet <remi@remirepo.net> - 3.4.0-1
+- update to 3.4.0 (no change)
+- raise dependency on PHP 8.0
+
* Fri Jul 22 2022 Remi Collet <remi@remirepo.net> - 3.3.0-1
- update to 3.3.0
- raise dependency on PHP 7.4