summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-22 11:33:17 +0200
committerRemi Collet <remi@php.net>2022-07-22 11:33:17 +0200
commitdeff79e467fb05e641e37dea35f41ee6c45f9f7c (patch)
treed6dd04bcb7b2559cd78d0ef2fb19886d9d61a38d
parent3043172644472b7c6a6e6e27b74c11c2697a68c1 (diff)
update to 3.3.0
raise dependency on PHP 7.4
-rw-r--r--composer.json18
-rw-r--r--php-laminas-permissions-rbac.spec28
2 files changed, 28 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index f6b2422..ea7fc5a 100644
--- a/composer.json
+++ b/composer.json
@@ -18,16 +18,22 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "platform": {
+ "php": "7.4.99"
+ },
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0"
+ "php": "^7.4 || ~8.0.0 || ~8.1.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^9.3",
- "psalm/plugin-phpunit": "^0.15.1",
- "vimeo/psalm": "^4.7"
+ "laminas/laminas-coding-standard": "~2.3.0",
+ "phpunit/phpunit": "^9.5.21",
+ "psalm/plugin-phpunit": "^0.17.0",
+ "vimeo/psalm": "^4.24.0"
},
"autoload": {
"psr-4": {
diff --git a/php-laminas-permissions-rbac.spec b/php-laminas-permissions-rbac.spec
index e7c1bf1..bfbde5a 100644
--- a/php-laminas-permissions-rbac.spec
+++ b/php-laminas-permissions-rbac.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-permissions-rbac
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit ce117f1d2fb8ec8ec6186633bf485a89149fe46f
+%global gh_commit 77011e721c1af3c4cede98df2f8c06944c0f0b67
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-permissions-rbac
@@ -23,7 +23,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.2.0
+Version: 3.3.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj} component
@@ -35,29 +35,29 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 7.4
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^9.3",
-# "psalm/plugin-phpunit": "^0.15.1",
-# "vimeo/psalm": "^4.7"
+# "laminas/laminas-coding-standard": "~2.3.0",
+# "phpunit/phpunit": "^9.5.21",
+# "psalm/plugin-phpunit": "^0.17.0",
+# "vimeo/psalm": "^4.24.0"
# remirepo:3
%else
BuildRequires: php-laminas-zendframework-bridge
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.3
+BuildRequires: phpunit9 >= 9.5.21
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0"
-Requires: php(language) >= 7.3
+# "php": "^7.4 || ~8.0.0 || ~8.1.0"
+Requires: php(language) >= 7.4
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -135,7 +135,7 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\Role") ? 0 : 1);
: upstream test suite
ret=0
-for cmd in "php %{phpunit}" php73 php74 php80 php81; do
+for cmd in "php %{phpunit}" php74 php80 php81 php82; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit9} \
@@ -161,6 +161,10 @@ exit $ret
%changelog
+* Fri Jul 22 2022 Remi Collet <remi@remirepo.net> - 3.3.0-1
+- update to 3.3.0
+- raise dependency on PHP 7.4
+
* Thu Oct 14 2021 Remi Collet <remi@remirepo.net> - 3.2.0-1
- update to 3.2.0 (no change)
- keep compatibility using laminas-zendframework-bridge