summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-04-14 08:03:17 +0200
committerRemi Collet <remi@remirepo.net>2021-04-14 08:03:17 +0200
commitea60a0d2207806c847c23a7e26f3c87f04525fbd (patch)
tree7daf1dfc38637919adf93c3e8533470665c78531
parent61a3c4daf16ea1b72ca464676a73309341d62bd0 (diff)
update to 1.2.0 (no change)
raise dependency on PHP 7.3 switch to phpunit9
-rw-r--r--composer.json11
-rw-r--r--php-laminas-mvc-plugin-identity.spec39
2 files changed, 29 insertions, 21 deletions
diff --git a/composer.json b/composer.json
index 93ae06e..8872b15 100644
--- a/composer.json
+++ b/composer.json
@@ -19,16 +19,12 @@
"sort-packages": true
},
"extra": {
- "branch-alias": {
- "dev-master": "1.1.x-dev",
- "dev-develop": "1.2.x-dev"
- },
"laminas": {
"component": "Laminas\\Mvc\\Plugin\\Identity"
}
},
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"container-interop/container-interop": "^1.1",
"laminas/laminas-authentication": "^2.5.3",
"laminas/laminas-mvc": "^3.0",
@@ -37,7 +33,8 @@
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
+ "phpspec/prophecy-phpunit": "^2.0",
+ "phpunit/phpunit": "^9.5"
},
"conflict": {
"laminas/laminas-mvc": "<3.0.0"
@@ -63,6 +60,6 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-mvc-plugin-identity": "self.version"
+ "zendframework/zend-mvc-plugin-identity": "^1.1.1"
}
}
diff --git a/php-laminas-mvc-plugin-identity.spec b/php-laminas-mvc-plugin-identity.spec
index dddd2d6..4d3ea92 100644
--- a/php-laminas-mvc-plugin-identity.spec
+++ b/php-laminas-mvc-plugin-identity.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-mvc-plugin-identity
#
-# Copyright (c) 2016-2020 Remi Collet
+# Copyright (c) 2016-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 0dc0c349be0faee67bbb4ae2a0206435a7a51516
+%global gh_commit 75cf6df47aef315521eb390ab1478e586fda4ec8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mvc-plugin-identity
@@ -24,7 +24,7 @@
%endif
Name: php-%{gh_project}
-Version: 1.1.1
+Version: 1.2.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj}/%{subsubp} component
@@ -36,7 +36,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -47,29 +47,32 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
-# remirepo:7
+# "phpspec/prophecy-phpunit": "^2.0",
+# "phpunit/phpunit": "^9.5"
+BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
+# remirepo:8
%else
BuildRequires: php-container-interop
BuildRequires: php-laminas-authentication
BuildRequires: php-laminas-mvc
BuildRequires: php-laminas-servicemanager
BuildRequires: php-laminas-zendframework-bridge
+BuildRequires: php-phpspec-prophecy-phpunit
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.4
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.5
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "container-interop/container-interop": "^1.1",
# "laminas/laminas-authentication": "^2.5.3",
# "laminas/laminas-mvc": "^3.0",
# "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
@@ -91,8 +94,8 @@ Requires: php-composer(fedora/autoloader)
Requires: php-spl
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 1.1.1-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 1.1.2
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -151,6 +154,9 @@ cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/%{subproj}/%{subsubp}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\%{subproj}\\%{subsubp}\\', dirname(__DIR__) . '/test');
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Prophecy/PhpUnit/autoload.php',
+]);
EOF
: check compat autoloader
@@ -161,10 +167,10 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\%{subsubp}\\Module") ? 0 : 1
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -186,6 +192,11 @@ exit $ret
%changelog
+* Wed Apr 14 2021 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update to 1.2.0 (no change)
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Thu Jan 16 2020 Remi Collet <remi@remirepo.net> - 1.1.1-1
- switch to Laminas