summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-16 11:50:36 +0100
committerRemi Collet <remi@remirepo.net>2020-01-16 11:50:36 +0100
commit61a3c4daf16ea1b72ca464676a73309341d62bd0 (patch)
tree5db998894433281bf46d60d3158866aba0bec78d
parentde40de892f7d1875aa654de09cf6aa79b0570c24 (diff)
switch to Laminas
-rw-r--r--composer.json64
-rw-r--r--php-laminas-mvc-plugin-identity.spec157
2 files changed, 123 insertions, 98 deletions
diff --git a/composer.json b/composer.json
index bc6be02..93ae06e 100644
--- a/composer.json
+++ b/composer.json
@@ -1,54 +1,55 @@
{
- "name": "zendframework/zend-mvc-plugin-identity",
- "description": "Plugin for retrieving the current authenticated identity within zend-mvc controllers",
+ "name": "laminas/laminas-mvc-plugin-identity",
+ "description": "Plugin for retrieving the current authenticated identity within laminas-mvc controllers",
"license": "BSD-3-Clause",
"keywords": [
- "zf",
- "zendframework",
+ "laminas",
"mvc"
],
+ "homepage": "https://laminas.dev",
"support": {
- "docs": "https://docs.zendframework.com/zend-mvc-plugin-identity/",
- "issues": "https://github.com/zendframework/zend-mvc-plugin-identity/issues",
- "source": "https://github.com/zendframework/zend-mvc-plugin-identity",
- "rss": "https://github.com/zendframework/zend-mvc-plugin-identity/releases.atom",
- "chat": "https://zendframework-slack.herokuapp.com",
- "forum": "https://discourse.zendframework.com/c/questions/components"
+ "docs": "https://docs.laminas.dev/laminas-mvc-plugin-identity/",
+ "issues": "https://github.com/laminas/laminas-mvc-plugin-identity/issues",
+ "source": "https://github.com/laminas/laminas-mvc-plugin-identity",
+ "rss": "https://github.com/laminas/laminas-mvc-plugin-identity/releases.atom",
+ "chat": "https://laminas.dev/chat",
+ "forum": "https://discourse.laminas.dev"
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.1.x-dev",
+ "dev-develop": "1.2.x-dev"
+ },
+ "laminas": {
+ "component": "Laminas\\Mvc\\Plugin\\Identity"
+ }
},
"require": {
"php": "^5.6 || ^7.0",
"container-interop/container-interop": "^1.1",
- "zendframework/zend-authentication": "^2.5.3",
- "zendframework/zend-mvc": "^3.0",
- "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3"
+ "laminas/laminas-authentication": "^2.5.3",
+ "laminas/laminas-mvc": "^3.0",
+ "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
+ "laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
- "zendframework/zend-coding-standard": "~1.0.0"
+ "laminas/laminas-coding-standard": "~1.0.0",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
},
"conflict": {
- "zendframework/zend-mvc": "<3.0.0"
+ "laminas/laminas-mvc": "<3.0.0"
},
"autoload": {
"psr-4": {
- "Zend\\Mvc\\Plugin\\Identity\\": "src/"
+ "Laminas\\Mvc\\Plugin\\Identity\\": "src/"
}
},
"autoload-dev": {
"psr-4": {
- "ZendTest\\Mvc\\Plugin\\Identity\\": "test/"
- }
- },
- "config": {
- "sort-packages": true
- },
- "extra": {
- "branch-alias": {
- "dev-master": "1.1.x-dev",
- "dev-develop": "1.2.x-dev"
- },
- "zf": {
- "component": "Zend\\Mvc\\Plugin\\Identity"
+ "LaminasTest\\Mvc\\Plugin\\Identity\\": "test/"
}
},
"scripts": {
@@ -60,5 +61,8 @@
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ },
+ "replace": {
+ "zendframework/zend-mvc-plugin-identity": "self.version"
}
}
diff --git a/php-laminas-mvc-plugin-identity.spec b/php-laminas-mvc-plugin-identity.spec
index 459b972..dddd2d6 100644
--- a/php-laminas-mvc-plugin-identity.spec
+++ b/php-laminas-mvc-plugin-identity.spec
@@ -1,4 +1,4 @@
-# remirepo/Fedora spec file for php-zendframework-zend-mvc-plugin-identity
+# remirepo/Fedora spec file for php-laminas-mvc-plugin-identity
#
# Copyright (c) 2016-2020 Remi Collet
# License: CC-BY-SA
@@ -7,25 +7,29 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 21473f4fa5381ce947593c2fec0f5d7f18693b4a
+%global gh_commit 0dc0c349be0faee67bbb4ae2a0206435a7a51516
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-mvc-plugin-identity
+%global gh_owner laminas
+%global gh_project laminas-mvc-plugin-identity
+%global zf_name zend-mvc-plugin-identity
%global php_home %{_datadir}/php
-%global library Identity
+%global namespace Laminas
+%global library Mvc
+%global subproj Plugin
+%global subsubp Identity
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
%else
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 1.1.1
Release: 1%{?dist}
-Summary: Zend Framework Mvc-Plugin-%{library} component
+Summary: %{namespace} Framework %{library}/%{subproj}/%{subsubp} component
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -34,30 +38,26 @@ BuildArch: noarch
%if %{with_tests}
BuildRequires: php(language) >= 5.6
BuildRequires: php-spl
-# From composer, "require-dev": {
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
-# "zendframework/zend-coding-standard": "~1.0.0"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-authentication) >= 2.5.3 with php-autoloader(%{gh_owner}/zend-authentication) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-mvc) >= 3.0 with php-autoloader(%{gh_owner}/zend-mvc) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.4
-# remirepo:12
+BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-authentication) >= 2.5.3 with php-autoloader(%{gh_owner}/laminas-authentication) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# From composer, "require-dev": {
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
+# remirepo:7
%else
-BuildRequires: php-composer(container-interop/container-interop) < 2
-BuildRequires: php-composer(container-interop/container-interop) >= 1.1
-BuildRequires: php-autoloader(%{gh_owner}/zend-authentication) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-authentication) >= 2.5.3
-BuildRequires: php-autoloader(%{gh_owner}/zend-mvc) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-mvc) >= 3.0
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.5.8
+BuildRequires: php-container-interop
+BuildRequires: php-laminas-authentication
+BuildRequires: php-laminas-mvc
+BuildRequires: php-laminas-servicemanager
+BuildRequires: php-laminas-zendframework-bridge
%endif
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.4
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -65,42 +65,45 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
# "container-interop/container-interop": "^1.1",
-# "zendframework/zend-authentication": "^2.5.3",
-# "zendframework/zend-mvc": "^3.0",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3"
+# "laminas/laminas-authentication": "^2.5.3",
+# "laminas/laminas-mvc": "^3.0",
+# "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
+# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 5.6
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
-Requires: (php-autoloader(%{gh_owner}/zend-authentication) >= 2.5.3 with php-autoloader(%{gh_owner}/zend-authentication) < 3)
-Requires: (php-autoloader(%{gh_owner}/zend-mvc) >= 3.0 with php-autoloader(%{gh_owner}/zend-mvc) < 4)
-Requires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
-# remirepo:10
+Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+Requires: (php-autoloader(%{gh_owner}/laminas-authentication) >= 2.5.3 with php-autoloader(%{gh_owner}/laminas-authentication) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# remirepo:7
%else
-Requires: php-composer(container-interop/container-interop) < 2
-Requires: php-composer(container-interop/container-interop) >= 1.1
-Requires: php-autoloader(%{gh_owner}/zend-authentication) < 3
-Requires: php-autoloader(%{gh_owner}/zend-authentication) >= 2.5.3
-Requires: php-autoloader(%{gh_owner}/zend-mvc) < 4
-Requires: php-autoloader(%{gh_owner}/zend-mvc) >= 3.0
-Requires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
-Requires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
+Requires: php-container-interop
+Requires: php-laminas-authentication
+Requires: php-laminas-mvc
+Requires: php-laminas-servicemanager
+Requires: php-laminas-zendframework-bridge
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 1.0.0
+# From phpcompatinfo report for version 1.1.1
Requires: php-spl
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 1.1.1-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-Provides a zend-mvc plugin (for versions 3.0 and up) that allows retrieving
-the current identity as provided by zend-authentication.
+Provides a laminas-mvc plugin (for versions 3.0 and up) that allows retrieving
+the current identity as provided by laminas-authentication.
-* Issues at https://github.com/zendframework/zend-mvc-plugin-identity/issues
-* Documentation is at https://zendframework.github.io/zend-mvc-plugin-identity/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -110,29 +113,35 @@ mv LICENSE.md LICENSE
%build
-: Create dependency autoloader - deprecated
-cat << 'EOF' | tee autoload.php
-<?php
-require_once '%{php_home}/Interop/Container/autoload.php';
-EOF
-
: Generate autoloader
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/Interop/Container/autoload.php',
- '%{php_home}/Zend/Mvc/autoload.php',
- '%{php_home}/Zend/Authentication/autoload.php',
- '%{php_home}/Zend/ServiceManager/autoload.php',
+ '%{php_home}/%{namespace}/Mvc/autoload.php',
+ '%{php_home}/%{namespace}/Authentication/autoload.php',
+ '%{php_home}/%{namespace}/ServiceManager/autoload.php',
]);
EOF
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(dirname(dirname(__DIR__)))) . '/%{namespace}/%{library}/%{subproj}/%{subsubp}/autoload.php',
+]);
+EOF
+
%install
-mkdir -p %{buildroot}%{php_home}/Zend/Mvc/Plugin
-cp -pr src %{buildroot}%{php_home}/Zend/Mvc/Plugin/%{library}
-
-install -m644 autoload.php %{buildroot}%{php_home}/Zend/Mvc-Plugin-%{library}-autoload.php
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/%{library}/%{subproj}
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}/%{subproj}/%{subsubp}
+
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}/%{subproj}/%{subsubp}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/%{subproj}/%{subsubp}/autoload.php
%check
@@ -140,12 +149,19 @@ install -m644 autoload.php %{buildroot}%{php_home}/Zend/Mvc-Plugin-%{library}-au
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/Mvc/Plugin/%{library}/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\Mvc\\Plugin\\%{library}\\', dirname(__DIR__) . '/test');
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/%{subproj}/%{subsubp}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\%{subproj}\\%{subsubp}\\', dirname(__DIR__) . '/test');
EOF
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/%{subproj}/%{subsubp}/autoload.php";
+exit (class_exists("\\Zend\\%{library}\\%{subproj}\\%{subsubp}\\Module") ? 0 : 1);
+'
+
+: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
@@ -163,11 +179,16 @@ exit $ret
%license LICENSE
%doc *.md
%doc composer.json
-%{php_home}/Zend/Mvc/Plugin/%{library}
-%{php_home}/Zend/Mvc-Plugin-%{library}-autoload.php
+%dir %{php_home}/Zend/%{library}/%{subproj}
+ %{php_home}/Zend/%{library}/%{subproj}/%{subsubp}
+%dir %{php_home}/%{namespace}/%{library}/%{subproj}
+ %{php_home}/%{namespace}/%{library}/%{subproj}/%{subsubp}
%changelog
+* Thu Jan 16 2020 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- switch to Laminas
+
* Fri Oct 18 2019 Remi Collet <remi@remirepo.net> - 1.1.1-1
- update to 1.1.1 (no change)