summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-16 11:32:59 +0100
committerRemi Collet <remi@remirepo.net>2020-01-16 11:32:59 +0100
commitde40de892f7d1875aa654de09cf6aa79b0570c24 (patch)
treef4d095b7544af5a7f0bf442db0a6f5aa8a5622e0
duplicate ZF
-rw-r--r--.gitignore8
-rw-r--r--Makefile3
-rw-r--r--composer.json64
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-laminas-mvc-plugin-identity.spec184
5 files changed, 287 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..bc6be02
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,64 @@
+{
+ "name": "zendframework/zend-mvc-plugin-identity",
+ "description": "Plugin for retrieving the current authenticated identity within zend-mvc controllers",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zf",
+ "zendframework",
+ "mvc"
+ ],
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-mvc-plugin-identity/",
+ "issues": "https://github.com/zendframework/zend-mvc-plugin-identity/issues",
+ "source": "https://github.com/zendframework/zend-mvc-plugin-identity",
+ "rss": "https://github.com/zendframework/zend-mvc-plugin-identity/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
+ },
+ "require": {
+ "php": "^5.6 || ^7.0",
+ "container-interop/container-interop": "^1.1",
+ "zendframework/zend-authentication": "^2.5.3",
+ "zendframework/zend-mvc": "^3.0",
+ "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
+ "zendframework/zend-coding-standard": "~1.0.0"
+ },
+ "conflict": {
+ "zendframework/zend-mvc": "<3.0.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "Zend\\Mvc\\Plugin\\Identity\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\Mvc\\Plugin\\Identity\\": "test/"
+ }
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.1.x-dev",
+ "dev-develop": "1.2.x-dev"
+ },
+ "zf": {
+ "component": "Zend\\Mvc\\Plugin\\Identity"
+ }
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..87d223d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-laminas-mvc-plugin-identity.spec b/php-laminas-mvc-plugin-identity.spec
new file mode 100644
index 0000000..459b972
--- /dev/null
+++ b/php-laminas-mvc-plugin-identity.spec
@@ -0,0 +1,184 @@
+# remirepo/Fedora spec file for php-zendframework-zend-mvc-plugin-identity
+#
+# Copyright (c) 2016-2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 21473f4fa5381ce947593c2fec0f5d7f18693b4a
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-mvc-plugin-identity
+%global php_home %{_datadir}/php
+%global library Identity
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.1.1
+Release: 1%{?dist}
+Summary: Zend Framework Mvc-Plugin-%{library} component
+
+License: BSD
+URL: https://zendframework.github.io/%{gh_project}/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-spl
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
+# "zendframework/zend-coding-standard": "~1.0.0"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-authentication) >= 2.5.3 with php-autoloader(%{gh_owner}/zend-authentication) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-mvc) >= 3.0 with php-autoloader(%{gh_owner}/zend-mvc) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.4
+# remirepo:12
+%else
+BuildRequires: php-composer(container-interop/container-interop) < 2
+BuildRequires: php-composer(container-interop/container-interop) >= 1.1
+BuildRequires: php-autoloader(%{gh_owner}/zend-authentication) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-authentication) >= 2.5.3
+BuildRequires: php-autoloader(%{gh_owner}/zend-mvc) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-mvc) >= 3.0
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
+%endif
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0",
+# "container-interop/container-interop": "^1.1",
+# "zendframework/zend-authentication": "^2.5.3",
+# "zendframework/zend-mvc": "^3.0",
+# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3"
+Requires: php(language) >= 5.6
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+Requires: (php-autoloader(%{gh_owner}/zend-authentication) >= 2.5.3 with php-autoloader(%{gh_owner}/zend-authentication) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-mvc) >= 3.0 with php-autoloader(%{gh_owner}/zend-mvc) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+# remirepo:10
+%else
+Requires: php-composer(container-interop/container-interop) < 2
+Requires: php-composer(container-interop/container-interop) >= 1.1
+Requires: php-autoloader(%{gh_owner}/zend-authentication) < 3
+Requires: php-autoloader(%{gh_owner}/zend-authentication) >= 2.5.3
+Requires: php-autoloader(%{gh_owner}/zend-mvc) < 4
+Requires: php-autoloader(%{gh_owner}/zend-mvc) >= 3.0
+Requires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
+Requires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
+%endif
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+# From phpcompatinfo report for version 1.0.0
+Requires: php-spl
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Provides a zend-mvc plugin (for versions 3.0 and up) that allows retrieving
+the current identity as provided by zend-authentication.
+
+* Issues at https://github.com/zendframework/zend-mvc-plugin-identity/issues
+* Documentation is at https://zendframework.github.io/zend-mvc-plugin-identity/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+: Create dependency autoloader - deprecated
+cat << 'EOF' | tee autoload.php
+<?php
+require_once '%{php_home}/Interop/Container/autoload.php';
+EOF
+
+: Generate autoloader
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Interop/Container/autoload.php',
+ '%{php_home}/Zend/Mvc/autoload.php',
+ '%{php_home}/Zend/Authentication/autoload.php',
+ '%{php_home}/Zend/ServiceManager/autoload.php',
+]);
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/Zend/Mvc/Plugin
+cp -pr src %{buildroot}%{php_home}/Zend/Mvc/Plugin/%{library}
+
+install -m644 autoload.php %{buildroot}%{php_home}/Zend/Mvc-Plugin-%{library}-autoload.php
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/Zend/Mvc/Plugin/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\Mvc\\Plugin\\%{library}\\', dirname(__DIR__) . '/test');
+EOF
+
+ret=0
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{php_home}/Zend/Mvc/Plugin/%{library}
+%{php_home}/Zend/Mvc-Plugin-%{library}-autoload.php
+
+
+%changelog
+* Fri Oct 18 2019 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1 (no change)
+
+* Thu May 3 2018 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+- use range dependencies on F27+
+- switch to phpunit6 or phpunit7
+
+* Wed Dec 13 2017 Remi Collet <remi@remirepo.net> - 1.0.0-4
+- switch from zend-loader to fedora/autoloader
+
+* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- initial package
+