summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-22 11:19:06 +0200
committerRemi Collet <remi@php.net>2022-07-22 11:19:06 +0200
commit07bebc2ecb8145c7b9d46024be3a9b7be3592ecb (patch)
tree74c567baa7a08b42be2276a95aae3a768ae5bab8
parent0c4b9b56700d09abfa3f0a1845038a02f92e22e1 (diff)
update to 1.4.0
raise dependency on PHP 7.4 raise dependency on laminas-authentication 2.11.0 raise dependency on laminas-mvc 3.3.3 raise dependency on laminas-servicemanager 3.15.1
-rw-r--r--composer.json26
-rw-r--r--php-laminas-mvc-plugin-identity.spec43
2 files changed, 43 insertions, 26 deletions
diff --git a/composer.json b/composer.json
index 9ea00f6..acadcfe 100644
--- a/composer.json
+++ b/composer.json
@@ -16,7 +16,13 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "platform": {
+ "php": "7.4.99"
+ },
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
},
"extra": {
"laminas": {
@@ -24,16 +30,17 @@
}
},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0",
- "container-interop/container-interop": "^1.1",
- "laminas/laminas-authentication": "^2.5.3",
- "laminas/laminas-mvc": "^3.0",
- "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3"
+ "php": "^7.4 || ~8.0.0 || ~8.1.0",
+ "laminas/laminas-authentication": "^2.11.0",
+ "laminas/laminas-mvc": "^3.3.3",
+ "laminas/laminas-servicemanager": "^3.15.1"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-coding-standard": "~2.3.0",
"phpspec/prophecy-phpunit": "^2.0",
- "phpunit/phpunit": "^9.5"
+ "phpunit/phpunit": "^9.5",
+ "psalm/plugin-phpunit": "^0.17.0",
+ "vimeo/psalm": "^4.24"
},
"conflict": {
"laminas/laminas-mvc": "<3.0.0",
@@ -57,6 +64,7 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "static-analysis": "psalm --shepard --stats"
}
}
diff --git a/php-laminas-mvc-plugin-identity.spec b/php-laminas-mvc-plugin-identity.spec
index dd6df33..56972bb 100644
--- a/php-laminas-mvc-plugin-identity.spec
+++ b/php-laminas-mvc-plugin-identity.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit d22e7fb74f0395828df5cd42ed55d23a98569ed1
+%global gh_commit 81b4bf2121044f6e3e24e00ea8676fa6de595f59
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mvc-plugin-identity
@@ -24,8 +24,8 @@
%endif
Name: php-%{gh_project}
-Version: 1.3.0
-Release: 3%{?dist}
+Version: 1.4.0
+Release: 1%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj}/%{subsubp} component
License: BSD
@@ -36,18 +36,20 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 7.4
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-authentication) >= 2.5.3 with php-autoloader(%{gh_owner}/laminas-authentication) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.12 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-authentication) >= 2.11.0 with php-autoloader(%{gh_owner}/laminas-authentication) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.3.3 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.15.1 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-coding-standard": "~2.3.0",
# "phpspec/prophecy-phpunit": "^2.0",
# "phpunit/phpunit": "^9.5"
+# "psalm/plugin-phpunit": "^0.17.0",
+# "vimeo/psalm": "^4.24"
BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
# remirepo:7
%else
@@ -64,17 +66,17 @@ BuildRequires: phpunit9 >= 9.5
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0",
+# "php": "^7.4 || ~8.0.0 || ~8.1.0",
# "container-interop/container-interop": "^1.1",
-# "laminas/laminas-authentication": "^2.5.3",
-# "laminas/laminas-mvc": "^3.0",
-# "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3"
-Requires: php(language) >= 7.3
+# "laminas/laminas-authentication": "^2.11.0",
+# "laminas/laminas-mvc": "^3.3.3",
+# "laminas/laminas-servicemanager": "^3.15.1"
+Requires: php(language) >= 7.4
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/laminas-authentication) >= 2.5.3 with php-autoloader(%{gh_owner}/laminas-authentication) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.12 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-authentication) >= 2.11.0 with php-autoloader(%{gh_owner}/laminas-authentication) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.3.3 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.15.1 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# remirepo:6
%else
@@ -161,7 +163,7 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\%{subsubp}\\Module") ? 0 : 1
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -186,6 +188,13 @@ exit $ret
%changelog
+* Fri Jul 22 2022 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0
+- raise dependency on PHP 7.4
+- raise dependency on laminas-authentication 2.11.0
+- raise dependency on laminas-mvc 3.3.3
+- raise dependency on laminas-servicemanager 3.15.1
+
* Thu Jun 23 2022 Remi Collet <remi@remirepo.net> - 1.3.0-3
- drop dependency on container-interop/container-interop
replaced by servicemanager >= 3.12