summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-06-23 16:09:22 +0200
committerRemi Collet <remi@php.net>2022-06-23 16:09:22 +0200
commit0c4b9b56700d09abfa3f0a1845038a02f92e22e1 (patch)
tree86b258df0bc79a2c5acfa44940640c2cb50f1e80
parentdb06972bfaeeb7a8266bfb6d0487d9cf0f1695be (diff)
drop dependency on container-interop/container-interopHEADmaster
replaced by servicemanager >= 3.12
-rw-r--r--php-laminas-mvc-plugin-identity.spec25
1 files changed, 12 insertions, 13 deletions
diff --git a/php-laminas-mvc-plugin-identity.spec b/php-laminas-mvc-plugin-identity.spec
index fb55762..dd6df33 100644
--- a/php-laminas-mvc-plugin-identity.spec
+++ b/php-laminas-mvc-plugin-identity.spec
@@ -1,6 +1,6 @@
# remirepo/Fedora spec file for php-laminas-mvc-plugin-identity
#
-# Copyright (c) 2016-2021 Remi Collet
+# Copyright (c) 2016-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -25,7 +25,7 @@
Name: php-%{gh_project}
Version: 1.3.0
-Release: 1%{?dist}
+Release: 3%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj}/%{subsubp} component
License: BSD
@@ -40,19 +40,17 @@ BuildRequires: php(language) >= 7.3
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-authentication) >= 2.5.3 with php-autoloader(%{gh_owner}/laminas-authentication) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.12 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
# "phpspec/prophecy-phpunit": "^2.0",
# "phpunit/phpunit": "^9.5"
BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
-# remirepo:8
+# remirepo:7
%else
-BuildRequires: php-container-interop
BuildRequires: php-laminas-authentication
BuildRequires: php-laminas-mvc
BuildRequires: php-laminas-servicemanager
@@ -74,14 +72,12 @@ BuildRequires: php-fedora-autoloader-devel
Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
Requires: (php-autoloader(%{gh_owner}/laminas-authentication) >= 2.5.3 with php-autoloader(%{gh_owner}/laminas-authentication) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.12 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
-# remirepo:7
+# remirepo:6
%else
-Requires: php-container-interop
Requires: php-laminas-authentication
Requires: php-laminas-mvc
Requires: php-laminas-servicemanager
@@ -119,10 +115,9 @@ mv LICENSE.md LICENSE
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Interop/Container/autoload.php',
+ '%{php_home}/%{namespace}/ServiceManager/autoload.php',
'%{php_home}/%{namespace}/Mvc/autoload.php',
'%{php_home}/%{namespace}/Authentication/autoload.php',
- '%{php_home}/%{namespace}/ServiceManager/autoload.php',
]);
EOF
@@ -166,7 +161,7 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\%{subsubp}\\Module") ? 0 : 1
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -191,6 +186,10 @@ exit $ret
%changelog
+* Thu Jun 23 2022 Remi Collet <remi@remirepo.net> - 1.3.0-3
+- drop dependency on container-interop/container-interop
+ replaced by servicemanager >= 3.12
+
* Tue Sep 14 2021 Remi Collet <remi@remirepo.net> - 1.3.0-1
- update to 1.3.0 (no change)
- keep compatibility using laminas-zendframework-bridge