summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-24 15:46:09 +0200
committerRemi Collet <remi@php.net>2022-10-24 15:46:09 +0200
commit6bf51850a875e506ab403d4e0ef9f095a1ad1af2 (patch)
treed75016ffe45b44176b7205caf0e9efb334cd9b41
parent07bebc2ecb8145c7b9d46024be3a9b7be3592ecb (diff)
update to 1.5.0 (no change)HEADmaster
raise dependency on PHP 8.0
-rw-r--r--composer.json9
-rw-r--r--php-laminas-mvc-plugin-identity.spec28
2 files changed, 17 insertions, 20 deletions
diff --git a/composer.json b/composer.json
index acadcfe..147d4bd 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "7.4.99"
+ "php": "8.0.99"
},
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
@@ -30,17 +30,16 @@
}
},
"require": {
- "php": "^7.4 || ~8.0.0 || ~8.1.0",
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
"laminas/laminas-authentication": "^2.11.0",
"laminas/laminas-mvc": "^3.3.3",
"laminas/laminas-servicemanager": "^3.15.1"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~2.3.0",
- "phpspec/prophecy-phpunit": "^2.0",
+ "laminas/laminas-coding-standard": "~2.4.0",
"phpunit/phpunit": "^9.5",
"psalm/plugin-phpunit": "^0.17.0",
- "vimeo/psalm": "^4.24"
+ "vimeo/psalm": "^4.29"
},
"conflict": {
"laminas/laminas-mvc": "<3.0.0",
diff --git a/php-laminas-mvc-plugin-identity.spec b/php-laminas-mvc-plugin-identity.spec
index 56972bb..424af31 100644
--- a/php-laminas-mvc-plugin-identity.spec
+++ b/php-laminas-mvc-plugin-identity.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 81b4bf2121044f6e3e24e00ea8676fa6de595f59
+%global gh_commit 362035bc191be806052666d8aa790ff860b394a9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mvc-plugin-identity
@@ -24,7 +24,7 @@
%endif
Name: php-%{gh_project}
-Version: 1.4.0
+Version: 1.5.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj}/%{subsubp} component
@@ -36,7 +36,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 8.0
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -45,19 +45,16 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.3.
BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.15.1 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~2.3.0",
-# "phpspec/prophecy-phpunit": "^2.0",
+# "laminas/laminas-coding-standard": "~2.4.0",
# "phpunit/phpunit": "^9.5"
# "psalm/plugin-phpunit": "^0.17.0",
-# "vimeo/psalm": "^4.24"
-BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
-# remirepo:7
+# "vimeo/psalm": "^4.29"
+# remirepo:6
%else
BuildRequires: php-laminas-authentication
BuildRequires: php-laminas-mvc
BuildRequires: php-laminas-servicemanager
BuildRequires: php-laminas-zendframework-bridge
-BuildRequires: php-phpspec-prophecy-phpunit
%endif
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.5
@@ -66,12 +63,12 @@ BuildRequires: phpunit9 >= 9.5
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "container-interop/container-interop": "^1.1",
# "laminas/laminas-authentication": "^2.11.0",
# "laminas/laminas-mvc": "^3.3.3",
# "laminas/laminas-servicemanager": "^3.15.1"
-Requires: php(language) >= 7.4
+Requires: php(language) >= 8.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-authentication) >= 2.11.0 with php-autoloader(%{gh_owner}/laminas-authentication) < 3)
@@ -150,9 +147,6 @@ cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/%{subproj}/%{subsubp}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\%{subproj}\\%{subsubp}\\', dirname(__DIR__) . '/test');
-\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Prophecy/PhpUnit/autoload.php',
-]);
EOF
: check compat autoloader
@@ -163,7 +157,7 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\%{subsubp}\\Module") ? 0 : 1
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -188,6 +182,10 @@ exit $ret
%changelog
+* Mon Oct 24 2022 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0 (no change)
+- raise dependency on PHP 8.0
+
* Fri Jul 22 2022 Remi Collet <remi@remirepo.net> - 1.4.0-1
- update to 1.4.0
- raise dependency on PHP 7.4