summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-07 08:58:48 +0100
committerRemi Collet <remi@php.net>2022-12-07 08:58:48 +0100
commit6e98999e537da72abbeb97bba4d9e87815498f88 (patch)
tree11e5bd04340eca2fad92027336cb0a2a19bbb769
parente79e37b4e944d8565ab5f7f337404269c2801ce5 (diff)
update to 1.5.0 (no change)
-rw-r--r--composer.json10
-rw-r--r--php-laminas-mvc-plugin-fileprg.spec25
2 files changed, 19 insertions, 16 deletions
diff --git a/composer.json b/composer.json
index f916943..bb87359 100644
--- a/composer.json
+++ b/composer.json
@@ -30,7 +30,7 @@
}
},
"require": {
- "php": "^7.4 || ~8.0.0 || ~8.1.0",
+ "php": "^7.4 || ~8.0.0 || ~8.1.0 || ~8.2.0",
"laminas/laminas-filter": "^2.13.1",
"laminas/laminas-form": "^3.1",
"laminas/laminas-inputfilter": "^2.13",
@@ -40,10 +40,10 @@
"laminas/laminas-validator": "^2.15.1"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~2.3.0",
- "phpunit/phpunit": "^9.5.11",
- "psalm/plugin-phpunit": "^0.17.0",
- "vimeo/psalm": "^4.24"
+ "laminas/laminas-coding-standard": "~2.4.0",
+ "phpunit/phpunit": "^9.5.26",
+ "psalm/plugin-phpunit": "^0.18.0",
+ "vimeo/psalm": "^4.29.0"
},
"conflict": {
"laminas/laminas-mvc": "<3.0.0",
diff --git a/php-laminas-mvc-plugin-fileprg.spec b/php-laminas-mvc-plugin-fileprg.spec
index eeac5a4..e9f309f 100644
--- a/php-laminas-mvc-plugin-fileprg.spec
+++ b/php-laminas-mvc-plugin-fileprg.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit c72675556a32cb42597ec3bace6ab9cef8847c04
+%global gh_commit 407ef6288f03f65132ec72629bc2675d303e7a3c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mvc-plugin-fileprg
@@ -24,7 +24,7 @@
%endif
Name: php-%{gh_project}
-Version: 1.4.0
+Version: 1.5.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj}/%{subsubp} component
@@ -36,13 +36,13 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 7.4
BuildRequires: php-reflection
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~2.3.0",
-# "phpunit/phpunit": "^9.5.11",
-# "psalm/plugin-phpunit": "^0.17.0",
-# "vimeo/psalm": "^4.24"
+# "laminas/laminas-coding-standard": "~2.4.0",
+# "phpunit/phpunit": "^9.5.26",
+# "psalm/plugin-phpunit": "^0.18.0",
+# "vimeo/psalm": "^4.29.0"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.13.1 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
@@ -65,13 +65,13 @@ BuildRequires: php-laminas-validator
BuildRequires: php-laminas-zendframework-bridge
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.11
+BuildRequires: phpunit9 >= 9.5.26
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+# "php": "^7.4 || ~8.0.0 || ~8.1.0 || ~8.2.0",
# "laminas/laminas-filter": "^2.13.1",
# "laminas/laminas-form": "^3.1",
# "laminas/laminas-inputfilter": "^2.13",
@@ -79,7 +79,7 @@ BuildRequires: php-fedora-autoloader-devel
# "laminas/laminas-session": "^2.12",
# "laminas/laminas-stdlib": "^3.6.2",
# "laminas/laminas-validator": "^2.15.1"
-Requires: php(language) >= 7.3
+Requires: php(language) >= 7.4
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.13.1 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
@@ -189,7 +189,7 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\%{subsubp}\\Module") ? 0 : 1
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -216,6 +216,9 @@ exit $ret
%changelog
+* Wed Dec 7 2022 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0 (no change)
+
* Mon Jul 25 2022 Remi Collet <remi@remirepo.net> - 1.4.0-1
- update to 1.4.0 (no change)