summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-25 14:24:26 +0200
committerRemi Collet <remi@php.net>2022-07-25 14:24:26 +0200
commite79e37b4e944d8565ab5f7f337404269c2801ce5 (patch)
treed2c904a57d992358969d7f9df9b8b94bf112b422
parentcb0c6ecaab57af10344888986987949747ea1dac (diff)
update to 1.4.0 (no change)
-rw-r--r--composer.json10
-rw-r--r--php-laminas-mvc-plugin-fileprg.spec13
2 files changed, 17 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 7c74b95..f916943 100644
--- a/composer.json
+++ b/composer.json
@@ -19,6 +19,9 @@
"sort-packages": true,
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
+ },
+ "platform": {
+ "php": "7.4.99"
}
},
"extra": {
@@ -38,7 +41,9 @@
},
"require-dev": {
"laminas/laminas-coding-standard": "~2.3.0",
- "phpunit/phpunit": "^9.5.11"
+ "phpunit/phpunit": "^9.5.11",
+ "psalm/plugin-phpunit": "^0.17.0",
+ "vimeo/psalm": "^4.24"
},
"conflict": {
"laminas/laminas-mvc": "<3.0.0",
@@ -64,6 +69,7 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "static-analysis": "psalm --shepherd --stats"
}
}
diff --git a/php-laminas-mvc-plugin-fileprg.spec b/php-laminas-mvc-plugin-fileprg.spec
index f344570..eeac5a4 100644
--- a/php-laminas-mvc-plugin-fileprg.spec
+++ b/php-laminas-mvc-plugin-fileprg.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 28b9cbb4a656e3b618a70776b100906ca6fe8810
+%global gh_commit c72675556a32cb42597ec3bace6ab9cef8847c04
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mvc-plugin-fileprg
@@ -24,7 +24,7 @@
%endif
Name: php-%{gh_project}
-Version: 1.3.1
+Version: 1.4.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj}/%{subsubp} component
@@ -40,7 +40,9 @@ BuildRequires: php(language) >= 7.3
BuildRequires: php-reflection
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~2.3.0",
-# "phpunit/phpunit": "^9.5.11"
+# "phpunit/phpunit": "^9.5.11",
+# "psalm/plugin-phpunit": "^0.17.0",
+# "vimeo/psalm": "^4.24"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.13.1 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
@@ -187,7 +189,7 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\%{subsubp}\\Module") ? 0 : 1
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -214,6 +216,9 @@ exit $ret
%changelog
+* Mon Jul 25 2022 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0 (no change)
+
* Mon Jan 31 2022 Remi Collet <remi@remirepo.net> - 1.3.1-1
- update to 1.3.1 (no change)