summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-16 11:18:11 +0100
committerRemi Collet <remi@remirepo.net>2020-01-16 11:18:11 +0100
commit42b822da5994e194333d919b772e1b8c7d3b3490 (patch)
treeacc19e3e0ee06c92a7c42a92e610a8410048a575
parentc4ec32be532d006abbde58512d2590e0b029354d (diff)
switch to Laminas
-rw-r--r--composer.json72
-rw-r--r--php-laminas-mvc-plugin-fileprg.spec197
2 files changed, 150 insertions, 119 deletions
diff --git a/composer.json b/composer.json
index 664333b..bb2a145 100644
--- a/composer.json
+++ b/composer.json
@@ -1,57 +1,58 @@
{
- "name": "zendframework/zend-mvc-plugin-fileprg",
- "description": "Post/Redirect/Get plugin with file upload handling for zend-mvc controllers",
+ "name": "laminas/laminas-mvc-plugin-fileprg",
+ "description": "Post/Redirect/Get plugin with file upload handling for laminas-mvc controllers",
"license": "BSD-3-Clause",
"keywords": [
- "zf",
- "zendframework",
+ "laminas",
"mvc"
],
+ "homepage": "https://laminas.dev",
"support": {
- "docs": "https://docs.zendframework.com/zend-mvc-plugin-fileprg/",
- "issues": "https://github.com/zendframework/zend-mvc-plugin-fileprg/issues",
- "source": "https://github.com/zendframework/zend-mvc-plugin-fileprg",
- "rss": "https://github.com/zendframework/zend-mvc-plugin-fileprg/releases.atom",
- "chat": "https://zendframework-slack.herokuapp.com",
- "forum": "https://discourse.zendframework.com/c/questions/components"
+ "docs": "https://docs.laminas.dev/laminas-mvc-plugin-fileprg/",
+ "issues": "https://github.com/laminas/laminas-mvc-plugin-fileprg/issues",
+ "source": "https://github.com/laminas/laminas-mvc-plugin-fileprg",
+ "rss": "https://github.com/laminas/laminas-mvc-plugin-fileprg/releases.atom",
+ "chat": "https://laminas.dev/chat",
+ "forum": "https://discourse.laminas.dev"
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.1.x-dev",
+ "dev-develop": "1.2.x-dev"
+ },
+ "laminas": {
+ "component": "Laminas\\Mvc\\Plugin\\FilePrg"
+ }
},
"require": {
"php": "^5.6 || ^7.0",
- "zendframework/zend-filter": "^2.6.1",
- "zendframework/zend-form": "^2.7",
- "zendframework/zend-inputfilter": "^2.8.1",
- "zendframework/zend-mvc": "^3.0",
- "zendframework/zend-session": "^2.8.5",
- "zendframework/zend-stdlib": "^2.7 || ^3.0",
- "zendframework/zend-validator": "^2.6"
+ "laminas/laminas-filter": "^2.6.1",
+ "laminas/laminas-form": "^2.7",
+ "laminas/laminas-inputfilter": "^2.8.1",
+ "laminas/laminas-mvc": "^3.0",
+ "laminas/laminas-session": "^2.8.5",
+ "laminas/laminas-stdlib": "^2.7 || ^3.0",
+ "laminas/laminas-validator": "^2.6",
+ "laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5",
- "zendframework/zend-coding-standard": "~1.0.0"
+ "laminas/laminas-coding-standard": "~1.0.0",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5"
},
"conflict": {
- "zendframework/zend-mvc": "<3.0.0"
+ "laminas/laminas-mvc": "<3.0.0"
},
"autoload": {
"psr-4": {
- "Zend\\Mvc\\Plugin\\FilePrg\\": "src/"
+ "Laminas\\Mvc\\Plugin\\FilePrg\\": "src/"
}
},
"autoload-dev": {
"psr-4": {
- "ZendTest\\Mvc\\Plugin\\FilePrg\\": "test/"
- }
- },
- "config": {
- "sort-packages": true
- },
- "extra": {
- "branch-alias": {
- "dev-master": "1.1.x-dev",
- "dev-develop": "1.2.x-dev"
- },
- "zf": {
- "component": "Zend\\Mvc\\Plugin\\FilePrg"
+ "LaminasTest\\Mvc\\Plugin\\FilePrg\\": "test/"
}
},
"scripts": {
@@ -63,5 +64,8 @@
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ },
+ "replace": {
+ "zendframework/zend-mvc-plugin-fileprg": "self.version"
}
}
diff --git a/php-laminas-mvc-plugin-fileprg.spec b/php-laminas-mvc-plugin-fileprg.spec
index 1b7a8df..8abf329 100644
--- a/php-laminas-mvc-plugin-fileprg.spec
+++ b/php-laminas-mvc-plugin-fileprg.spec
@@ -1,31 +1,35 @@
-# remirepo/Fedora spec file for php-zendframework-zend-mvc-plugin-fileprg
+# remirepo/Fedora spec file for php-laminas-mvc-plugin-fileprg
#
-# Copyright (c) 2016-2018 Remi Collet
+# Copyright (c) 2016-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 87184f33dbb98eb57c7338a5f026cca29bdd6048
+%global gh_commit 4a1a3729b3789a4d9e7cfe285ce84a636be87a67
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-mvc-plugin-fileprg
+%global gh_owner laminas
+%global gh_project laminas-mvc-plugin-fileprg
+%global zf_name zend-mvc-plugin-fileprg
%global php_home %{_datadir}/php
-%global library FilePrg
+%global namespace Laminas
+%global library Mvc
+%global subproj Plugin
+%global subsubp FilePrg
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
%else
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 1.1.0
Release: 1%{?dist}
-Summary: Zend Framework Mvc-Plugin-%{library} component
+Summary: %{namespace} Framework %{library}/%{subproj}/%{subsubp} component
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -35,95 +39,89 @@ BuildArch: noarch
BuildRequires: php(language) >= 5.6
BuildRequires: php-reflection
# From composer, "require-dev": {
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5",
-# "zendframework/zend-coding-standard": "~1.0.0"
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/zend-filter) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-filter) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-form) >= 2.7 with php-autoloader(%{gh_owner}/zend-form) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-inputfilter) >= 2.8.1 with php-autoloader(%{gh_owner}/zend-inputfilter) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-mvc) >= 3.0 with php-autoloader(%{gh_owner}/zend-mvc) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-session) >= 2.8.5 with php-autoloader(%{gh_owner}/zend-session) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.6 with php-autoloader(%{gh_owner}/zend-validator) < 3)
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.4
-# remirepo:18
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-form) >= 2.7 with php-autoloader(%{gh_owner}/laminas-form) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-inputfilter) >= 2.8.1 with php-autoloader(%{gh_owner}/laminas-inputfilter) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.8.5 with php-autoloader(%{gh_owner}/laminas-session) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.6 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# remirepo:10
%else
-BuildRequires: php-autoloader(%{gh_owner}/zend-filter) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-filter) >= 2.6.1
-BuildRequires: php-autoloader(%{gh_owner}/zend-form) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-form) >= 2.7
-BuildRequires: php-autoloader(%{gh_owner}/zend-inputfilter) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-inputfilter) >= 2.8.1
-BuildRequires: php-autoloader(%{gh_owner}/zend-mvc) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-mvc) >= 3.0
-BuildRequires: php-autoloader(%{gh_owner}/zend-session) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-session) >= 2.8.5
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
-BuildRequires: php-autoloader(%{gh_owner}/zend-validator) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.6
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.5.8
+BuildRequires: php-laminas-filter
+BuildRequires: php-laminas-form
+BuildRequires: php-laminas-inputfilter
+BuildRequires: php-laminas-mvc
+BuildRequires: php-laminas-session
+BuildRequires: php-laminas-stdlib
+BuildRequires: php-laminas-validator
+BuildRequires: php-laminas-zendframework-bridge
%endif
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.4
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
-# "zendframework/zend-filter": "^2.6.1",
-# "zendframework/zend-form": "^2.7",
-# "zendframework/zend-inputfilter": "^2.8.1",
-# "zendframework/zend-mvc": "^3.0",
-# "zendframework/zend-session": "^2.8.5",
-# "zendframework/zend-stdlib": "^2.7 || ^3.0",
-# "zendframework/zend-validator": "^2.6"
+# "laminas/laminas-filter": "^2.6.1",
+# "laminas/laminas-form": "^2.7",
+# "laminas/laminas-inputfilter": "^2.8.1",
+# "laminas/laminas-mvc": "^3.0",
+# "laminas/laminas-session": "^2.8.5",
+# "laminas/laminas-stdlib": "^2.7 || ^3.0",
+# "laminas/laminas-validator": "^2.6",
+# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 5.6
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/zend-filter) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-filter) < 3)
-Requires: (php-autoloader(%{gh_owner}/zend-form) >= 2.7 with php-autoloader(%{gh_owner}/zend-form) < 3)
-Requires: (php-autoloader(%{gh_owner}/zend-inputfilter) >= 2.8.1 with php-autoloader(%{gh_owner}/zend-inputfilter) < 3)
-Requires: (php-autoloader(%{gh_owner}/zend-mvc) >= 3.0 with php-autoloader(%{gh_owner}/zend-mvc) < 4)
-Requires: (php-autoloader(%{gh_owner}/zend-session) >= 2.8.5 with php-autoloader(%{gh_owner}/zend-session) < 3)
-Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-Requires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.6 with php-autoloader(%{gh_owner}/zend-validator) < 3)
-# remirepo:16
+Requires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-form) >= 2.7 with php-autoloader(%{gh_owner}/laminas-form) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-inputfilter) >= 2.8.1 with php-autoloader(%{gh_owner}/laminas-inputfilter) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.8.5 with php-autoloader(%{gh_owner}/laminas-session) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.6 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# remirepo:10
%else
-Requires: php-autoloader(%{gh_owner}/zend-filter) < 3
-Requires: php-autoloader(%{gh_owner}/zend-filter) >= 2.6.1
-Requires: php-autoloader(%{gh_owner}/zend-form) < 3
-Requires: php-autoloader(%{gh_owner}/zend-form) >= 2.7
-Requires: php-autoloader(%{gh_owner}/zend-inputfilter) < 3
-Requires: php-autoloader(%{gh_owner}/zend-inputfilter) >= 2.8.1
-Requires: php-autoloader(%{gh_owner}/zend-mvc) < 4
-Requires: php-autoloader(%{gh_owner}/zend-mvc) >= 3.0
-Requires: php-autoloader(%{gh_owner}/zend-session) < 3
-Requires: php-autoloader(%{gh_owner}/zend-session) >= 2.8.5
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
-Requires: php-autoloader(%{gh_owner}/zend-validator) < 3
-Requires: php-autoloader(%{gh_owner}/zend-validator) >= 2.6
+Requires: php-laminas-filter
+Requires: php-laminas-form
+Requires: php-laminas-inputfilter
+Requires: php-laminas-mvc
+Requires: php-laminas-session
+Requires: php-laminas-stdlib
+Requires: php-laminas-validator
+Requires: php-laminas-zendframework-bridge
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 1.0.0
+# From phpcompatinfo report for version 1.1.0
Requires: php-reflection
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 1.1.0-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-Provides a Post-Redirect-Get controller plugin for zend-mvc versions 3.0
+Provides a Post-Redirect-Get controller plugin for laminas-mvc versions 3.0
and up, specifically for submissions that include file uploads.
-If you want a generic PRG plugin without file upload support, see zend-mvc-plugin-prg.
+If you want a generic PRG plugin without file upload support,
+see laminas-mvc-plugin-prg.
-* Issues at https://github.com/zendframework/zend-mvc-plugin-fileprg/issues
-* Documentation is at https://zendframework.github.io/zend-mvc-plugin-fileprg/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -137,20 +135,34 @@ mv LICENSE.md LICENSE
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/Filter/autoload.php',
- '%{php_home}/Zend/Form/autoload.php',
- '%{php_home}/Zend/InputFilter/autoload.php',
- '%{php_home}/Zend/Mvc/autoload.php',
- '%{php_home}/Zend/Session/autoload.php',
- '%{php_home}/Zend/Stdlib/autoload.php',
- '%{php_home}/Zend/Validator/autoload.php',
+ '%{php_home}/%{namespace}/Filter/autoload.php',
+ '%{php_home}/%{namespace}/Form/autoload.php',
+ '%{php_home}/%{namespace}/InputFilter/autoload.php',
+ '%{php_home}/%{namespace}/Mvc/autoload.php',
+ '%{php_home}/%{namespace}/Session/autoload.php',
+ '%{php_home}/%{namespace}/Stdlib/autoload.php',
+ '%{php_home}/%{namespace}/Validator/autoload.php',
+]);
+EOF
+
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(dirname(dirname(__DIR__)))) . '/%{namespace}/%{library}/%{subproj}/%{subsubp}/autoload.php',
]);
EOF
%install
-mkdir -p %{buildroot}%{php_home}/Zend/Mvc/Plugin
-cp -pr src %{buildroot}%{php_home}/Zend/Mvc/Plugin/%{library}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/%{library}/%{subproj}
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}/%{subproj}/%{subsubp}
+
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}/%{subproj}/%{subsubp}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/%{subproj}/%{subsubp}/autoload.php
%check
@@ -158,12 +170,20 @@ cp -pr src %{buildroot}%{php_home}/Zend/Mvc/Plugin/%{library}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/Mvc/Plugin/%{library}/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\Mvc\\Plugin\\%{library}\\', dirname(__DIR__) . '/test');
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/%{subproj}/%{subsubp}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\%{subproj}\\%{subsubp}\\', dirname(__DIR__) . '/test');
EOF
+
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/%{subproj}/%{subsubp}/autoload.php";
+exit (class_exists("\\Zend\\%{library}\\%{subproj}\\%{subsubp}\\Module") ? 0 : 1);
+'
+
+: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
@@ -176,14 +196,21 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
%doc composer.json
-%{php_home}/Zend/Mvc/Plugin/%{library}
+%dir %{php_home}/Zend/%{library}/%{subproj}
+ %{php_home}/Zend/%{library}/%{subproj}/%{subsubp}
+%dir %{php_home}/%{namespace}/%{library}/%{subproj}
+ %{php_home}/%{namespace}/%{library}/%{subproj}/%{subsubp}
%changelog
+* Thu Jan 16 2020 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- switch to Laminas
+
* Thu May 3 2018 Remi Collet <remi@remirepo.net> - 1.1.0-1
- update to 1.1.0
- use range dependencies on F27+