summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-16 11:02:37 +0100
committerRemi Collet <remi@remirepo.net>2020-01-16 11:02:37 +0100
commitc4ec32be532d006abbde58512d2590e0b029354d (patch)
tree868bb0a94a604db47805c51dfc9844540aa6d2f4
duplicate ZF
-rw-r--r--.gitignore8
-rw-r--r--Makefile3
-rw-r--r--composer.json67
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-laminas-mvc-plugin-fileprg.spec199
5 files changed, 305 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..664333b
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,67 @@
+{
+ "name": "zendframework/zend-mvc-plugin-fileprg",
+ "description": "Post/Redirect/Get plugin with file upload handling for zend-mvc controllers",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zf",
+ "zendframework",
+ "mvc"
+ ],
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-mvc-plugin-fileprg/",
+ "issues": "https://github.com/zendframework/zend-mvc-plugin-fileprg/issues",
+ "source": "https://github.com/zendframework/zend-mvc-plugin-fileprg",
+ "rss": "https://github.com/zendframework/zend-mvc-plugin-fileprg/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
+ },
+ "require": {
+ "php": "^5.6 || ^7.0",
+ "zendframework/zend-filter": "^2.6.1",
+ "zendframework/zend-form": "^2.7",
+ "zendframework/zend-inputfilter": "^2.8.1",
+ "zendframework/zend-mvc": "^3.0",
+ "zendframework/zend-session": "^2.8.5",
+ "zendframework/zend-stdlib": "^2.7 || ^3.0",
+ "zendframework/zend-validator": "^2.6"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5",
+ "zendframework/zend-coding-standard": "~1.0.0"
+ },
+ "conflict": {
+ "zendframework/zend-mvc": "<3.0.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "Zend\\Mvc\\Plugin\\FilePrg\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\Mvc\\Plugin\\FilePrg\\": "test/"
+ }
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.1.x-dev",
+ "dev-develop": "1.2.x-dev"
+ },
+ "zf": {
+ "component": "Zend\\Mvc\\Plugin\\FilePrg"
+ }
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..87d223d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-laminas-mvc-plugin-fileprg.spec b/php-laminas-mvc-plugin-fileprg.spec
new file mode 100644
index 0000000..1b7a8df
--- /dev/null
+++ b/php-laminas-mvc-plugin-fileprg.spec
@@ -0,0 +1,199 @@
+# remirepo/Fedora spec file for php-zendframework-zend-mvc-plugin-fileprg
+#
+# Copyright (c) 2016-2018 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 87184f33dbb98eb57c7338a5f026cca29bdd6048
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-mvc-plugin-fileprg
+%global php_home %{_datadir}/php
+%global library FilePrg
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.1.0
+Release: 1%{?dist}
+Summary: Zend Framework Mvc-Plugin-%{library} component
+
+License: BSD
+URL: https://zendframework.github.io/%{gh_project}/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-reflection
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5",
+# "zendframework/zend-coding-standard": "~1.0.0"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-filter) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-filter) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-form) >= 2.7 with php-autoloader(%{gh_owner}/zend-form) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-inputfilter) >= 2.8.1 with php-autoloader(%{gh_owner}/zend-inputfilter) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-mvc) >= 3.0 with php-autoloader(%{gh_owner}/zend-mvc) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-session) >= 2.8.5 with php-autoloader(%{gh_owner}/zend-session) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.6 with php-autoloader(%{gh_owner}/zend-validator) < 3)
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.4
+# remirepo:18
+%else
+BuildRequires: php-autoloader(%{gh_owner}/zend-filter) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-filter) >= 2.6.1
+BuildRequires: php-autoloader(%{gh_owner}/zend-form) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-form) >= 2.7
+BuildRequires: php-autoloader(%{gh_owner}/zend-inputfilter) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-inputfilter) >= 2.8.1
+BuildRequires: php-autoloader(%{gh_owner}/zend-mvc) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-mvc) >= 3.0
+BuildRequires: php-autoloader(%{gh_owner}/zend-session) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-session) >= 2.8.5
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.6
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
+%endif
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0",
+# "zendframework/zend-filter": "^2.6.1",
+# "zendframework/zend-form": "^2.7",
+# "zendframework/zend-inputfilter": "^2.8.1",
+# "zendframework/zend-mvc": "^3.0",
+# "zendframework/zend-session": "^2.8.5",
+# "zendframework/zend-stdlib": "^2.7 || ^3.0",
+# "zendframework/zend-validator": "^2.6"
+Requires: php(language) >= 5.6
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/zend-filter) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-filter) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-form) >= 2.7 with php-autoloader(%{gh_owner}/zend-form) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-inputfilter) >= 2.8.1 with php-autoloader(%{gh_owner}/zend-inputfilter) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-mvc) >= 3.0 with php-autoloader(%{gh_owner}/zend-mvc) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-session) >= 2.8.5 with php-autoloader(%{gh_owner}/zend-session) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.6 with php-autoloader(%{gh_owner}/zend-validator) < 3)
+# remirepo:16
+%else
+Requires: php-autoloader(%{gh_owner}/zend-filter) < 3
+Requires: php-autoloader(%{gh_owner}/zend-filter) >= 2.6.1
+Requires: php-autoloader(%{gh_owner}/zend-form) < 3
+Requires: php-autoloader(%{gh_owner}/zend-form) >= 2.7
+Requires: php-autoloader(%{gh_owner}/zend-inputfilter) < 3
+Requires: php-autoloader(%{gh_owner}/zend-inputfilter) >= 2.8.1
+Requires: php-autoloader(%{gh_owner}/zend-mvc) < 4
+Requires: php-autoloader(%{gh_owner}/zend-mvc) >= 3.0
+Requires: php-autoloader(%{gh_owner}/zend-session) < 3
+Requires: php-autoloader(%{gh_owner}/zend-session) >= 2.8.5
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+Requires: php-autoloader(%{gh_owner}/zend-validator) < 3
+Requires: php-autoloader(%{gh_owner}/zend-validator) >= 2.6
+%endif
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+# From phpcompatinfo report for version 1.0.0
+Requires: php-reflection
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Provides a Post-Redirect-Get controller plugin for zend-mvc versions 3.0
+and up, specifically for submissions that include file uploads.
+
+If you want a generic PRG plugin without file upload support, see zend-mvc-plugin-prg.
+
+* Issues at https://github.com/zendframework/zend-mvc-plugin-fileprg/issues
+* Documentation is at https://zendframework.github.io/zend-mvc-plugin-fileprg/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+: Generate autoloader
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Zend/Filter/autoload.php',
+ '%{php_home}/Zend/Form/autoload.php',
+ '%{php_home}/Zend/InputFilter/autoload.php',
+ '%{php_home}/Zend/Mvc/autoload.php',
+ '%{php_home}/Zend/Session/autoload.php',
+ '%{php_home}/Zend/Stdlib/autoload.php',
+ '%{php_home}/Zend/Validator/autoload.php',
+]);
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/Zend/Mvc/Plugin
+cp -pr src %{buildroot}%{php_home}/Zend/Mvc/Plugin/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/Zend/Mvc/Plugin/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\Mvc\\Plugin\\%{library}\\', dirname(__DIR__) . '/test');
+EOF
+
+ret=0
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{php_home}/Zend/Mvc/Plugin/%{library}
+
+
+%changelog
+* Thu May 3 2018 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+- use range dependencies on F27+
+- switch to phpunit6 or phpunit7
+- raise dependency on zend-inputfilter 2.8.1
+- raise dependency on zend-session 2.8.5
+
+* Wed Dec 13 2017 Remi Collet <remi@remirepo.net> - 1.0.0-4
+- switch from zend-loader to fedora/autoloader
+
+* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- initial package
+