summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-03 09:06:06 +0200
committerRemi Collet <remi@remirepo.net>2021-09-03 09:06:06 +0200
commitb38690674bc7ee3bc4940f623e224f6b53e59609 (patch)
tree7484857bc16ea956fbf47c4a85c315e2b7b01e32
parent9c872b844bca0adeffd4cac5a65cbcbc865dd295 (diff)
update to 2.9.0
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader
-rw-r--r--composer.json16
-rw-r--r--php-laminas-mime.spec22
2 files changed, 22 insertions, 16 deletions
diff --git a/composer.json b/composer.json
index 310b5bc..abd1869 100644
--- a/composer.json
+++ b/composer.json
@@ -19,13 +19,12 @@
"sort-packages": true
},
"require": {
- "php": "^7.3 || ~8.0.0",
- "laminas/laminas-stdlib": "^2.7 || ^3.0",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "php": "^7.3 || ~8.0.0 || ~8.1.0",
+ "laminas/laminas-stdlib": "^2.7 || ^3.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~1.0.0",
- "laminas/laminas-mail": "^2.6",
+ "laminas/laminas-coding-standard": "~2.2.1",
+ "laminas/laminas-mail": "^2.12",
"phpunit/phpunit": "^9.3"
},
"suggest": {
@@ -37,6 +36,9 @@
}
},
"autoload-dev": {
+ "files": [
+ "test/TestAsset/Mail/Headers.php"
+ ],
"psr-4": {
"LaminasTest\\Mime\\": "test/"
}
@@ -51,7 +53,7 @@
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zend-mime": "^2.7.2"
+ "conflict": {
+ "zendframework/zend-mime": "*"
}
}
diff --git a/php-laminas-mime.spec b/php-laminas-mime.spec
index afbac74..1b31747 100644
--- a/php-laminas-mime.spec
+++ b/php-laminas-mime.spec
@@ -8,7 +8,7 @@
#
# When build without laminas-mail
%global bootstrap 0
-%global gh_commit 9a59704f33106427a384d0ae421f96043174093a
+%global gh_commit 02cc861f704d468726866457dcf8338d1fe74e76
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mime
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.8.0
+Version: 2.9.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -36,15 +36,15 @@ BuildRequires: php-iconv
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
-# "laminas/laminas-mail": "^2.6",
+# "laminas/laminas-coding-standard": "~2.2.1",
+# "laminas/laminas-mail": "^2.12",
# "phpunit/phpunit": "^9.3"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
%if ! %{bootstrap}
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-mail) >= 2.6 with php-autoloader(%{gh_owner}/laminas-mail) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-mail) >= 2.12 with php-autoloader(%{gh_owner}/laminas-mail) < 3)
%endif
# remirepo:7
%else
@@ -61,9 +61,8 @@ BuildRequires: phpunit9 >= 9.3
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
-# "laminas/laminas-stdlib": "^2.7 || ^3.0",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "php": "^7.3 || ~8.0.0 || ~8.1.0",
+# "laminas/laminas-stdlib": "^2.7 || ^3.0"
Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -164,7 +163,7 @@ rm test/DecodeTest.php
: upstream test suite
ret=0
-for cmd in "php %{phpunit}" php73 php74 php80; do
+for cmd in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit9} \
@@ -191,6 +190,11 @@ exit $ret
%changelog
+* Fri Sep 3 2021 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
* Thu Feb 25 2021 Remi Collet <remi@remirepo.net> - 2.8.0-1
- update to 2.8.0
- raise dependency on PHP 7.3