summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-02-25 08:41:22 +0100
committerRemi Collet <remi@remirepo.net>2021-02-25 08:41:22 +0100
commit9c872b844bca0adeffd4cac5a65cbcbc865dd295 (patch)
tree2c247c90bd083d78a4c3e3c2f4d8fd5d1bdf68b6
parent6cf0705675726908fe337339355c4582224a2e30 (diff)
update to 2.8.0
raise dependency on PHP 7.3 switch to phpunit9
-rw-r--r--composer.json10
-rw-r--r--php-laminas-mime.spec31
2 files changed, 20 insertions, 21 deletions
diff --git a/composer.json b/composer.json
index c64388f..310b5bc 100644
--- a/composer.json
+++ b/composer.json
@@ -18,21 +18,15 @@
"config": {
"sort-packages": true
},
- "extra": {
- "branch-alias": {
- "dev-master": "2.7.x-dev",
- "dev-develop": "2.8.x-dev"
- }
- },
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"laminas/laminas-stdlib": "^2.7 || ^3.0",
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
"laminas/laminas-mail": "^2.6",
- "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20"
+ "phpunit/phpunit": "^9.3"
},
"suggest": {
"laminas/laminas-mail": "Laminas\\Mail component"
diff --git a/php-laminas-mime.spec b/php-laminas-mime.spec
index 0be6a82..afbac74 100644
--- a/php-laminas-mime.spec
+++ b/php-laminas-mime.spec
@@ -1,6 +1,6 @@
# remirepo/Fedora spec file for php-laminas-mime
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -8,7 +8,7 @@
#
# When build without laminas-mail
%global bootstrap 0
-%global gh_commit e45a7d856bf7b4a7b5bd00d6371f9961dc233add
+%global gh_commit 9a59704f33106427a384d0ae421f96043174093a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mime
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.7.4
+Version: 2.8.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -31,14 +31,14 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-iconv
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
# "laminas/laminas-mail": "^2.6",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20"
+# "phpunit/phpunit": "^9.3"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
@@ -54,17 +54,17 @@ BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-laminas-mail
%endif
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.5.20
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-stdlib": "^2.7 || ^3.0",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
@@ -89,7 +89,7 @@ Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
Obsoletes: php-zendframework-%{zf_name} < 2.7.3
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -164,10 +164,10 @@ rm test/DecodeTest.php
: upstream test suite
ret=0
-for cmd in "php %{phpunit}" php72 php73 php74; do
+for cmd in "php %{phpunit}" php73 php74 php80; do
if which $cmd; then
set $cmd
- $1 ${2:-%{_bindir}/phpunit7} \
+ $1 ${2:-%{_bindir}/phpunit9} \
%if %{bootstrap}
--filter '^((?!(testFromMessageDecode|testFromMessageMultiPart)).)*$' \
%endif
@@ -191,8 +191,13 @@ exit $ret
%changelog
+* Thu Feb 25 2021 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Mon Mar 30 2020 Remi Collet <remi@remirepo.net> - 2.7.4-1
-- update to 2.7.4
+- update to 2.7.4 (no change)
- not bootstrap build
* Fri Mar 6 2020 Remi Collet <remi@remirepo.net> - 2.7.3-1