summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-07 15:26:45 +0100
committerRemi Collet <remi@php.net>2021-12-07 15:26:45 +0100
commiteb6afff5f1b5893400aa73e28e7358f455299ea7 (patch)
tree6beba484e21dd6cc5fc74c20036a661f3b61e94c
parente7fbce553c35f44e424c8a5a30252386046638ff (diff)
update to 2.8.0
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader
-rw-r--r--composer.json7
-rw-r--r--php-laminas-memory.spec14
2 files changed, 12 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 9f75c21..e9bd8e2 100644
--- a/composer.json
+++ b/composer.json
@@ -19,8 +19,7 @@
"sort-packages": true
},
"require": {
- "php": "^7.3 || ~8.0.0",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "php": "^7.3 || ~8.0.0"
},
"require-dev": {
"laminas/laminas-cache": "^2.7",
@@ -50,7 +49,7 @@
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zend-memory": "^2.6.1"
+ "conflict": {
+ "zendframework/zend-memory": "*"
}
}
diff --git a/php-laminas-memory.spec b/php-laminas-memory.spec
index 2b9ebd2..d275e31 100644
--- a/php-laminas-memory.spec
+++ b/php-laminas-memory.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit a59d9750868b2c8441c69ddd2778fad863e0b413
+%global gh_commit 134db5ce89030fcdc0425c807d2382a340fb97df
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-memory
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.7.0
+Version: 2.8.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -56,8 +56,7 @@ BuildRequires: phpunit9 >= 9.3
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "php": "^7.3 || ~8.0.0"
Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -156,7 +155,7 @@ exit (class_exists("\\Zend\\%{library}\\Value") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -179,6 +178,11 @@ exit $ret
%changelog
+* Tue Dec 7 2021 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
* Thu Feb 25 2021 Remi Collet <remi@remirepo.net> - 2.7.0-1
- update to 2.7.0 (no change)
- raise dependency on PHP 7.3