summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-02-25 08:25:25 +0100
committerRemi Collet <remi@remirepo.net>2021-02-25 08:25:25 +0100
commite7fbce553c35f44e424c8a5a30252386046638ff (patch)
tree0845b60055705a419a839563096638f67b2471cc
parentc499aea410839bb67cf585a68e96132ceed0f9c7 (diff)
update to 2.7.0 (no change)
raise dependency on PHP 7.3 switch to phpunit9
-rw-r--r--composer.json12
-rw-r--r--php-laminas-memory.spec33
2 files changed, 22 insertions, 23 deletions
diff --git a/composer.json b/composer.json
index bd15d21..9f75c21 100644
--- a/composer.json
+++ b/composer.json
@@ -18,20 +18,14 @@
"config": {
"sort-packages": true
},
- "extra": {
- "branch-alias": {
- "dev-master": "2.6.x-dev",
- "dev-develop": "2.7.x-dev"
- }
- },
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
"laminas/laminas-cache": "^2.7",
"laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
+ "phpunit/phpunit": "^9.3"
},
"suggest": {
"laminas/laminas-cache": "To support swapping memory objects into and out of non-memory cache storage"
@@ -57,6 +51,6 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-memory": "self.version"
+ "zendframework/zend-memory": "^2.6.1"
}
}
diff --git a/php-laminas-memory.spec b/php-laminas-memory.spec
index 3c46fc9..2b9ebd2 100644
--- a/php-laminas-memory.spec
+++ b/php-laminas-memory.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-memory
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7d4f8a727b781f1acd5713b9667cdb6e42dbec17
+%global gh_commit a59d9750868b2c8441c69ddd2778fad863e0b413
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-memory
@@ -22,8 +22,8 @@
%endif
Name: php-%{gh_project}
-Version: 2.6.1
-Release: 2%{?dist}
+Version: 2.7.0
+Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
License: BSD
@@ -34,12 +34,12 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-spl
# From composer, "require-dev": {
# "laminas/laminas-cache": "^2.7",
# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
+# "phpunit/phpunit": "^9.3"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -49,16 +49,16 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.7
BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-laminas-cache
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.4
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -80,8 +80,8 @@ Requires: php-spl
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 2.6.1-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 2.6.2
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -156,10 +156,10 @@ exit (class_exists("\\Zend\\%{library}\\Value") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -179,6 +179,11 @@ exit $ret
%changelog
+* Thu Feb 25 2021 Remi Collet <remi@remirepo.net> - 2.7.0-1
+- update to 2.7.0 (no change)
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Fri Jan 17 2020 Remi Collet <remi@remirepo.net> - 2.6.1-2
- cleanup