summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-03-24 09:13:10 +0100
committerRemi Collet <remi@php.net>2022-03-24 09:13:10 +0100
commit6f5a88e011271b5e543f2bd0be355ad95cc689f5 (patch)
tree57dd5fbc9899d4aec62a21d474a902f9ba772138
parenteb6afff5f1b5893400aa73e28e7358f455299ea7 (diff)
update to 2.9.0
-rw-r--r--composer.json12
-rw-r--r--php-laminas-memory.spec17
2 files changed, 19 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index e9bd8e2..15972db 100644
--- a/composer.json
+++ b/composer.json
@@ -16,14 +16,18 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
},
"require": {
- "php": "^7.3 || ~8.0.0"
+ "php": "^7.4 || ~8.0.0 || ~8.1.0"
},
"require-dev": {
- "laminas/laminas-cache": "^2.7",
- "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-cache": "^3.0",
+ "laminas/laminas-cache-storage-adapter-memory": "^2.0",
+ "laminas/laminas-coding-standard": "~2.3.0",
"phpunit/phpunit": "^9.3"
},
"suggest": {
diff --git a/php-laminas-memory.spec b/php-laminas-memory.spec
index d275e31..1a065ce 100644
--- a/php-laminas-memory.spec
+++ b/php-laminas-memory.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-memory
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 134db5ce89030fcdc0425c807d2382a340fb97df
+%global gh_commit c5b51ba1958d55bceb5c79506fd7f25eef96156c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-memory
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.8.0
+Version: 2.9.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -37,12 +37,14 @@ BuildArch: noarch
BuildRequires: php(language) >= 7.3
BuildRequires: php-spl
# From composer, "require-dev": {
-# "laminas/laminas-cache": "^2.7",
-# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-cache": "^3.0",
+# "laminas/laminas-cache-storage-adapter-memory": "^2.0",
+# "laminas/laminas-coding-standard": "^2.0",
# "phpunit/phpunit": "^9.3"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# ignore minimal version
BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.7 with php-autoloader(%{gh_owner}/laminas-cache) < 3)
# remirepo:4
%else
@@ -56,7 +58,7 @@ BuildRequires: phpunit9 >= 9.3
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0"
+# "php": "^7.3 || ~8.0.0 || ~8.1.0"
Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -178,6 +180,9 @@ exit $ret
%changelog
+* Thu Mar 24 2022 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0
+
* Tue Dec 7 2021 Remi Collet <remi@remirepo.net> - 2.8.0-1
- update to 2.8.0
- keep compatibility using laminas-zendframework-bridge