summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-17 14:32:56 +0200
committerRemi Collet <remi@php.net>2022-10-17 14:32:56 +0200
commitbb6cbc22e9d697a9afbe24cda181a3aceb8f4b9e (patch)
treeb411795a08c10423756ca1561b760c4d8d0f3d79
parent95ec2dd882cb0d8c89fef977e3906df5b9b20191 (diff)
update to 3.6.0HEADmaster
raise dependency on PHP 8.0
-rw-r--r--composer.json11
-rw-r--r--php-laminas-math.spec24
2 files changed, 21 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index af1f8b9..69eb9a2 100644
--- a/composer.json
+++ b/composer.json
@@ -16,7 +16,10 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
},
"extra": {
"branch-alias": {
@@ -25,12 +28,12 @@
}
},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0",
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
"ext-mbstring": "*"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^9.5.5"
+ "laminas/laminas-coding-standard": "~2.4.0",
+ "phpunit/phpunit": "~9.5.25"
},
"suggest": {
"ext-bcmath": "If using the bcmath functionality",
diff --git a/php-laminas-math.spec b/php-laminas-math.spec
index 7487215..8c2b9e2 100644
--- a/php-laminas-math.spec
+++ b/php-laminas-math.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-math
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 146d8187ab247ae152e811a6704a953d43537381
+%global gh_commit 5770fc632a3614f5526632a8b70f41b65130460e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-math
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.5.0
+Version: 3.6.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.0
BuildRequires: php-mbstring
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -50,18 +50,18 @@ BuildRequires: php-spl
# test suite hangs without (need investigation)
BuildRequires: php-mcrypt
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^9.5.5"
+# "laminas/laminas-coding-standard": "~2.4.0",
+# "phpunit/phpunit": "^9.5.25"
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.5
+BuildRequires: phpunit9 >= 9.5.25
# Autoloader
BuildRequires: php-fedora-autoloader-devel
%endif
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "ext-mbstring": "*"
-Requires: php(language) >= 7.3
+Requires: php(language) >= 8.0
Requires: php-mbstring
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -153,7 +153,7 @@ if [ "$(id -un)" != "remi" ]; then
filter="--filter '^((?!(testRandFloat)).)*$'"
fi
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -185,6 +185,10 @@ exit $ret
%changelog
+* Mon Oct 17 2022 Remi Collet <remi@remirepo.net> - 3.6.0-1
+- update to 3.6.0
+- raise dependency on PHP 8.0
+
* Tue Dec 7 2021 Remi Collet <remi@remirepo.net> - 3.5.0-1
- update to 3.5.0 (no change)
- keep compatibility using laminas-zendframework-bridge